nrf51 problem



  • emm, i get nrf51 broad to run mysensor, but now i found a problem,when the battery low mcu always restart to connected mysensor gw,cause much Nack every senconds , and cause other normal sensor send data to gw Nack!
    so i add

    #define MY_NODE_ID 51  //Fallback NodeId
    #define MY_TRANSPORT_WAIT_READY_MS  2000
    #define MY_TRANSPORT_MAX_TSM_FAILURES 5
    #define MY_SLEEP_TRANSPORT_RECONNECT_TIMEOUT_MS 1000
    #define MY_TRANSPORT_UPLINK_CHECK_DISABLED
    #define MY_PARENT_NODE_IS_STATIC
    #define MY_PARENT_NODE_ID 0
    
    

    but also much Nack! Fortunately other sensor work well

    i don't know how to solve this problem ,did who know ? thanks!

    node 60 is low battery with 2.1v down , if i use more nrf51 sensor ,when power all low ,this also cuase gw No response for other normal sensor!

    alt text


  • Mod

    @huex are you using dc-dc mode or internal ldo? Dc-dc needs a minimum of 2.1V according to the nrf51822 datasheet.
    Which capacitors are you using? What type pf battery? Maybe the internal resistance of the battery makes the supply voltage drop too low?



  • @mfalkvidd thanks , yes i use dc-dc ,emm, i mean when this nrf51 node battery go to low 2.1V ,this cause much Nack influence other sensor node, so Is there any way to solve this problem?


  • Mod

    @huex in the log above, I only see nack for the messages sent to node 60. Isn't that the one with low power?



  • @mfalkvidd yes, i get six nrf51822-qfahh node, last wek i found 2 nrf51 nodes low power together ,the gw can't process other node any more ,all log is Nack! Very bad with this .....



  • @mfalkvidd OK, i resoved this problem with battery detect in void before ,thanks


 

175
Online

8.7k
Users

9.5k
Topics

99.9k
Posts