openHab 2.5.0 Message from Gateway ID 255



  • I have just upgraded my Docker based RPI Openhab to 2.5.6 and updated the jar to org.openhab.binding.mysensors-2.5.0-SNAPSHOT.jar

    Since I did this and tail the openhab log file I get this:

    2020-07-28 16:24:38.576 [DEBUG] [rsAbstractConnection$MySensorsReader] - Message from gateway received: 255;255;3;0;3;0
    2020-07-28 16:24:38.580 [INFO ] [rs.internal.gateway.MySensorsGateway] - ID Request received
    2020-07-28 16:24:38.588 [ERROR] [rs.internal.gateway.MySensorsGateway] - No more IDs available for this node, you could try cleaning cache file
    

    My Node:3 is a multi function, Humidity, Temp, Light, Rain and Barometric sensor. I believe 255 is used for some other comms as per the docs it is not recommended to be used for nodes. So why this being constantly logged, do I need to add a dummy node 255 or something?

    Oh and I have tried doing what it says and cleaning the cache file, I deleted both files in the userdata/logs/mysensors/cache and restarted my docker container.


  • Hero Member

    Please post the content of the given_ids.cached file. It is usally located within the /var/lib/openhab2/mysensors/cache/ directory.

    The error suggests that you have used all node ids from 1 to 253 and a new id is requested. The reason may also be a malfunctioning node that is requesting (continuously) an id although it already has one.



  • @TimO There is no given_ids.cached file - there is a given_ids_mysensors_bridge-eth_gateway.cached file and it contains:

    [0,1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20,21,22,23,24,25,26,27,28,29,30,31,32,33,34,35,36,37,38,39,40,41,42,43,44,45,46,47,48,49,50,51,52,53,54,55,56,57,58,59,60,61,62,63,64,65,66,67,68,69,70,71,72,73,74,75,76,77,78,79,80,81,82,83,84,85,86,87,88,89,90,91,92,93,94,95,96,97,98,99,100,101,102,103,104,105,106,107,108,109,110,111,112,113,114,115,116,117,118,119,120,121,122,123,124,125,126,127,128,129,130,131,132,133,134,135,136,137,138,139,140,141,142,143,144,145,146,147,148,149,150,151,152,153,154,155,156,157,158,159,160,161,162,163,164,165,166,167,168,169,170,171,172,173,174,175,176,177,178,179,180,181,182,183,184,185,186,187,188,189,190,191,192,193,194,195,196,197,198,199,200,201,202,203,204,205,206,207,208,209,210,211,212,213,214,215,216,217,218,219,220,221,222,223,224,225,226,227,228,229,230,231,232,233,234,235,236,237,238,239,240,241,242,243,244,245,246,247,248,249,250,251,252,253,254]

    I have fixed ID on all my nodes and have not changed anything for a long time.


  • Hero Member

    @itbeyond So my guess was right. The gateway and so the binding receives requests for ids. Do you see this message continuously in the log?

    You may stop the binding and connect via telnet to the gateway to rule out the binding. Are all your nodes running fine despite error? Or are there missing updates from nodes? Are there newly discovered nodes/things in Openhab?



  • @TimO thanks for the pointers. All my nodes were working ok but via a lot of playing around I found a repeater node that also runs a light dimmer (which the light dimmer worked fine and so did all of the repeating functions) was constantly sending an ID request. I disabled the repeater function and flashed it back and it is now not sending these requests. I then deployed another (better) repeater node into the same area and did not catch anymore ID requests so it would appear the repeater was causing the issue. I did flash it again with repeater on but it went bad again so gave that away and now have a different repeater serving that part of the property and no more weird ID requests. Thanks again for your help and continuing work on the binding.

    PS: Is there somewhere that we can always get the latest JAR files from, I find I have to troll posts to find links?


  • Hero Member

    @itbeyond I'm glad to hear you finally found the cause!

    The current jar is published via the download link on the wiki page: https://github.com/tobof/openhab2-addons/wiki/Installation

    And via eclipse marketplace. There is currently no active development, I only try to ensure the binding is running fine with the most current release of Openhab2.


Log in to reply
 

Suggested Topics

  • 16
  • 3
  • 3
  • 1
  • 2
  • 10
  • 22
  • 5

238
Online

9.8k
Users

10.3k
Topics

106.7k
Posts