Gateway USB and Gateway Ethernet



  • Hello,

    I have a little problem with my two Gateway my sensors.
    I have a USB Gateway and an Ethernet Gateway.
    The two Gateways work very well individually.
    When I have the two gateways in operation, there is always one of the two which is blocked and no longer communicates with Domoticz.
    I am not familiar with knots in Mysensor, and I think there is a problem with the knots.
    If you can help me find the solution.
    Daniel


  • Mod

    @Daniel-RUIZ9 could you post the domoticz log, and a picture of the hardware so we can see the settings for the gateways?

    What radios are you using? Are the radios on different channels?



  • Thank you for your help, because it is beyond my knowledge.

    2020-08-22_14h23_17.png
    2020-08-23_10h08_34.png
    2020-08-23_10h09_14.png
    2020-08-23_10h09_50.png
    2020-08-23_10h10_28.png

    I use this NRF24L01 radio

    I did not know that it was necessary to use different frequencies, I did not change anything, I used the Mysensors file without modification.

    Daniel


  • Mod

    @Daniel-RUIZ9 there can only be one gateway per MySensors network. You can create two MySensors networks by using different frequencies.



  • @mfalkvidd
    Sorry but I do not understand...
    Are you talking about the radio frequency of the NRF24L01?
    Could you give me a tutorial to use different frequencies.
    thank you


  • Mod

    @Daniel-RUIZ9 it depends a bit on what you are trying to achive.

    Could you tell us about your setup? How come you are using two gateways?



  • I am using a USB gateway for the sensors that are in the house. I have an outhouse far from home with an ethernet network. In this dependency I have sensors that are too far away for USB gateway.
    It is for this reason that I need this Ethernet gateway.
    Hopefully the GOOGLE translation of this post is understandable.
    Thanks again for your help.
    Daniel



  • I am attaching a diagram of the mysensor part of my installation.
    At the moment, I have the cellar's ethernet gateway working.
    The usb gateway also works but only towards the 4relais card which controls my 3D printer, The card which controls the mechanical ventilation of the ground floor no longer works.
    If I remove the cellar gateway The card that controls the mechanical ventilation of the ground floor works again.
    Daniel
    SCHEMA.jpg


  • Mod

    My guess is that the 4relais gets confused on which gateway to use. You could check thatby looking at the gateway debug output.

    If that's the case, you need to configure one of the two networks to use a different channel.

    Add

    #define MY_RF24_CHANNEL   (83)
    

    to the sketches of all nodes (including the gateway) of one of the network. Which one doesn't matter. I would choose the one with the fewest nodes, or where the nodes are easily accessible for reprogramming.

    The default channel is 76.



  • Thanks for your help, I'll do the test tomorrow.
    I make this modification in the gateway and in the relay card assigned to it

    modification ligne radio.png


  • Mod

    @Daniel-RUIZ9 great. Just to be clear: you need to add the new line. Keep the existing define without modification.



  • have followed your advice the two gateways are working properly together. I leave several days in the test to see if it holds up over time.
    I thank you for your help because alone I could not find the solution.


  • Mod

    Nice work @Daniel-RUIZ9. Thanks for reporting back.

    Helping rachother is the whole point of the forum. Everybody was a beginner once 🙂


Log in to reply
 

Suggested Topics

218
Online

9.6k
Users

10.2k
Topics

106.2k
Posts