Ethernet Gateway and Vera 3 on UI7

  • I had problems building a serial gateway for my Vera 3, so I ordered new stuff and have build a Ethernet Gateway using a Uno and W5100 Ethernet Shield. In the sketch I believe I set the right Ethernet (I'm new at this and don't really know what I'm doing) and I set the IP address to one that will work with my router. The thing that I think is the problem though is that the Vera 3 is on UI7.

    I have tried to downgrade to UI5, but it appears it is flagged for automatic upgrade. So I am trying to get it to work with UI7 but I'm having problems following the instructions which are based on UI5.

    Could there be anyone who could describe the actual process to get this working? I follow the instructions as far as when it says to press reload, but there is no reload button in UI7. The instructions I followed are :

    I'm probably missing something really simple... any help would be great 🙂

  • Looks like it is created in Vera!

    But something isn't right because I can't see the gateway as connected in my router settings, and vera is also saying there is a communication error.

    Any tips?

  • OK, to see what is going on, I have connected the Uno to my Macbook. The Uno was operating with the sketch that I had uploaded directly from Codebender, because every time I upload sketches from my mac using the Arduino program it never works...

    So I connect it to my mac, and and try again to upload the Ethernet Gateway sketch, but still no go; it is always asking for me to set this or that. Maybe I read wrong but I thought I only had to set which ethernet I was using, set the IP address and that's it. Anyways it verifies and uploads using Codebender, but I can never get that far locally.

    In all the reading that I've done, have I missed something? It does seem that way 😞

  • Now I am even more confused lol makes no reference to the IRQ pin on the radio, yet,23093.0.html does.

    Which one is right?

  • Ignore previous post. I saw somewhere that the IRQ pin is optional..... what I don't understand is when should it be used and when not....

    Anyways, I've worked out that uploading the sketches can be a bit of a hassle, depending on where you place stuff on your drive, so I'm just gonna stick with using Codebender.

    So I do to Codebender and I make sure the sketch is set to us the W5100 ethernet. I then go and change the port to something I'll remember and then set an IP address which is somewhere in my router's range; I then verify the sketch; all good. I then upload; all good.

    I plug the ethernet cord into the port and I power the Uno using 7.5 volt wall plug. I reboot my Vera 3. While I can't see in my router that the gateway is connected, I can ping it from my router, I think 🙂 This is what I get, which looks good to me lol
    **4 packets transmitted, 4 packets received, 0% packet loss
    round-trip min/avg/max = 0.298/0.483/0.918 ms **

    Now that I have confirmed that it is connected, I will try again to create the device in Vera 3.

  • Some good news!

    After pinging the Gateway, it now shows up as a connected device on my network!'

    I have rebooted Vera 3 and recreated the device. I might have some success; I was getting error messages about communication at the top of the Vera dashboard, and now I don't. BUT when I used to go to the devices page, there were buttons that showed which I could press to start inclusion, but they aren't there anymore. I do though have more settings for the device, which I think is good lol

  • Maybe more good news!

    I did some searching and found that not only do I have to set the IP address in Vera, but also the port. I tell you what, I do wish that all the info was in one place lol

    So I go back into Vera dashboard, and the buttons I was talking about are back woohoo, but I have less settings, but that might be ok. I dunno lol

    So I set the port number with the IP address and have rebooted again. In a moment I will check to see if it is working.. 🙂

  • While it looks like the gateway is connected, I am not sure...

    I build a relay sensor to operate my garage door, but couldn't get it to connect to the gateway. Thinking that it may be because it is too far away, I moved on to something else, and build a motion sensor. I sat it next to the gateway, and proceeded to connect the two following this : but nothing happened 😞

    Looks like I've spent another weekend not getting very far with this project 😞 Gotta pack it all up now coz it's getting late and I have a big week at work. Everything read as though this wouldn't be all that difficult, but it isn't proving to be the case. I have emailed the makers of Vera yesterday and have asked them to remove the flag off my device so I can downgrade the firmware, but I haven't heard anything from them 😞

  • Admin



  • @hek said:



    Yep. why?

  • Admin


    Noone has really fully verified the plugin in UI7. There might be problems with device-creation etc.

  • Yeah that does seem to be the case. But I have read that some were having success so I gave it a go anyways...

    I can't see me having much time for a while to give this another go, so i'll probably wait until i can roll back to UI5.

Suggested Topics