W5100 Gateway hangs /freezes after some time.



  • Thanx for your answer.

    That means, if I would use an raspberrypi as a gateway that could support devices?
    I would like to have only 1 gateway for each floor and I plan to have about 20 sensors connected to each gateway .

    Thanx.



  • @webstor said in W5100 Gateway hangs /freezes after some time.:

    Thanx for your answer.

    That means, if I would use an raspberrypi as a gateway that could support devices?
    I would like to have only 1 gateway for each floor and I plan to have about 20 sensors connected to each gateway .

    Thanx.

    Is there any benefit in using one GW for each floor? Imo it s best, to just have one MySensors network covering the entire building. To avoid problems wrt. to RF-coverage it is better to use some of the nodes also as repeater.

    As far as I understood, there is no limitation below 254 about the number of Nodes connected to one GW. Isn't the MAX_CLIENTS-definition targeting towards the maximum number of controllers to make use of the GW?

    Kind regards



  • yes there is. There is no signal getting through between the ground and the first floor.



  • OK, that's an argument.
    When starting with MySensors, I had similar problems, but using some caps and nrf+pa+lna-modules helped a lot. Keep in mind, you will also have some receiving problems if the distance on the same floor is to big...



  • Sorry but we are drifting away from the main problem.


  • Hero Member

    @webstor Are you confusing controllers with nodes ?

    comment out the line line

    #define MY_GATEWAY_MAX_CLIENTS 20
    
    

    and see if it still locks up.

    Your 20 nodes will still connect ok



  • Ok.
    I will try that when I come home from work.



  • Looks good. I will keep you up to date if the error appears again.

    Thanx.-



  • It stopped crashing.
    But the problems just switched.
    Only one device is communicating with the Gateway. The other devices aren't working anymore. My Relays and one temp and hum sensor are not communicating any more.

    And they are 5 meters away from the Gw.


  • Hero Member

    @webstor I am pretty sure that will be some other problem.

    as far as i am aware #define MY_GATEWAY_MAX_CLIENTS is not a setting for the number of nodes connected and is not needed in a standard Ethernet gateway with one controller, the default setting of 1 is all you need. I am running a w5100 gateway and am able to connect to multiple nodes without that line.

    If you un-comment it do your nodes then connect as per normal again?

    Maybe you could make a new post about #define MY_GATEWAY_MAX_CLIENTS and see if one of the MySensors devs can give a definite answer.

    Have you tried fitting a larger capacitor to the nrf power connections. When I updated to v2.1.1 I had two nodes that were usually very stable start to loose connection now and then. I replaced the 4.7uf with a 47uf and now they are working well again.



  • Hi,

    ok, starts to crash again. I replaced the whole hardware aswell.
    Yes if I uncomment them, the nodes connect normal.

    I'm not using v.2.1.1, my nodes and gateways are on v.2.0.0

    The next step will be to use an esp8266 as gateway instead of the arduino uno.

    Thanx.



  • I upgraded to 2.1.1 and I keep testing.



  • Ok, running on 2.1.1 and commented out the following lines:

    #define MY_GATEWAY_MAX_CLIENTS 20
    

    and

    //#define MY_INCLUSION_BUTTON_FEATURE
    

    is running now for three days and looks good that it will keep it that way.

    thanx guys.


Log in to reply
 

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.