building the Ethernet gateway



  • Hellow there I'm new to mysensors and I'm trying to create the Ethernet gateway.

    I use the following products:

    • Nano V3.0 ATmega328P 5V
    • list itemKeyestudio W5100_POE_PiA Netwerk Module
    • NRF24L01+PA+LNA 1100-meter long-distance

    I was not be able to following the wiring structure because the W5100 has a differend pin Layout. I found the following picture and connect the W5100 as described:

    http://arduino-info.wikispaces.com/Ethernet

    I did follow the guide but I can't get it working, I'm not able to get an IP address. I did test the Nano, with the "blink" script this is working so this should be fine.

    Script:

    /**
     * The MySensors Arduino library handles the wireless radio link and protocol
     * between your home built sensors/actuators and HA controller of choice.
     * The sensors forms a self healing radio network with optional repeaters. Each
     * repeater and gateway builds a routing tables in EEPROM which keeps track of the
     * network topology allowing messages to be routed to nodes.
     *
     * Created by Henrik Ekblad <henrik.ekblad@mysensors.org>
     * Copyright (C) 2013-2015 Sensnology AB
     * Full contributor list: https://github.com/mysensors/Arduino/graphs/contributors
     *
     * Documentation: http://www.mysensors.org
     * Support Forum: http://forum.mysensors.org
     *
     * This program is free software; you can redistribute it and/or
     * modify it under the terms of the GNU General Public License
     * version 2 as published by the Free Software Foundation.
     *
     *******************************
     *
     * REVISION HISTORY
     * Version 1.0 - Henrik EKblad
     * Contribution by a-lurker and Anticimex,
     * Contribution by Norbert Truchsess <norbert.truchsess@t-online.de>
     * Contribution by Tomas Hozza <thozza@gmail.com>
     *
     *
     * DESCRIPTION
     * The EthernetGateway sends data received from sensors to the ethernet link.
     * The gateway also accepts input on ethernet interface, which is then sent out to the radio network.
     *
     * The GW code is designed for Arduino 328p / 16MHz.  ATmega168 does not have enough memory to run this program.
     *
     * LED purposes:
     * - To use the feature, uncomment MY_DEFAULT_xxx_LED_PIN in the sketch below
     * - RX (green) - blink fast on radio message recieved. In inclusion mode will blink fast only on presentation recieved
     * - TX (yellow) - blink fast on radio message transmitted. In inclusion mode will blink slowly
     * - ERR (red) - fast blink on error during transmission error or recieve crc error
     *
     * See http://www.mysensors.org/build/ethernet_gateway for wiring instructions.
     *
     */
    
    // Enable debug prints to serial monitor
    #define MY_DEBUG
    
    // Enable and select radio type attached
    #define MY_RADIO_NRF24
    //#define MY_RADIO_RFM69
    
    // Enable gateway ethernet module type
    #define MY_GATEWAY_W5100
    
    // W5100 Ethernet module SPI enable (optional if using a shield/module that manages SPI_EN signal)
    //#define MY_W5100_SPI_EN 4
    
    // Enable Soft SPI for NRF radio (note different radio wiring is required)
    // The W5100 ethernet module seems to have a hard time co-operate with
    // radio on the same spi bus.
    #if !defined(MY_W5100_SPI_EN) && !defined(ARDUINO_ARCH_SAMD)
    #define MY_SOFTSPI
    #define MY_SOFT_SPI_SCK_PIN 14
    #define MY_SOFT_SPI_MISO_PIN 16
    #define MY_SOFT_SPI_MOSI_PIN 15
    #endif
    
    // When W5100 is connected we have to move CE/CSN pins for NRF radio
    #ifndef MY_RF24_CE_PIN
    #define MY_RF24_CE_PIN 5
    #endif
    #ifndef MY_RF24_CS_PIN
    #define MY_RF24_CS_PIN 6
    #endif
    
    // Enable to UDP
    //#define MY_USE_UDP
    
    //#define MY_IP_ADDRESS 192,168,0,199   // If this is disabled, DHCP is used to retrieve address
    // Renewal period if using DHCP
    //#define MY_IP_RENEWAL_INTERVAL 60000
    // The port to keep open on node server mode / or port to contact in client mode
    #define MY_PORT 5003
    
    // Controller ip address. Enables client mode (default is "server" mode).
    // Also enable this if MY_USE_UDP is used and you want sensor data sent somewhere.
    //#define MY_CONTROLLER_IP_ADDRESS 192, 168, 178, 254
    
    // The MAC address can be anything you want but should be unique on your network.
    // Newer boards have a MAC address printed on the underside of the PCB, which you can (optionally) use.
    // Note that most of the Ardunio examples use  "DEAD BEEF FEED" for the MAC address.
    #define MY_MAC_ADDRESS 0xDE, 0xAD, 0xBE, 0xEF, 0xFE, 0xED
    
    // Enable inclusion mode
    #define MY_INCLUSION_MODE_FEATURE
    // Enable Inclusion mode button on gateway
    //#define MY_INCLUSION_BUTTON_FEATURE
    // Set inclusion mode duration (in seconds)
    #define MY_INCLUSION_MODE_DURATION 60
    // Digital pin used for inclusion mode button
    //#define MY_INCLUSION_MODE_BUTTON_PIN  3
    
    // Set blinking period
    #define MY_DEFAULT_LED_BLINK_PERIOD 300
    
    // Flash leds on rx/tx/err
    // Uncomment to override default HW configurations
    //#define MY_DEFAULT_ERR_LED_PIN 7  // Error led pin
    //#define MY_DEFAULT_RX_LED_PIN  8  // Receive led pin
    //#define MY_DEFAULT_TX_LED_PIN  9  // Transmit led pin
    
    
    #if defined(MY_USE_UDP)
    #include <EthernetUdp.h>
    #endif
    #include <Ethernet.h>
    #include <MySensors.h>
    
    
    void setup()
    {
    }
    
    void loop()
    {
    

    please help...

    Thank you in advance,


  • Mod

    Welcome to the MySensors community @evertos !

    I took the liberty to add the code markup for the sketch. This makes it much easier to read here in the forum. Please use it next time.

    The wiring looks good.

    Could you post the serial debug output?



  • @evertos I can't help but notice there is no code in your setup or loop.


  • Mod

    @Terrence for gateway you don't need code in setup and loop



  • @gohan Thank you for pointing that out. Just getting started in MS.



  • Hi!

    Thank you all for the fast response, I'm in the middle of buying a house so I will test this as soon as possible.

    Thank you for the response!



  • Good afternoon all,

    I did some more testing and finally, got an IP address and I'm able to ping the gateway, but it looks like that the gateway keeps restarting.

    I'm using OpenHab to communicate, and OpenHab is not been able to get the Gateway version.

    Did some one got the same version (2.1.1 ) Up and running with OpenHab?

    Thank you in advance,

    Evert

    Serial Gateway Log

    ##0;255;3;0;9;MCO:BGN:INIT GW,CP=RNNGA--,VER=2.1.1 
    
    0;255;3;0;9;TSM:INIT 
    
    0;255;3;0;9;TSF:WUR:MS=0 
    
    0;255;3;0;9;TSM:INIT:TSP OK 
    
    0;255;3;0;9;TSM:INIT:GW MODE 
    
    0;255;3;0;9;TSM:READY:ID=0,PAR=0,DIS=0 
    
    0;255;3;0;9;MCO:REG:NOT NEEDED 
    
    IP: 192.168.0.201 
    
    0;255;3;0;9;MCO:BGN:INIT OK,TSP=1 
    
    0;255;3;0;9;Eth: connect 
    
    0;255;3;0;9;MCO:BGN:INIT GW,CP=RNNGA--,VER=2.1.1 
    
    0;255;3;0;9;TSM:INIT 
    
    0;255;3;0;9;TSF:WUR:MS=0 
    
    0;255;3;0;9;TSM:INIT:TSP OK 
    
    0;255;3;0;9;TSM:INIT:GW MODE 
    
    0;255;3;0;9;TSM:READY:ID=0,PAR=0,DIS=0 
    
    0;255;3;0;9;MCO:REG:NOT NEEDED 
    
    IP: 192.168.0.201 
    
    0;255;3;0;9;MCO:BGN:INIT OK,TSP=1 
    
    0;255;3;0;9;Eth: connect 
    
    0;255;3;0;9;MCO:BGN:INIT GW,CP=RNNGA--,VER=2.1.1 
    
    0;255;3;0;9;TSM:INIT 
    
    0;255;3;0;9;TSF:WUR:MS=0 
    
    0;255;3;0;9;TSM:INIT:TSP OK 
    
    0;255;3;0;9;TSM:INIT:GW MODE 
    
    0;255;3;0;9;TSM:READY:ID=0,PAR=0,DIS=0 
    
    0;255;3;0;9;MCO:REG:NOT NEEDED 
    
    IP: 192.168.0.201 
    
    0;255;3;0;9;MCO:BGN:INIT OK,TSP=1 
    
    0;255;3;0;9;Eth: connect
    

  • Contest Winner

    @evertos

    I had the restart problem, and tried the advice here regarding the Arduino IDE's Board Manager.



  • Thank you for all the answers just got the INternet Gateway working

    Just downgrade the Arduino IDE to: 1.6.8. (Arduino program)

    Als for other beginners, as soon as you upload an "Mysensors", switch to 11520 baund on the Serial Monitor.

    I did test my cheap Arduino clone with the basic ethernet script and this is using another baund on the serial monitor. I know it is stupid but this also cost me a couple of nights before I realize that this was my first problem.

    Thank you all for the answers!


  • Mod

    If you set the default baud rate in myconfig.h you should have all sensors and gateway running the same (of course you don't have to specify it in the sketch)



  • Hi All,

    for the mysensors the gateway i decided also to give a try with ENC28J60 Ethernet module, RF24 and arduino nano.

    The code i used is:

    // Enable debug prints to serial monitor
    #define MY_DEBUG 
    
    // Enable and select radio type attached
    #define MY_RADIO_RF24
    #define MY_RF24_PA_LEVEL RF24_PA_MAX
    
    // When ENC28J60 is connected we have to move CE/CSN pins for NRF radio
    #define MY_RF24_CE_PIN 5
    #define MY_RF24_CS_PIN 6
    
    // Enable gateway ethernet module type 
    #define MY_GATEWAY_ENC28J60
    
    // Gateway IP address
    #define MY_IP_ADDRESS 192,168,80,9  
    #define MY_IP_GATEWAY_ADDRESS 192,168,80,1
    #define MY_IP_SUBNET_ADDRESS 255,255,255,0
    
    // The MAC address can be anything you want but should be unique on your network.
    // Newer boards have a MAC address printed on the underside of the PCB, which you can (optionally) use.
    // Note that most of the Ardunio examples use  "DEAD BEEF FEED" for the MAC address.
    #define MY_MAC_ADDRESS 0x00, 0x40, 0xFD, 0xEF, 0x35, 0x70
    
    // The port to keep open on node server mode / or port to contact in client mode
    #define MY_PORT 5003   
    
    // Controller ip address. Enables client mode (default is "server" mode). 
    // Also enable this if MY_USE_UDP is used and you want sensor data sent somewhere. 
    //#define MY_CONTROLLER_IP_ADDRESS 192, 168, 80, 4 
    
    // If MQTT, uncomment the follwoing:
    //#define MY_GATEWAY_MQTT_CLIENT
    //#define MY_MQTT_CLIENT_ID "mysnsg1"
    //#define MY_MQTT_USER "admin"
    //#define MY_MQTT_PASSWORD "bucleta01"
    // MQTT broker ip address or url. Define one or the other.
    //#define MY_CONTROLLER_URL_ADDRESS "mysnsg1.wollny.com.br"
    //#define MY_CONTROLLER_IP_ADDRESS 192, 168, 80, 4
    // The MQTT broker port to to open
    //#define MY_PORT 1883
    // Set this node's subscribe and publish topic prefix
    //#define MY_MQTT_PUBLISH_TOPIC_PREFIX "mysnsg1-out"
    //#define MY_MQTT_SUBSCRIBE_TOPIC_PREFIX "mysnsg1-in"  
    
    // Flash leds on rx/tx/err
    // Set blinking period
    #define MY_DEFAULT_LED_BLINK_PERIOD 300
    
    // Enable inclusion mode
    #define MY_INCLUSION_MODE_FEATURE
    // Enable Inclusion mode button on gateway
    #define MY_INCLUSION_BUTTON_FEATURE
    // Set inclusion mode duration (in seconds)
    #define MY_INCLUSION_MODE_DURATION 60 
    // Digital pin used for inclusion mode button
    #define MY_INCLUSION_MODE_BUTTON_PIN  3 
    
    #define MY_DEFAULT_ERR_LED_PIN 7  // Error led pin
    #define MY_DEFAULT_RX_LED_PIN  8  // Receive led pin
    #define MY_DEFAULT_TX_LED_PIN  9  // the PCB, on board LED
    
    #include <SPI.h>
    #include <UIPEthernet.h>
    #include <MySensors.h>
    
    
    void setup()
    {
    }
    
    void loop() {
    }
    

    on the monitor, i read:

    0 MCO:BGN:INIT GW,CP=RNNGA---,FQ=16,REL=255,VER=2.3.2
    4 TSM:INIT0 MCO:BGN:INIT GW,CP=RNNGA---,FQ=16,REL=255,VER=2.3.2
    4 TSM:INIT
    5 TSF:WUR:MS=0
    12 TSM:INIT:TSP OK
    13 TSM:INIT:GW MODE
    15 TSM:READY:ID=0,PAR=0,DIS=0
    18 MCO:REG:NOT NEEDED
    71 GWT:TIN:IP=192.168.80.9
    1074 MCO:BGN:STP
    1075 MCO:BGN:INIT OK,TSP=1
    1078 TSM:READY:NWD REQ
    1083 ?TSF:MSG:SEND,0-0-255-255,s=255,c=3,t=20,pt=0,l=0,sg=0,ft=0,st=OK:
    0 MCO:BGN:INIT GW,CP=RNNGA---,FQ=16,REL=255,VER=2.3.2
    4 TSM:INIT
    5 TSF:WUR:MS=0
    12 TSM:INIT:TSP OK
    13 TSM:INIT:GW MODE
    15 TSM:READY:ID=0,PAR=0,DIS=0
    18 MCO:REG:NOT NEEDED
    71 GWT:TIN:IP=192.168.80.9
    1074 MCO:BGN:STP
    1075 MCO:BGN:INIT OK,TSP=1
    1078 TSM:READY:NWD REQ
    1083 ?TSF:MSG:SEND,0-0-255-255,s=255,c=3,t=20,pt=0,l=0,sg=0,ft=0,st=OK:
    13182 GWT:TSA:ETH OK
    13190 GWT:RFC:MSG=0;255;3;0;2;
    23293 GWT:RFC:MSG=0;255;3;0;2;
    33400 GWT:RFC:MSG=0;255;3;0;2;
    43508 GWT:RFC:MSG=0;255;3;0;2;
    53615 GWT:RFC:MSG=0;255;3;0;2;
    63723 GWT:RFC:MSG=0;255;3;0;2;
    73830 GWT:RFC:MSG=0;255;3;0;2;
    83937 GWT:RFC:MSG=0;255;3;0;2;
    94044 GWT:RFC:MSG=0;255;3;0;2;
    104153 GWT:RFC:MSG=0;255;3;0;2;
    114259 GWT:RFC:MSG=0;255;3;0;2;
    124366 GWT:RFC:MSG=0;255;3;0;2;
    134474 GWT:RFC:MSG=0;255;3;0;2;
    144581 GWT:RFC:MSG=0;255;3;0;2;
    154689 GWT:RFC:MSG=0;255;3;0;2;
    164798 GWT:RFC:MSG=0;255;3;0;2;
    174905 GWT:RFC:MSG=0;255;3;0;2;
    185013 GWT:RFC:MSG=0;255;3;0;2;
    195324 GWT:RFC:MSG=0;255;3;0;2;
    205228 GWT:RFC:MSG=0;255;3;0;2;
    215334 GWT:RFC:MSG=0;255;3;0;2;
    225441 GWT:RFC:MSG=0;255;3;0;2;
    235549 GWT:RFC:MSG=0;255;3;0;2;
    245657 GWT:RFC:MSG=0;255;3;0;2;
    255970 GWT:RFC:MSG=0;255;3;0;2;
    265872 GWT:RFC:MSG=0;255;3;0;2;
    275980 GWT:RFC:MSG=0;255;3;0;2;
    286088 GWT:RFC:MSG=0;255;3;0;2;
    296196 GWT:RFC:MSG=0;255;3;0;2;
    306302 GWT:RFC:MSG=0;255;3;0;2;
    316411 GWT:RFC:MSG=0;255;3;0;2;
    326518 GWT:RFC:MSG=0;255;3;0;2;
    336625 GWT:RFC:MSG=0;255;3;0;2;
    346733 GWT:RFC:MSG=0;255;3;0;2;
    357048 GWT:RFC:MSG=0;255;3;0;2;
    366948 GWT:RFC:MSG=0;255;3;0;2;
    377056 GWT:RFC:MSG=0;255;3;0;2;
    387163 GWT:RFC:MSG=0;255;3;0;2;
    397270 GWT:RFC:MSG=0;255;3;0;2;
    407377 GWT:RFC:MSG=0;255;3;0;2;
    417485 GWT:RFC:MSG=0;255;3;0;2;
    427592 GWT:RFC:MSG=0;255;3;0;2;
    437701 GWT:RFC:MSG=0;255;3;0;2;
    447807 GWT:RFC:MSG=0;255;3;0;2;
    457916 GWT:RFC:MSG=0;255;3;0;2;
    468024 GWT:RFC:MSG=0;255;3;0;2;
    478131 GWT:RFC:MSG=0;255;3;0;2;
    488238 GWT:RFC:MSG=0;255;3;0;2;
    498345 GWT:RFC:MSG=0;255;3;0;2;
    

    for testing, i installed also mycontroller, but seams there is no interaction.

    also trying to make it dhcp (commenting out the ip line), does not work (complie error).

    beside that, disconnecting the usb cabe makes it becomes unresponsive to ping, even powered and connected to the ethernet cable.

    Home Assistant Core also does not connect to it.

    Thx in advance for any help.


  • Mod

    If someone tries to help @pw44, please respond in https://forum.mysensors.org/topic/11213/mysensor-gateway-with-enc28j60-ethernet-doubts to avoid confusion and double work.


Log in to reply
 

Suggested Topics

  • 2
  • 5
  • 3
  • 12
  • 5
  • 6
  • 14
  • 22

166
Online

9.5k
Users

10.1k
Topics

105.0k
Posts