Gateway with Nokia 5110 LCD ??



  • Hi All,
    i been working on moving my wired smart heating to wireless using mysensors, so far so good with few issues to fix but that is work in progress.
    reason of my this post to make gateway little bit more then just something blind piece of hardware with no status (apart from rx/tx and error led), how about nokia 5110 lcd? To show some general info i.e. ip address, connected client, in/out messages. Just wondering has any one done this ?


  • Mod

    As a matter of fact, you could connect any display you want, but still I don't see the real benefits as the small screen will be pretty much useless with the few lines available



  • ok if does not please you then lets get 3.5" TFT screen.....


  • Mod

    Don't get me wrong, I don't see the benefit, maybe you can: I don't see it because my gw/controller is not easily accessible and if I want to know what is going on I can just look at the controller's dashboard from any device. That said you can connect any display you like to show the info you want, given of course that you do some coding to write data on the display



  • when it comes to basic troubleshooting there is nothing gateway tells me, i.e. controller connected or not, network connected or not etc... and its not very easy to connect gateway to computer to check what is going on.


  • Mod

    it depends a lot on what kind of gateway you have


  • Mod



  • just to give you background of this, i have rpi based heating systems that i built and its working fine 99% but its all wires system temperature sensors are wired, relay for zone wired, relay for boiler wired, now i want to make this all wireless.

    to make it wireless i m using mysensors and i have done all ground work done and it all works fine apart from
    i. relay nodes are very unpredictable
    ii. if i reboot my wifi router my gateway do not try to re-connect i have to press re-set button to get it connected to wifi.

    hence i thought what if i have small little screen or tft on gateway that can tell me what is going on. i m testing wifi gateway but probably same goes to Ethernet gateway.

    Here is my project that i m working on and trying to publish it PiHome


Log in to reply
 

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.