Raspberry pi nrf2401 arduino nrf2401



  • I Have Configured a raspberry pi as Gateway to recieve by a nrf2401 mqtt and domoticz controller.
    i also have a arduino uno configured with the motion sensor example of my sensors and a nrf2401 connected to it. both nrf2401 have a capicitor on the vcc and gnd.
    Both nrf2401 are configured to work on channel 1.
    The problem is that the nrf2401 will nor pare with each other.
    Part of the logging of the arduino is.

    0 MCO:BGN:INIT NODE,CP=RNNNA--,VER=2.1.1
    3 TSM:INIT
    4 TSF:WUR:MS=0
    5 RF24:INIT Ce_PIN =9 logging aded by my to check pins
    7 RF24:INIT Cs_PIN =10 logging aded by my to check pins
    9 RF24:write register, reg=0, value=14
    18 RF24:write register, reg=3, value=3
    21 RF24:write register, reg=4, value=95
    24 RF24:write register, reg=5, value=1
    28 RF24:INIT Channel =1 logging aded by my to to check channel
    30 RF24:write register, reg=6, value=39
    33 RF24:write register, reg=16, value=115
    37 RF24:write register, reg=29, value=6
    41 RF24:read register, reg=6, value=39
    45 RF24:read register, reg=5, value=1
    48 RF24:write register, reg=2, value=2
    52 RF24:write register, reg=1, value=0
    55 RF24:write register, reg=28, value=3
    59 RF24:flushRX
    60 RF24:flushTX
    62 RF24:write register, reg=7, value=112
    65 TSM:INIT:TSP OK
    67 TSM:FPAR
    68 RF24:STP LIS
    70 RF24:write register, reg=0, value=14
    73 RF24:OPEN WPIPE,RCPT=255
    76 RF24:write register, reg=10, value=255
    79 RF24:write register, reg=16, value=255
    83 RF24:SND:TO=255,LEN=7
    86 RF24:flushTX
    88 RF24:write register, reg=7, value=48
    92 RF24:STRT LIS
    93 RF24:write register, reg=0, value=15
    97 TSF:MSG:SEND,255-255-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    103 RF24:read register, reg=23, value=17
    many times
    913692 RF24:read register, reg=23, value=17
    913696 TSM:ID
    913698 TSM:ID:REQ
    913699 RF24:STP LIS
    913701 RF24:write register, reg=0, value=14
    913705 RF24:OPEN WPIPE,RCPT=0
    913709 RF24:write register, reg=10, value=0
    913713 RF24:write register, reg=16, value=0
    913717 RF24:SND:TO=0,LEN=7
    913719 RF24:flushTX
    913722 RF24:write register, reg=7, value=48
    913726 RF24:STRT LIS
    913728 RF24:write register, reg=0, value=15
    913732 TSF:MSG:SEND,255-255-0-0,s=255,c=3,t=3,pt=0,l=0,sg=0,ft=0,st=OK:
    Many times
    913738 RF24:read register, reg=23, value=17

    278859 !TSM:ID:FAIL
    278861 TSM:FAIL:CNT=7
    278863 TSM:FAIL:PDT
    278865 RF24:write register, reg=0, value=12
    278870 RF24:PD

    logging og mysqw generated by the -d parameter

    mysgw: TSF:MSG:BC
    mysgw: TSF:MSG:FPAR REQ,ID=255
    mysgw: TSF:PNG:SEND,TO=0
    mysgw: TSF:CKU:OK
    mysgw: TSF:MSG:GWL OK
    mysgw: TSF:MSG:SEND,0-0-255-255,s=255,c=3,t=8,pt=1,l=1,sg=0,ft=0,st=OK:0
    mysgw: TSF:MSG:READ,255-255-0,s=255,c=3,t=3,pt=0,l=0,sg=0:
    mysgw: Sending message on topic: mysensors-out/255/255/3/0/3
    mysgw: TSF:MSG:READ,255-255-0,s=255,c=3,t=3,pt=0,l=0,sg=0:
    mysgw: Sending message on topic: mysensors-out/255/255/3/0/3
    mysgw: TSF:MSG:READ,255-255-0,s=255,c=3,t=3,pt=0,l=0,sg=0:
    mysgw: Sending message on topic: mysensors-out/255/255/3/0/3
    mysgw: TSF:MSG:READ,255-255-0,s=255,c=3,t=3,pt=0,l=0,sg=0:
    mysgw: Sending message on topic: mysensors-out/255/255/3/0/3
    mysgw: TSF:MSG:READ,255-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0:
    mysgw: TSF:MSG:BC
    mysgw: TSF:MSG:FPAR REQ,ID=255
    mysgw: TSF:PNG:SEND,TO=0
    mysgw: TSF:CKU:OK
    mysgw: TSF:MSG:GWL OK
    mysgw: TSF:MSG:SEND,0-0-255-255,s=255,c=3,t=8,pt=1,l=1,sg=0,ft=0,st=OK:0
    mysgw: TSF:MSG:READ,255-255-0,s=255,c=3,t=3,pt=0,l=0,sg=0:
    mysgw: Sending message on topic: mysensors-out/255/255/3/0/3

    mysgw is configured

    ./configure --my-transport=nrf24 --my-rf24-irq-pin=15 --my-gateway=mqtt --my-controller-ip-address=127.0.0.1 --my-mqtt-publish-topic-prefix=mysensors-out --my-mqtt-subscribe-topic-prefix=mysensors-in --my-mqtt-client-id=mygateway1 --my-leds-err-pin=12 --my-leds-rx-pin=16 --my-leds-tx-pin=18 --my-debug=enable --my-rf24-pa-level=RF24_PA_MAX --my-rf24-channel=1 --my-rf24-ce-pin=24 --my-rf24-cs-pin=26

    the raspberry is build like stated on the website of my sensors

    Watch the ce and cs pins there are configured on the raspberry like as configured in the configure command.

    I also have the leds connected to the raspberry pi as stated in the https://www.mysensors.org/build/raspberry#test. The leds for tx/rx are flashing on the raspberry pi so i think the raspbaeery pi is recieving something. I have nothing configured in domoticz.

    Btw i think there some error in the pin configuration of the raspberry py. In the table the pins for ce and cs are different as there are in the picture of the raspberry pi.

    I hope that someone can point me in the right direction to get it to work.



  • @Johandelange What value are your capacitors on your nRF24L01 radios?


  • Mod

    @Johandelange the radio communication is working fine on both node (indicated by st=OK).

    The log says that the node does not get an ID from the controller.

    To my knowledge, auto id assignment is not supported when using Domoticz and mqtt. Defining a node id on the Uno should get everyhting going.

    #define MY_NODE_ID 42
    

    This needs to be done before the line that includes MySensors.h



  • @mfalkvidd That did the trick Thanks a lot



  • @dbemowsk the values of the capacitors are 47 uf. Vcc is from a voltage regulator of 3,3 volt feed by the +5 volt of the arduino or/and raspberry pi. There are no dips and just a little noise.



  • @Johandelange I didn't look closely enough at the logs, but I think @mfalkvidd may be right. You may need to assign the node IDs manually in your code if you are using MQTT. The 47uf capacitors might be a little high, but may still work fine. On my radio nodes I typically use 4.7uf, but your situation could be different. It does seem to be working for you.


 

385
Online

7.6k
Users

8.5k
Topics

91.3k
Posts