Mysensors gateway (v2.2.0) keeps rebooting



  • Recently I updated my MySensors gateway (ESP8266) to version 2.2.0. Perhaps i didn't noticed it while i used the older version, but because i updated it I noticed that the gateway is rebooting regularly. Still my sensors are working fine. I am using Domoticz as controler (latest beta)

    2018-06-09 12:26:03.657 MySensors: Gateway Ready...
    2018-06-09 12:26:03.657 Status: MySensors: Node: 0, Sketch Name: Gateway beneden
    2018-06-09 12:26:03.658 Status: MySensors: Node: 0, Sketch Version: 1.0
    2018-06-09 12:26:04.659 MySensors: Gateway Version: 2.2.0
    2018-06-09 12:31:05.692 MySensors: Gateway Ready...
    2018-06-09 12:31:05.692 Status: MySensors: Node: 0, Sketch Name: Gateway beneden
    2018-06-09 12:31:05.693 Status: MySensors: Node: 0, Sketch Version: 1.0
    2018-06-09 12:31:06.693 MySensors: Gateway Version: 2.2.0 
    

    Any ideas to narrow down this issue? I already tried several different radio's, but i don't have spare ESP8266 boards lying around


  • Mod

    @mister_ik are you sure the gateway is rebooting? The log you posted looks like a Domoticz log, and shows Domoticz (re)connecting to the gateway every 5 minutes.

    The debug log from the gateway will probably give better information on what is happening on the gateway.

    You could also check if you have configured a data timeout (for the gateway hardware) in Domoticz.



  • Maybe you can add a publish statement, that sends a message when it has been reset? Then you are sure what happens.

    What board version for the ESP8266 are you using? I used 2.4.1 for a while but that didn't work for me and I switched back to 2.3.0

    I've also posted an issue with the ESP8266 gateway (https://forum.mysensors.org/topic/9422/long-cycle-times-mqtt-gateway), do you experience that issue as well? If you want I can share the code I used to measure this.



  • @mfalkvidd I never thought of that, but that could indeed be the case. In domoticz there is no data timeout configured. So still cant explain why domoticz is reconnecting.

    @electrik i am not using MQTT with the gateway. I use still the 2.3.0 board.


 

375
Online

7.8k
Users

8.7k
Topics

93.1k
Posts