arduino ide says unable to compile on arduino what should i do




  • Mod

    @jasxvii how about posting the error message, with information about which arduino you are trying to use, which board version you have installed and which version of the Arduino IDE you are using?



  • @mfalkvidd i am using v 1.8.9



  • @jasxvii Arduino: 1.8.9 (Windows Store 1.8.21.0) (Windows 10), Board: "Arduino Pro or Pro Mini, ATmega328P (5V, 16 MHz)"

    In file included from C:\Users\Asus\Desktop\RelayOutlet\RelayOutlet.ino:14:0:

    C:\Users\Asus\Documents\Arduino\libraries\MySensors/MySensors.h:287:4: error: #error No forward link or gateway feature activated. This means nowhere to send messages! Pretty pointless.

    #error No forward link or gateway feature activated. This means nowhere to send messages! Pretty pointless.

    ^
    

    exit status 1
    Error compiling for board Arduino Pro or Pro Mini.

    This report would have more information with
    "Show verbose output during compilation"
    option enabled in File -> Preferences.



  • @mfalkvidd so i going to upload the code and then it said unable to compile the code to the arduino mini pro

    can i know what is the step by step procedure in coding the arduino

    what codes am i to download and what controller should i use and how to configure it ?



  • @jasxvii Have a vague memory of coming across this error and found it linked to the library MyConfig being called, but as I went with a different sketch for that particular project did not investigate further. @mfalkvidd has considerably greater insight on the sequence of library calls, perhaps posting the sketch might help.


 

Suggested Topics

190
Online

8.8k
Users

9.6k
Topics

100.4k
Posts