Wiring Help



  • I recently got my ethernet shield and was going to wire it up but I'm unsure on the correct way?

    Reading this page http://www.mysensors.org/build/ethernet_gateway seems to indicate to wire it like this
    WizNET (W5100) Ethernet module
    Arduino NRF24L01 Radio
    GND GND
    3.3V VCC
    A2 MISO
    A1 MOSI
    A0 SCK
    6 CSN
    5 CE

    But the code seems to reference pins 5-9 both for the ethernet and MQTT gateway sketchs.

    It also says I need to uncomment a softSPI Define but I'm not seeing that line?

    I'm attempting to connect the radio to an Uno with an ethernet shield.

    I really don't want to end up frying the radio so want to make sure I'm connecting it correctly.

    Edit: I attempted to wire it up how it was described in the table and I'm getting

    0;0;3;0;9;check wires
    

    But from reading other posts it sounds like that could be cause the arduino isn't able to source enough power from the 3.3V pin which is attempting to power both the radio and the ethernet.



  • It looks like the code on CodeBender is different from the code on Github. I had been using the CodeBender code (I assumed it was up to date) but going to get the github code now and try that.

    That appeared to work. I am now getting

    Started!
    

    in the Serial Monitor.



  • I got this working after switching to the code on github and using the Define there.

    So if anyone else gets stuck when trying to use the codebender versions of the library they aren't the most up to date.


  • Admin

    You're right. Updated codebender library just now to the most recent on github/master

    Not sure if codebender autodetects this if you already cloned it to your local account.


 

320
Online

8.9k
Users

9.6k
Topics

101.0k
Posts