Trying to setup a gateway on Orangepi Zero 2..

  • Did anyone manage to make it work on an Orangepi Zero 2?
    It compiles (after some tweaks) on armbian, it starts OK, trasport seems OK, it can transmit, but not receive.
    Out of the box, it comes with

    ls -l /dev/spidev*

    My config:

    ./configure --spi-spidev-device=/dev/spidev1.1 --my-transport=rfm69 --my-rfm69-irq-pin=2 --my-rfm69-cs-pin=13 --my-rfm69-frequency=915 --my-is-rfm69hw --my-gateway=ethernet --my-port=5003

    The output is

    Mar 23 18:17:18 INFO  Starting gateway...
    Mar 23 18:17:18 INFO  Protocol version - 2.3.2
    Mar 23 18:17:18 DEBUG MCO:BGN:INIT GW,CP=RPNGL---,FQ=NA,REL=255,VER=2.3.2
    Mar 23 18:17:18 DEBUG TSF:LRT:OK
    Mar 23 18:17:18 DEBUG TSM:INIT
    Mar 23 18:17:18 DEBUG TSF:WUR:MS=0
    Mar 23 18:17:18 DEBUG TSM:INIT:TSP OK
    Mar 23 18:17:18 DEBUG TSM:INIT:GW MODE
    Mar 23 18:17:18 DEBUG TSM:READY:ID=0,PAR=0,DIS=0
    Mar 23 18:17:18 DEBUG MCO:REG:NOT NEEDED
    Mar 23 18:17:18 DEBUG Listening for connections on P▒E:5003
    Mar 23 18:17:18 DEBUG MCO:BGN:STP
    Mar 23 18:17:18 DEBUG MCO:BGN:INIT OK,TSP=1
    Mar 23 18:17:18 DEBUG TSM:READY:NWD REQ
    Mar 23 18:17:21 DEBUG ?TSF:MSG:SEND,0-0-255-255,s=255,c=3,t=20,pt=0,l=0,sg=0,ft=0,st=OK:

    I tried also with the development branch (fewer tweaks) but with the same results.
    Any help would be appreciated

  • I don't have experience with a Linux gateway, but had a similar issue where the transport was initialised okay and could send, but receiving didn't work.
    This was caused by a not connected/working interrupt input (IRQ).
    Hope it helps you

  • @electrik Going through the documentation of the Orangepi, I found out that the config should be

    --my-rfm69-irq-pin=71 --my-rfm69-cs-pin=233

    but still no dice. I also get an error:

    Mar 28 14:11:14 DEBUG MCO:BGN:INIT GW,CP=RPNGL---,FQ=NA,REL=0,VER=2.4.0-alpha
    Mar 28 14:11:14 DEBUG TSF:LRT:OK
    Mar 28 14:11:14 DEBUG TSM:INIT
    Mar 28 14:11:14 DEBUG TSF:WUR:MS=0
    Mar 28 14:11:14 DEBUG TSM:INIT:TSP OK
    Mar 28 14:11:14 DEBUG TSM:INIT:GW MODE
    Mar 28 14:11:14 ERROR Interrupt handler error: Bad file descriptor
    Mar 28 14:11:14 DEBUG TSM:READY:ID=0,PAR=0,DIS=0
    Mar 28 14:11:14 DEBUG MCO:REG:NOT NEEDED
    Mar 28 14:11:14 DEBUG Listening for connections on ▒]o:5003
    Mar 28 14:11:14 DEBUG MCO:BGN:STP
    Mar 28 14:11:14 DEBUG MCO:BGN:INIT OK,TSP=1
    Mar 28 14:11:14 DEBUG TSM:READY:NWD REQ
    Mar 28 14:11:16 DEBUG ?TSF:MSG:SEND,0-0-255-255,s=255,c=3,t=20,pt=0,l=0,sg=0,ft=0,st=OK:

    The IRQ pin is connected alright, the RFM69 module works perfectly on a RaspberryPi or an OrangePi Zero.
    It just refuses to receive when used on the OrangePi Zero 2 Something with pin assignements or SPI...
    It is a a new SOC, so maybe I should wait for someone with more expertise than me to work it out...

Log in to reply

Suggested Topics

  • 3
  • 24
  • 2
  • 2
  • 2
  • 15