Errors compiling MQTTGateway



  • When trying to compile an adapted version of MTTClientGateway for use with the nrf24L01 I get the following errors:

    Arduino: 1.6.4 (Mac OS X), Platine: "Arduino Mega or Mega 2560, ATmega2560 (Mega 2560)"
    
    Build-Optionen wurden verändert, alles wird neu gebaut
    Verwende die Bibliothek DigitalIO im Ordner: /Users/tom/Documents/Arduino/libraries/DigitalIO (legacy)
    Verwende die Bibliothek SPI im Ordner: /Applications/Arduino.app/Contents/Java/hardware/arduino/avr/libraries/SPI 
    Verwende die Bibliothek MySensors im Ordner: /Users/tom/Documents/Arduino/libraries/MySensors (legacy)
    Verwende die Bibliothek MsTimer2 im Ordner: /Users/tom/Documents/Arduino/libraries/MsTimer2 (legacy)
    Verwende die Bibliothek Ethernet im Ordner: /Applications/Arduino.app/Contents/Java/libraries/Ethernet 
    
    /Applications/Arduino.app/Contents/Java/hardware/tools/avr/bin/avr-g++ -c -g -Os -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -MMD -mmcu=atmega2560 -DF_CPU=16000000L -DARDUINO=10604 -DARDUINO_AVR_MEGA2560 -DARDUINO_ARCH_AVR -I/Applications/Arduino.app/Contents/Java/hardware/arduino/avr/cores/arduino -I/Applications/Arduino.app/Contents/Java/hardware/arduino/avr/variants/mega -I/Users/tom/Documents/Arduino/libraries/DigitalIO -I/Applications/Arduino.app/Contents/Java/hardware/arduino/avr/libraries/SPI -I/Users/tom/Documents/Arduino/libraries/MySensors -I/Users/tom/Documents/Arduino/libraries/MsTimer2 -I/Applications/Arduino.app/Contents/Java/libraries/Ethernet/src /var/folders/3s/rjbksrj96nv0hqfqjlpfw8bm0000gn/T/build5138094512674816324.tmp/MQTTGateway.cpp -o /var/folders/3s/rjbksrj96nv0hqfqjlpfw8bm0000gn/T/build5138094512674816324.tmp/MQTTGateway.cpp.o 
    In file included from MQTTGateway.ino:84:0:
    /Users/tom/Documents/Arduino/libraries/MySensors/MySigningAtsha204Soft.h:40:0: warning: "SIGNING_IDENTIFIER" redefined [enabled by default]
     #define SIGNING_IDENTIFIER (1)
     ^
    In file included from MQTTGateway.ino:80:0:
    /Users/tom/Documents/Arduino/libraries/MySensors/MySigningNone.h:35:0: note: this is the location of the previous definition
     #define SIGNING_IDENTIFIER (0)
     ^
    In file included from /Users/tom/Documents/Arduino/libraries/MySensors/MyTransportRFM69.h:26:0,
                     from MQTTGateway.ino:81:
    /Users/tom/Documents/Arduino/libraries/MySensors/utility/RFM69.h:78:62: error: 'RF69_IRQ_PIN' was not declared in this scope
         RFM69(byte slaveSelectPin=RF69_SPI_CS, byte interruptPin=RF69_IRQ_PIN, bool isRFM69HW=false, byte interruptNum=RF69_IRQ_NUM) {
                                                                  ^
    /Users/tom/Documents/Arduino/libraries/MySensors/utility/RFM69.h:78:116: error: 'RF69_IRQ_NUM' was not declared in this scope
         RFM69(byte slaveSelectPin=RF69_SPI_CS, byte interruptPin=RF69_IRQ_PIN, bool isRFM69HW=false, byte interruptNum=RF69_IRQ_NUM) {
                                                                                                                        ^
    In file included from MQTTGateway.ino:81:0:
    /Users/tom/Documents/Arduino/libraries/MySensors/MyTransportRFM69.h:33:145: error: 'RF69_IRQ_PIN' was not declared in this scope
      MyTransportRFM69(uint8_t freqBand=RFM69_FREQUENCY, uint8_t networkId=RFM69_NETWORKID, uint8_t slaveSelectPin=RF69_SPI_CS, uint8_t interruptPin=RF69_IRQ_PIN, bool isRFM69HW=false, uint8_t interruptNum=RF69_IRQ_NUM);
                                                                                                                                                     ^
    /Users/tom/Documents/Arduino/libraries/MySensors/MyTransportRFM69.h:33:202: error: 'RF69_IRQ_NUM' was not declared in this scope
      MyTransportRFM69(uint8_t freqBand=RFM69_FREQUENCY, uint8_t networkId=RFM69_NETWORKID, uint8_t slaveSelectPin=RF69_SPI_CS, uint8_t interruptPin=RF69_IRQ_PIN, bool isRFM69HW=false, uint8_t interruptNum=RF69_IRQ_NUM);
                                                                                                                                                                                                              ^
    Fehler beim Kompilieren.
    

    I receive the same error trying to compile the MQTTGateway which is part of the MySensors library. I didn't change MyConfig.h and I am not aware where this error is originating from.

    Any ideas?


  • Admin

    You got AtMega2560, try development-branch where this has been fixed.



  • Thanks a lot! Works now!


Log in to reply
 

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.