Can't Include MySensors node, not sure if Vera or MySensors problem

  • Setting: I have a VeraEdge (UI7) and an ethernet gateway. Gateway is working fine as far as I know, Vera sees it.

    I built a RGB LED node to control some analog LED strips. When I first started it up using the stock sketch from the Mysensors library, Vera found 2 devices, a repeater and a dimmer. But there should be 3 dimmers. Repeated includes didn't fix it.

    I added a 1 sec delay between the gw.present commands in the RGB sketch and changed the gw.begin from a fixed node number of 31 to auto. I then deleted the two devices from Vera, rebooted Vera and the ethernet gateway, and then tried to re-include the node. I'm getting nothing on the Vera.

    Since I've got the RGB node connected to my computer still, I pulled up the serial console and see every line with a st=fail status. What am I doing wrong? Is there some way I need to exclude the node beyond just deleting it from the Vera dashboard? The node does seem to still be trying to use ID 31.

    I even found a clear eeprom sketch on here in the debug section, did that, and still not working.

    Sample log:

    send: 31-31-0-0 s=255,c=0,t=18,pt=0,l=3,sg=0,st=fail:1.5
    send: 31-31-0-0 s=255,c=3,t=6,pt=1,l=1,sg=0,st=fail:0
    repeater started, id=31, parent=0, distance=1
    send: 31-31-0-0 s=255,c=3,t=11,pt=0,l=16,sg=0,st=fail:RGB Led strip 3D
    send: 31-31-0-0 s=255,c=3,t=12,pt=0,l=2,sg=0,st=fail:v1
    send: 31-31-0-0 s=6,c=0,t=4,pt=0,l=17,sg=0,st=fail:present RED light
    send: 31-31-0-0 s=5,c=0,t=4,pt=0,l=19,sg=0,st=fail:present GREEN light
    find parent
    send: 31-31-255-255 s=255,c=3,t=7,pt=0,l=0,sg=0,st=bc:
    send: 31-31-0-0 s=3,c=0,t=4,pt=0,l=18,sg=0,st=fail:present BLUE light
    send: 31-31-0-0 s=0,c=0,t=3,pt=0,l=19,sg=0,st=fail:present Show button
    Load from eeprom RED: 0%
    Load from eeprom GREEN: 0%
    Load from eeprom BLUE: 0%
    Send eeprom value to controler
    send: 31-31-0-0 s=6,c=1,t=3,pt=1,l=1,sg=0,st=fail:0
    send: 31-31-0-0 s=5,c=1,t=3,pt=1,l=1,sg=0,st=fail:0
    send: 31-31-0-0 s=3,c=1,t=3,pt=1,l=1,sg=0,st=fail:0
    send: 31-31-0-0 s=0,c=1,t=2,pt=2,l=2,sg=0,st=fail:0
    find parent
    send: 31-31-255-255 s=255,c=3,t=7,pt=0,l=0,sg=0,st=bc:
    Ready to receive messages...

  • Solved!

    It was a hardware problem - I didn't put caps on the radio on the gateway or RGB node originally. I added them and the node added perfectly. I guess I got lucky originally that even the 2 devices appeared on the first try.