Understanding the message



  • I have had a read through the general API info and I think I generally understand the message formats, but not sure why my system would always be sending the following string/payload and what it exactly means (think it is from the temp/humidity sensor reading.

    0;0;3;0;9;read: 20-20-0;0;3;0;9;read: 20-20-0
    s=1,c=1,t=0,pt=7,l=5,sg=0:5.0

    The other message is OK which is from the straight temp sensor. That is easy to understand.

    2;0;1;0;0;15.7



  • see this post



  • This post is deleted!


  • @ch3b7 Thanks for that.

    When reading through the API info, the 0,0,3,0,9 message relates to an internal type message, which I get. However I don't understanding why I seem to get it continually occurring on my serial port when I monitor it (every few minutes). However when I am running MYSController, the only internal message that comes up is when the gate way reboots?

    Wondering why I would see the difference.

    Serial Output

    upload-42ac8319-1db4-4f96-a104-1358e26c81ba

    MYSController Output with only two internal messages

    upload-014b4222-b613-4436-8067-a19fa8755182



  • @diggs to hide this 0,0,3,0,9 you need disable "#define DEBUG" replace with "//#define DEBUG" in libraries\MySensors\MyConfig.h and then upload sketch again


  • Admin

    @diggs the internal/debug (=I_LOG) messages are filtered from the main tab and displayed in the MySensors Debug tab.



  • hi guys

    thanks all for the responses. Tis all clear now and makes sense


Log in to reply
 

Suggested Topics

  • 4
  • 274
  • 933
  • 9
  • 2
  • 9

0
Online

11.2k
Users

11.1k
Topics

112.5k
Posts