Debug findParent



  • I have a gateway which already has 6 nodes hooked up. One of the nodes is a repeater.
    I am trying to hook up a new node which does not find its parent.

    Starting sensor (RNNNAA, 2.0.0-beta)
    write register, reg=0, value=6
    write register, reg=3, value=3
    write register, reg=4, value=95
    write register, reg=5, value=124
    write register, reg=6, value=39
    read register, reg=6, value=39
    write register, reg=16, value=115
    write register, reg=29, value=6
    write register, reg=2, value=2
    write register, reg=1, value=0
    write register, reg=28, value=3
    flushRX
    flushTX
    write register, reg=7, value=112
    Radio init successful.
    find parent
    stop listening
    write register, reg=0, value=6
    open writing pipe, recipient=255
    write register, reg=10, value=255
    write register, reg=16, value=255
    send message to 255, len=7
    flushTX
    write register, reg=7, value=48
    start listening
    write register, reg=0, value=7
    send: 32-32-255-255 s=255,c=3,t=7,pt=0,l=0,sg=0,st=bc:
    find parent
    stop listening
    write register, reg=0, value=6
    open writing pipe, recipient=255
    write register, reg=10, value=255
    write register, reg=16, value=255
    send message to 255, len=7
    flushTX
    write register, reg=7, value=48
    start listening
    write register, reg=0, value=7
    send: 32-32-255-255 s=255,c=3,t=7,pt=0,l=0,sg=0,st=bc:
    

    From the log above you can see that it does not find its parent.
    How can I debug that?

    In particular, I am interested whether I should see that the gateway receives the "broadcast" message although it is already serving six nodes? From the log I do not see any message being received at the gateway.


  • Admin

    The broadcast should vi visible in the debug log of the gateway or repeater (if i hears it).



  • @hek: Thanks! It's working now. I was confused by another issue, a call to requestTime in the setup routine which seems not going out.


 

459
Online

7.9k
Users

8.8k
Topics

94.3k
Posts