Newbie trying to compile a sketch/installing mysensors library



  • Hello,

    I´m trying to build my first mqtt-Gateway using an arduino nano V3 clone and a ethernet W5100 shield.

    Downloaded the arduino-master.zip and unzipped it into the sketchbook directory. But, arduino IDE tells me on startup that it´s not a valid library.

    Afterwards I tried to use codebender on chrome. By clicking the run on arduino button, codebender tells me the same like the Arduino IDE itself:
    "(sketch file) MQTTGateway.ino:77:10: fatal error: 'DigitalIO.h' file not found
    #include <DigitalIO.h>
    ^
    1 error generated."

    Little help would be great...


  • Contest Winner

    How did you install the mySensors library?


  • Mod

    @blebbens Instructions are available at https://www.mysensors.org/about/arduino#installing-the-sensor-libraries (not sure if you've already used them)



  • Think, the description is a bit confusing. Watched the video and copied Arduino-master.zip´s directory libraries to /user/documents/arduino/libraries and c:\program files(x86)\arduino\libraries.

    Now on compiling I get the following (german) message:

    WARNUNG: Kategorie '' in der Bibliothek UIPEthernet ist ungültig und wird auf 'Uncategorized' festgelegt
    WARNUNG: Kategorie '' in der Bibliothek UIPEthernet ist ungültig und wird auf 'Uncategorized' festgelegt
    Mehrere Bibliotheken wurden für "MsTimer2.h" gefunden
    Benutzt: C:\Users\R\Documents\Arduino\libraries\MsTimer2
    Nicht benutzt: F:\Program Files (x86)\Arduino\libraries\MsTimer2
    Mehrere Bibliotheken wurden für "DigitalIO.h" gefunden
    Benutzt: C:\Users\R\Documents\Arduino\libraries\DigitalIO
    Nicht benutzt: F:\Program Files (x86)\Arduino\libraries\DigitalIO
    Mehrere Bibliotheken wurden für "MySigningNone.h" gefunden
    Benutzt: C:\Users\R\Documents\Arduino\libraries\MySensors (used)
    Nicht benutzt: F:\Program Files (x86)\Arduino\libraries\MySensors (not used)
    Nicht benutzt: F:\Program Files (x86)\Arduino\libraries\MySensors
    Nicht benutzt: F:\Program Files (x86)\Arduino\libraries\MySensors
    Nicht benutzt: F:\Program Files (x86)\Arduino\libraries\MySensors



  • I copied the libraries to 2 directories, so the IDE finds 2 versions of the same library.

    But, the first message seems to be the problem:
    WARNING: category '' in library UIPEthernet not valid and will be categorized as 'Uncategorized'
    WARNUNG: Kategorie '' in der Bibliothek UIPEthernet ist ungültig und wird auf 'Uncategorized' festgelegt


 

417
Online

7.9k
Users

8.7k
Topics

93.7k
Posts