[Solved] Does not work after latest update



  • Hey all!
    I just updated to the latest 2.0 release and everything stopped working. I have researched as much as I can on this topic, especially this thread. But nothing has worked for me this far, I've tried for hours and hours and now I feel like I've hit a wall. I tried the development branch too but to no success.

    I have updated my gateway (esp8266 mqtt gateway with a nrf24l01+pa+lna) and one Arduino Nano (with a nrf24l01) having DHT22 and motion sensor, all this is reporting to Home Assistant. It worked perfectly before with 2.0.0b.

    I've tried adjusting the rf24 power to LOW and 1mbps etc, playing with stuff that people have suggested, keeping the gw and node at a bigger distance etc. Now I kind of wish I could find the older 2.0.0b libraries but I can't, but I would appreciate any help that I can with getting this latest version working, sorry if I repeated a similar question but I thought I'd start a new thread since the other ones does not work for me.

    I get this message (which some may recognize from the other posts) which is pretty much the same for release 2.0. and dev branch. Let me know if I should provide some more info.

    Starting sensor (RNNNA-, 2.0.1-beta)
    TSM:INIT
    TSM:INIT:TSP OK
    TSM:INIT:STATID,ID=10
    TSF:ASID:OK,ID=10
    TSM:FPAR
    TSF:MSG:SEND,10-10-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=bc:
    !TSM:FPAR:NO REPLY
    TSM:FPAR
    TSF:MSG:SEND,10-10-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=bc:
    !TSM:FPAR:NO REPLY
    TSM:FPAR
    TSF:MSG:SEND,10-10-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=bc:
    !TSM:FPAR:NO REPLY
    TSM:FPAR
    TSF:MSG:SEND,10-10-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=bc:
    !TSM:FPAR:FAIL
    TSM:FAILURE
    TSM:FAILURE:PDT
    TSM:FAILURE:RE-INIT
    

    and this is some output from the esp8266 gw:

    0;255;3;0;9;Attempting MQTT connection...
    0;255;3;0;9;MQTT connected
    0;255;3;0;9;TSF:MSG:READ,10-10-255,s=255,c=3,t=7,pt=0,l=0,sg=0:
    0;255;3;0;9;TSF:MSG:BC
    0;255;3;0;9;TSF:MSG:FPAR REQ,ID=10
    0;255;3;0;9;TSF:CHKUPL:OK,FCTRL
    0;255;3;0;9;TSF:MSG:GWL OK
    0;255;3;0;9;!TSF:MSG:SEND,0-0-10-10,s=255,c=3,t=8,pt=1,l=1,sg=0,ft=0,st=NACK:0
    0;255;3;0;9;TSF:MSG:READ,10-10-255,s=255,c=3,t=7,pt=0,l=0,sg=0:
    0;255;3;0;9;TSF:MSG:BC
    0;255;3;0;9;TSF:MSG:FPAR REQ,ID=10
    0;255;3;0;9;TSF:CHKUPL:OK,FCTRL
    0;255;3;0;9;TSF:MSG:GWL OK```

  • Admin

    @Emil-Besirevic Radio link is ok:

    1. node sends find parent request:
    TSM:FPAR
    TSF:MSG:SEND,10-10-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=bc:
    
    1. GW answers:
    0;255;3;0;9;TSF:MSG:READ,10-10-255,s=255,c=3,t=7,pt=0,l=0,sg=0:
    0;255;3;0;9;TSF:MSG:BC
    0;255;3;0;9;TSF:MSG:FPAR REQ,ID=10
    0;255;3;0;9;TSF:CHKUPL:OK,FCTRL
    0;255;3;0;9;TSF:MSG:GWL OK
    0;255;3;0;9;!TSF:MSG:SEND,0-0-10-10,s=255,c=3,t=8,pt=1,l=1,sg=0,ft=0,st=NACK:0
    
    

    ..but your node does not receive the find parent response, see last line GW log (NACK) + node log:

    !TSM:FPAR:NO REPLY.
    
    

    Please make sure GW and node are running the same code base and double check power/cap/wiring. Also, try changing and re-seating the radios. Additionally, please post the node sketch here.



  • Hi Tekka!
    Thanks for you reply!

    The sketches I used for the testing in the end was the included ones, which is the esp8266 mqtt gateway and then I tried with the motion sensor sketch, both are from the mysensors library examples.

    The wiring, cap etc. are all identical to how it has always been when it was working with the 2.0.0beta, it's all in place and sturdy, what do you mean by changing/re-seating the radios?

    EDIT: Tried with different radio modules, both usual and the one with antenna for the node etc, but still the same :/

    EDIT2: It worked randomly for like 1 minute but stopped working again, with this ouput from the node:

    TSF:MSG:SEND,10-10-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=bc:
    TSF:MSG:READ,0-0-10,s=255,c=3,t=8,pt=1,l=1,sg=0:0
    TSF:MSG:FPAR RES,ID=0,D=0
    TSF:MSG:FPAR OK,ID=0,D=1
    TSM:FPAR:OK
    TSM:ID
    TSM:ID:OK,ID=10
    TSM:UPL
    TSF:PING:SEND,TO=0
    !TSF:MSG:SEND,10-10-0-0,s=255,c=3,t=24,pt=1,l=1,sg=0,ft=0,st=NACK:1
    TSF:CHKUPL:FAIL
    !TSM:UPL:FAIL
    TSM:FPAR```

  • Admin

    @Emil-Besirevic hmm...If it works randomly for a few minutes - this could possibly hint to a power issue. What caps did you connect to the radio modules? Try substituting them for larger ones. 2.0.0 is exchanging more messages during initialisation, and this could cause power instabilities under certain conditions.



  • Ok, so you truly rock Tekka!
    I just took entirely new modules, soldered 22uf instead of 10uf caps on them both, just plugged everything in, and it WORKS now!

    I've disconnected it a few times, re-connected, tried back and forth and it communicated and sends everything to Home assistant each time flawlessly, even better than before!

    Super happy guy here! A huge thank you for having patience with me! This new release of mysensors is awesome! :)


  • Admin

    @Emil-Besirevic Excellent, have fun 😀



  • @Emil-Besirevic I have the same problem, I follow the same steps. I have already soldered a 22uF + 100nF, but I still have the problem.
    Is yours still working? Any other idea?

    Thanks



  • @Jic said:

    @Emil-Besirevic I have the same problem, I follow the same steps. I have already soldered a 22uF + 100nF, but I still have the problem.
    Is yours still working? Any other idea?

    Thanks

    Hi! I have only soldered a 22uF on all, the arduino nano nodes and the esp8266 gate which uses a nrf24l01 antenna version, and it all works great still! Have you tried with different modules?



  • @Emil-Besirevic
    yes, I have tested:

    • with diffetents modules of nrf24l01+,

    • with the NRF24L01+ Socket Adapter Board.

    • with 10uF+100nF capacitor and 22uF+100nF capacitor

    • with diferents Arduino nano, and also with an Arduino One

    And no success, I'm a bit frustrated now. I suppouse that the problem it is with software it's unlikey that all hardware are wrong.
    I don't know if the problem is in Arduino nano + nrf24l01plus or in the rpi gateway connected to the GPIO.
    Somebody know how can I test it?

    Thanks



  • Hello everybody!
    This my first post, but I've been reading for a long while and realy admire the team for the work done :)

    I have moved to development branch, I have latest MySensors on my gateway (Rpi2 + nrf24l01+plna, caps and reg to solve the power issue), burned the MYSBootloader (8MHz internal) and could upload the binary scetch via serial.
    Now i have that problem with !TSM:FPAR:NO REPLY on the node side.
    I can see the FPAR request on the gateway side.

    653051 TSM:INIT
    653060 TSM:INIT:TSP OK
    653062 TSM:FPAR
    653064 TSF:MSG:SEND,255-255-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    655073 !TSM:FPAR:NO REPLY
    655075 TSM:FPAR
    655077 TSF:MSG:SEND,255-255-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    657088 !TSM:FPAR:NO REPLY
    657090 TSM:FPAR
    657092 TSF:MSG:SEND,255-255-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    659103 !TSM:FPAR:NO REPLY
    659105 TSM:FPAR
    659107 TSF:MSG:SEND,255-255-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    661121 !TSM:FPAR:FAIL
    661123 TSM:FAIL:CNT=7
    661125 TSM:FAIL:PDT```
    
    
    mysgw: TSF:MSG:READ,255-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0:
    mysgw: TSF:MSG:BC
    mysgw: TSF:MSG:FPAR REQ,ID=255
    mysgw: TSF:PNG:SEND,TO=0
    mysgw: TSF:CKU:OK
    mysgw: TSF:MSG:GWL OK
    mysgw: TSF:MSG:SEND,0-0-255-255,s=255,c=3,t=8,pt=1,l=1,sg=0,ft=0,st=OK:0
    mysgw: Client 0: 0;0;3;0;18;PING
    mysgw: TSF:MSG:READ,255-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0:
    mysgw: TSF:MSG:BC
    mysgw: TSF:MSG:FPAR REQ,ID=255
    mysgw: TSF:CKU:OK,FCTRL
    mysgw: TSF:MSG:GWL OK
    mysgw: TSF:MSG:SEND,0-0-255-255,s=255,c=3,t=8,pt=1,l=1,sg=0,ft=0,st=OK:0
    mysgw: TSF:MSG:READ,255-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0:
    mysgw: TSF:MSG:BC
    mysgw: TSF:MSG:FPAR REQ,ID=255
    mysgw: TSF:CKU:OK,FCTRL
    mysgw: TSF:MSG:GWL OK
    mysgw: TSF:MSG:SEND,0-0-255-255,s=255,c=3,t=8,pt=1,l=1,sg=0,ft=0,st=OK:0
    mysgw: TSF:MSG:READ,255-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0:
    mysgw: TSF:MSG:BC
    mysgw: TSF:MSG:FPAR REQ,ID=255
    mysgw: TSF:CKU:OK,FCTRL
    mysgw: TSF:MSG:GWL OK
    mysgw: TSF:MSG:SEND,0-0-255-255,s=255,c=3,t=8,pt=1,l=1,sg=0,ft=0,st=OK:0
    

    Though there is no sign of activity in MYSController (the one included with the MYSBootloader archive)

    I have tried differen radio modules, different pro minis, modules not jumper wired but soldered with short wires and caps (10, 20, 47 uF). The other 3 nodes are responding (2 x si7021 + motion sensor) but they are on 1.5 version I suppose.

    EDIT: The interestinf thing is that I tried to update my perfectly working motion sensor and it doesn't work now.

    TSM:FPAR
    TSP:MSG:SEND 1-1-255-255 s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=bc:
    !TSM:FPAR:FAIL
    !TSM:FAILURE```


  • @Tigroenot I have the same errors until I soldered the nrf24l01 module.
    Power supply and wired it is very important with this module. I think a have a lot of problems with jumper wires.

    Be also sure that you are using the last binding

    https://github.com/tobof/openhab2-addons/blob/MySensors/addons/binding/org.openhab.binding.mysensors/target/org.openhab.binding.mysensors-2.0.0-SNAPSHOT.jar



  • @Jic I have all Nrf24 modules soldered, with caps (tried 20 and 47 uF), I have three versions of Nrf24 modules: from the mysensors shop, smd and plna. On the gateway I have plna, on sensors I have both the others. Those sensors worked fine for almost a year, and stoped after I have updated them to 2.0.0 or development branch. On the gateway side I have latest development version.
    Maybe all my radio modules are clones that do not work with the versions of mysensors higher than 1.4?

    And I use domoticz. Maybe I should switch to openhub?



  • I just upgraded all my nodes + gateway to latest dev branch (2.10) and it's working great with home assistant, they communicate without issues. As mentioned earlier my setup is nrf24l01 (with antenna mod) for all nodes (arduino nano) and then the gateway (esp8266) is with a nrf24l01+plna, and they all have a 22uF cap, it's been like 6+ months and it's been working great this far. I ordered all the nrf24l01 from aliexpress.



  • I will try to move my gateway from raspberry to esp. When I compiled gateway on raspberry it has argued on some parameter in config, I removed the cortex a7 entry and all went fine. Maybe it was the issue.



  • @Tigroenot Have you Clean the Eprom before update to mysensors 2.0?

    https://github.com/mysensors/MySensors/blob/master/examples/ClearEepromConfig/ClearEepromConfig.ino

    Sometimes it solve me somes issues



  • @Jic I sure did, to erase the node id value.



  • Reporting: I have thrown away the capacitors that I've bought from Ali and replaced them by those bougth here localy (47uF) and everything worked like a charm! So to admit, the promblem IS indeed in the decoupling capacitors! Very happy guy here! :)


Log in to reply
 

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.