MySensors Communication Error



  • VeraPlus UI7 version: 1.7.2044
    MySensors Gateway: ESP8266 - NodeMCU 0.9
    Library 2.0

    For some reason the Vera is unable to communicate with the gateway

    1. I can see proper information when connected to the gateway via MYSController, no radio problem
    2. I can ping the gateway IP address from my laptop
    3. I can connect to the gateway via telnet to IPADDRESS:5003

    When I logged in to the VeraPlus console

    1. I cannot ping the gateway IP, there is no reply.
    2. I can ping from the gateway to other devices in my network
    3. The MAC address of the gateway is resolved in the controller (arp -a)

    Vera is reporting
    MySensors plugin : Cannot send command - communications error

    Any idea?


  • Mod

    @yoram Enable #define MY_DEBUG in the gateway sketch and upload gateway again.
    Connect NodeMCU to a PC and report back serial data output by the gateway.



  • I see no problem on this side, I even rebooted one node and it can be seeing

    2016-08-08 20:12:15	Message	0;255;3;0;9;Starting gateway (RNNGE-, 2.0.0)
    2016-08-08 20:12:15	Message	
    0;255;3;0;9;TSM:INIT
    0;255;3;0;9;TSM:RADIO:OK
    0;255;3;0;9;TSM:GW MODE
    0;255;3;0;9;TSM:READY
    0;255;3;0;9;-^^--
    0;255;3;0;9;Yoram:
    0;255;3;0;9;Static IP:
    10.100.102.111
    scandone
    f 0, scandone
    state: 0 -> 2 (b
    2016-08-08 20:12:15	Message	0)
    state: 2 -> 3 (0)
    state: 3 -> 5 (10)
    add 0
    aid 1
    cnt 
    
    connected with ShechoriHome, channel 11
    ip:10.100.102.111,mask:255.255.255.0,gw:10.100.102.1
    2016-08-08 20:12:15	Message	.IP: 10.100.102.111
    0;255;3;0;9;No regis
    2016-08-08 20:12:15	Message	tration required
    0;255;3;0;9;Init complete, id=0, parent=0, distance=0, registration=1
    2016-08-08 20:12:25	Message	pm open,type:2 0
    2016-08-08 20:12:45	Message	0;255;3;0;9;TSP:MSG:READ 20-20-255 s=255,c=3,t=7,pt=0,l=0,sg=0:
    0;255;3;0;9;TSP:MSG:BC
    0;255;3;0;9;TSP:MSG:FPAR REQ (sender=20)
    0;255;3;0;9;TSP:CHKUPL:OK
    0;255;3;0;9;TSP:MSG:GWL OK
    2016-08-08 20:12:46	Message	0;255;3;0;9;TSP:MSG:SEND 0-0-20-20 s=255,c=3,t=8,pt=1,l=1,sg=0,ft=0,st=ok:0
    0;255;3;0;9;TSP:MSG:READ 1-1-0 s=255,c=3,t=24,pt=1,l=1,sg=0:1
    0;255;3;0;9;TSP:MSG:PINGED (ID=1, hops=1)
    0;255;3;0;9;TSP:MSG:SEND 0-0-1-1 s=255,c=3,t=25,pt=1,l=1,sg=0,ft=0,st=ok:1
    2016-08-08 20:12:48	Message	0;255;3;0;9;TSP:MSG:READ 20-20-0 s=255,c=3,t=24,pt=1,l=1,sg=0:1
    0;255;3;0;9;TSP:MSG:PINGED (ID=20, hops=1)
    0;255;3;0;9;TSP:MSG:SEND 0-0-20-20 s=255,c=3,t=25,pt=1,l=1,sg=0,ft=0,st=ok:1
    0;255;3;0;9;TSP:MSG:READ 20-20-0 s=255,c=3,t=15,pt=6,l=2,sg=0:0100
    0;255;3;0;9;TSP:MSG:SEND 0-0-20-20 s=255,c=3,t=15,pt=6,l=2,sg=0,ft=0,st=ok:0100
    0;255;3;0;9;TSP:MSG:READ 20-20-0 s=255,c=0,t=17,pt=0,l=5,sg=0:2.0.0
    0;255;3;0;9;TSP:MSG:READ 20-20-0 s=255,c=3,t=6,pt=1,l=1,sg=0:0
    2016-08-08 20:12:50	Message	0;255;3;0;9;TSP:MSG:READ 20-20-0 s=255,c=3,t=11,pt=0,l=19,sg=0:Water Leakage w Bat
    0;255;3;0;9;TSP:MSG:READ 20-20-0 s=255,c=3,t=12,pt=0,l=3,sg=0:1.0
    0;255;3;0;9;TSP:MSG:READ 20-20-0 s=0,c=0,t=32,pt=0,l=0,sg=0:
    0;255;3;0;9;TSP:MSG:READ 20-20-0 s=1,c=0,t=23,pt=0,l=0,sg=0:
    0;255;3;0;9;TSP:MSG:READ 20-20-0 s=255,c=3,t=26,pt=1,l=1,sg=0:2
    0;255;3;0;9;TSP:MSG:SEND 0-0-20-20 s=255,c=3,t=27,pt=1,l=1,sg=0,ft=0,st=ok:1
    0;255;3;0;9;TSP:MSG:READ 20-20-0 s=1,c=1,t=38,pt=7,l=5,sg=0:3.178
    0;255;3;0;9;TSP:MSG:READ 20-20-0 s=255,c=3,t=0,pt=1,l=1,sg=0:100
    0;255;3;0;9;TSP:MSG:READ 20-20-0 s=0,c=2,t=15,pt=0,l=0,sg=0:
    
    

  • Mod

    @yoram apart from all the "2016-08-08 20:12:50 Message" texts (does your terminal program add them?) output looks OK.
    I don't have a Vera, so can't help you any further...


 

Suggested Topics

451
Online

7.9k
Users

8.8k
Topics

93.8k
Posts