S_HVAC in domoticz



  • is there anyone that has the switch for HVAC working in domoticz?

    i have tried several times to create a HVAC switch by presenting my node with " present(CHILD_ID_HVAC, S_HVAC);"
    but when i look in domoticz there is no node to be found in the devices or in the hardware( under setup), only in the log i can see that the node has presented itself correctly.

    is it possible that S_HVAC is not supported by domoticz? is there a workaround for this?

    thanks for the help anyway!


  • Mod

    @diamantmatch Domoticz adds devices when the first data is sent, ot when the device is presented. I'm not sure if this applies to S_HVAC, but it applies to temperature and humidity.

    Try sending some data and see if it helps.



  • @mfalkvidd thanks for the tip! i got the following result in domoticz.

    16-08-29 11:22:34.763 (mysensor) Temp (Baro Temp)
    2016-08-29 11:22:34.772 (mysensor) General/Barometer (Baro)
    2016-08-29 11:22:35.059 MySensors: Node: 12, Sketch Version: 1.0
    2016-08-29 11:22:35.099 Error: MySensors: Unhandled sensor (sub-type=22), please report with log!
    2016-08-29 11:22:35.108 Error: MySensors: Unhandled sensor (sub-type=21), please report with log!
    2016-08-29 11:22:35.115 (mysensor) Thermostat (Setpoint Heat)
    2016-08-29 11:22:35.298 (mysensor) Temp (Baro Temp)

    this is what i get when presenting 3 values back to domoticz.
    i guess this means that V_HVAC_FLOW_STATE and V_HVAC_SPEED are not implemented in domoticz yet?
    is there a way for me to work around this?


  • Hero Member

    @diamantmatch said:

    @mfalkvidd thanks for the tip! i got the following result in domoticz.

    16-08-29 11:22:34.763 (mysensor) Temp (Baro Temp)
    2016-08-29 11:22:34.772 (mysensor) General/Barometer (Baro)
    2016-08-29 11:22:35.059 MySensors: Node: 12, Sketch Version: 1.0
    2016-08-29 11:22:35.099 Error: MySensors: Unhandled sensor (sub-type=22), please report with log!
    2016-08-29 11:22:35.108 Error: MySensors: Unhandled sensor (sub-type=21), please report with log!
    2016-08-29 11:22:35.115 (mysensor) Thermostat (Setpoint Heat)
    2016-08-29 11:22:35.298 (mysensor) Temp (Baro Temp)

    this is what i get when presenting 3 values back to domoticz.
    i guess this means that V_HVAC_FLOW_STATE and V_HVAC_SPEED are not implemented in domoticz yet?
    is there a way for me to work around this?

    I think your assumption is right about HVAC messages not supported in Domoticz. Try to do as suggested, report to Domoticz forum with the log and maybe they'll implement it ;)


  • Hardware Contributor

    @diamantmatch - are you using the latest version. Atleast there is something in the sourcode: https://github.com/domoticz/domoticz/blob/master/hardware/MySensorsBase.h#L53. Im not a coding guy so not completley sure it its just a declaration or its implemented but alteast check if you can update and try again.



  • yes there is indeed something in the source code there.. but it is only the setpoint almost like a thermostat.

    in my code i presented three values. two of these values where not recognised as could be seen in the last post. but the last value was indeed a temperature setting and was recognised as a thermostat.

    i guess i will post this to domoticz and hopefully it will be implemented :D

    Thanks you guys for the help!

    i will post back here if i find anything usefull or when it is working just so others can find it.



  • @diamantmatch said:

    i guess this means that V_HVAC_FLOW_STATE and V_HVAC_SPEED are not implemented in domoticz yet?

    If you read through this post that I have out there for the RS485 bridge that I am working on for my RCS thermostat, there is some information regarding this in there. Regarding your comment directly, @pjr stated that V_HVAC_FLOW_STATE, V_HVAC_FLOW_MODE and V_HVAC_SPEED are not implemented in Domoticz yet.

    There is some other useful information in that post if you are looking to do something with your thermostat. My RS485 bridge is still a work in progress, but I had to put it on hold for a while as I am a beta tester for a different thermostat, so I currently have my RCS thermostat disconnected. I think it is worth it though to post to the Domoticz community that this would be a useful implementation.


Log in to reply
 

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.