💬 Building a Raspberry Pi Gateway


  • Code Contributor

    Please, could all of you who experienced this issue post the configuration options you used to build the gateway?
    This would help to investigate the problem.



  • @marceloaqno : of course, thanks for the hint!

    I had the following configure:

    ./configure --my-transport=nrf24 --my-rf24-irq-pin=15 --my-gateway=ethernet --my-port=5004
    

    (The high CPU problem also occured before I connected PIN 15 to IRQ without the corresponding config option. I hoped to solve the Problem using IRQ, but this did not help. And I have a second GW with default port 5003 in my network. This is running an ancient version of Raspi GW Software and this is working fine -but slower). I am using current fhem as controller and I have it connecting every 30 minutes to the gateways due to stability issues in the past. There are only about 6 nodes (just motion, humidity & temp and lux) connected to this gateway.

    In addition to that I changed the default channel in MyConfig.h (because I have two different MySensor networks):

    #ifndef MY_RF24_CHANNEL
    #define MY_RF24_CHANNEL (82)
    #endif
    

    I am pretty sure, that this is not important, but I also set up rsyslog to write gw logs to an own file instead of syslog....

    Maybe this helps.

    Cheers,
    Otto


  • Code Contributor



  • @marceloaqno : Wow, you are fast! Thanks!
    Just applied the patch and recompiled. I will report in a couple of days while my monitoring-script is still running (and logging)...

    Cheers,
    Otto



  • @marceloaqno I am also recompiling and testing.
    thanks for the (hopeful) fix
    I will report back with my status in a few days



  • @marceloaqno :

    At first, THANKS for your help. CPU usage does not rise anymore.
    But unfortunately no more node READs after the same situation:

    Mar  4 07:00:09 raspiez mysgw: TSF:MSG:READ,14-14-0,s=255,c=3,t=6,pt=1,l=1,sg=0:0
    Mar  4 07:00:09 raspiez mysgw: TSF:MSG:READ,12-12-0,s=255,c=3,t=6,pt=1,l=1,sg=0:0
    Mar  4 07:00:09 raspiez mysgw: GWT:RFC:C=1,MSG=14;255;3;0;6;M
    Mar  4 07:00:09 raspiez mysgw: !TSF:MSG:SEND,0-0-14-14,s=255,c=3,t=6,pt=0,l=1,sg=0,ft=0,st=NACK:M
    Mar  4 07:00:09 raspiez mysgw: TSF:MSG:READ,11-11-0,s=255,c=0,t=18,pt=0,l=3,sg=0:1.5
    Mar  4 07:00:09 raspiez mysgw: GWT:RFC:C=1,MSG=12;255;3;0;6;M
    Mar  4 07:00:09 raspiez mysgw: TSF:MSG:SEND,0-0-12-12,s=255,c=3,t=6,pt=0,l=1,sg=0,ft=0,st=OK:M
    Mar  4 07:00:13 raspiez mysgw: TSM:READY:NWD REQ
    Mar  4 07:00:13 raspiez mysgw: TSF:MSG:SEND,0-0-255-255,s=255,c=3,t=20,pt=0,l=0,sg=0,ft=0,st=OK:
    Mar  4 07:00:13 raspiez mysgw: TSF:SRT:OK
    Mar  4 07:00:13 raspiez mysgw: TSF:SAN:OK
    Mar  4 07:00:37 raspiez mysgw: Ethernet client disconnected.
    Mar  4 07:00:37 raspiez mysgw: New connection from 192.168.1.11
    Mar  4 07:00:37 raspiez mysgw: GWT:TSA:C=0,CONNECTED
    Mar  4 07:00:37 raspiez mysgw: GWT:TSA:C=1,DISCONNECTED
    

    After this point (again after a reconnect from the controller) no more messages from any node PLUS the cpu usage stayed normal (what makes it even worse at this moment, as I would have to create a script which monitors the logfile and restarts the mysgw service in this situation). As soon as the service is restarted, everything is working fine again.

    What happens after this point in the log:

    Mar  4 07:00:37 raspiez mysgw: GWT:RFC:C=0,MSG=0;0;3;0;2;
    Mar  4 07:15:13 raspiez mysgw: TSF:SAN:OK
    Mar  4 07:20:13 raspiez mysgw: TSM:READY:NWD REQ
    Mar  4 07:20:13 raspiez mysgw: TSF:MSG:SEND,0-0-255-255,s=255,c=3,t=20,pt=0,l=0,sg=0,ft=0,st=OK:
    Mar  4 07:30:13 raspiez mysgw: TSF:SRT:OK
    Mar  4 07:30:13 raspiez mysgw: TSF:SAN:OK
    Mar  4 07:30:37 raspiez mysgw: GWT:TSA:C=0,DISCONNECTED
    Mar  4 07:30:37 raspiez mysgw: Ethernet client disconnected.
    Mar  4 07:30:37 raspiez mysgw: New connection from 192.168.1.11
    Mar  4 07:30:37 raspiez mysgw: GWT:TSA:C=0,CONNECTED
    Mar  4 07:30:37 raspiez mysgw: GWT:RFC:C=0,MSG=0;0;3;0;2;
    Mar  4 07:40:13 raspiez mysgw: TSM:READY:NWD REQ
    Mar  4 07:40:13 raspiez mysgw: TSF:MSG:SEND,0-0-255-255,s=255,c=3,t=20,pt=0,l=0,sg=0,ft=0,st=OK:
    Mar  4 07:45:13 raspiez mysgw: TSF:SAN:OK
    Mar  4 08:00:13 raspiez mysgw: TSM:READY:NWD REQ
    Mar  4 08:00:13 raspiez mysgw: TSF:MSG:SEND,0-0-255-255,s=255,c=3,t=20,pt=0,l=0,sg=0,ft=0,st=OK:
    Mar  4 08:00:13 raspiez mysgw: TSF:SRT:OK
    Mar  4 08:00:13 raspiez mysgw: TSF:SAN:OK
    Mar  4 08:00:37 raspiez mysgw: GWT:TSA:C=0,DISCONNECTED
    Mar  4 08:00:37 raspiez mysgw: Ethernet client disconnected.
    Mar  4 08:00:37 raspiez mysgw: New connection from 192.168.1.11
    Mar  4 08:00:37 raspiez mysgw: GWT:TSA:C=0,CONNECTED
    

    and so on....

    It seems that the increasing cpu usage is only a symptom for the real problem.
    As I am using this in production I will dis-apply the patch and use the daemon as before (beacuse using the python script for cpu-usage-monitoring makes the situation somehow controllable for me).
    Maybe you could have an additional eye on this please? Could I help you with further information? Maybe I could add some additional logging somewhere in the code?

    Thanks again and cheers,
    Otto


  • Code Contributor

    @otto001 I'm trying to reproduce this problem, but so far I've got nothing beyond the normal behavior of mysgw.
    I tried with a RPi1 and RPi3 using the fhem controller with the latest raspbian.



  • @marceloaqno said in 💬 Building a Raspberry Pi Gateway:

    @otto001 I'm trying to reproduce this problem, but so far I've got nothing beyond the normal behavior of mysgw.
    I tried with a RPi1 and RPi3 using the fhem controller with the latest raspbian.

    My uptime is at 4 days now. so far still working with your patch. CPU is at 2% and sensor network still working correctly. will report if that changes.



  • I've been using your restarting method and its been working ok and has done one restart in 5 days.
    However I now see something else where altho cpu use is fine, none of my nodes can communicate to the gateway. My controller can connect to the gateway no problem but there are no messages received. Restarting nodes does not help. Only a manual restart of the gateway gets things going again - at least for a while anyway.
    Where is the log output from the gateway to be found? I know it can be run from the bash prompt to write the output to screen but how about logging the installed service output?


  • Mod

    @nick-willis the log is sent to syslog by default. See https://www.mysensors.org/build/raspberry#troubleshooting for details.



  • @marceloaqno : This is strange. I am using a RPi 1 on this gateway with raspbian Jessie. Beside the GW-service there is only a small python programm which listens on an UPD-Port and plays an mp3 if it receives suitable data (for doorbell). Since March 4, 20:15 there were several restarts due to high cpu usage (after dis-applying your patch):

    2018-03-04 23:01:03 cpu (99.7) very high! --> restarting service
    2018-03-05 07:31:03 cpu (99.7) very high! --> restarting service
    2018-03-05 11:01:03 cpu (98.7) very high! --> restarting service
    2018-03-05 13:31:04 cpu (94.7) very high! --> restarting service
    2018-03-06 11:31:03 cpu (99.7) very high! --> restarting service
    2018-03-06 12:31:03 cpu (98.7) very high! --> restarting service
    2018-03-07 06:01:03 cpu (94.8) very high! --> restarting service
    2018-03-07 22:31:03 cpu (99.8) very high! --> restarting service
    

    With this "auto-restarts" the sensors are working fine, I did not notice any problems.

    However, I just upgraded to the recent Stretch (what takes a LONG time on RPi 1 and made me struggle a little bit with the new network names). I also rebuilt the GW of course and will report here what will happen....

    @Nick-Willis : did you apply the patch of marceloaqno or not? Did you enable debugging? (see here )

    Cheers,
    Otto


  • Code Contributor

    @otto001 In a new attempt to trigger this problem, I am using a script that will force the fhem controller to reconnect every 30s to the gateway (built with mysensors master branch, unpatched), and sends me a note in case of high CPU usage:

    I'll leave it running for a few days to see what happens.

    Here is the script, if anyone is interested:

    #!/bin/sh
    
    while true; do
      (echo "set mysgw disconnect"; echo "quit") | telnet localhost 7072 > /dev/null 2>&1
      sleep 1
      (echo "set mysgw connect"; echo "quit") | telnet localhost 7072 > /dev/null 2>&1
      sleep 1
    
      cpu_percent=$(ps -C "mysgw" -o %cpu=)
      cpu_percent=${cpu_percent%%.*}
      if [ "$cpu_percent" -ge 90 ]
      then
        echo "ALERT: HIGH CPU USAGE"
        # pushbullet script from https://gist.github.com/outadoc/189bd3ccbf5d6e0f39e4
        /home/pi/pushbullet.sh "RPi1: HIGH CPU USAGE"
        exit
      fi
    
      sleep 30
    done
    


  • @marceloaqno : Thank you!
    Just a notice: I do NOT disconnect, I just connect every 30 minutes. Has been working for me since more than 2 years (ancient ms-gw version on RPi).

    Yesterday I did a dist-upgrade to stretch on the "problematic" gw (as mentioned above) - without your patch but with my monitoring-script running. It is a little bit to early I presume, but no high cpu problems so far. I will report back here in a few days. Maybe this problem is really related to old libraries or something?! If this is running stable for a few days I will apply your patch and see what happens.
    Thanks again!

    Cheers,
    Pula


  • Code Contributor

    @otto001 After a few hours running the reconnect script, I noticed several error messages in my gateway log:

    accept(): Too many open files
    

    The problem was that the gateway wasn't releasing the socket descriptor after each disconnection of the controller. After reaching the limit (mine was 1036) the controller can't connect.

    I'm not entirely sure that this problem is related to what you're having. You can check how many file descriptors currently opened by the gateway with the command below

    sudo lsof -u root |grep mysgw |wc -l
    

    The fix:
    https://github.com/marceloaqno/MySensors/commit/a40d4441b7460225100398ff6f2581c2b0df36ea



  • How do I update from master branch to development branch?


  • Mod

    Why do you want to do that? Development version is still work in progress



  • I'm using a raspberry pi gateway in home-assistant.
    Sometimes my gateway doesn't work anymore, and when I restart the service, it is running good
    I used ./configure --my-transport=nrf24 --my-rf24-irq-pin=15 --my-gateway=ethernet --my-port=5003


  • Mod

    Read the article again, there is the instruction on how to download the development version, but before you have to uninstall the mysgw service and rename the current mysensors folder to keep as backup.


  • Code Contributor

    @gieljnssns The fixes I mentioned above haven't yet been applied to the development branch. Eventually they will be, but I'm still doing some testing.



  • @marceloaqno :
    Thank you!!! Should this patch be applied together with your first patch?
    Interesting:
    After some days without problems on the newest raspbian packages the gw hung again, but WITHOUT high cpu usage (and WITHOUT your first patch applied). There were just no more reads from the sensors in the log, only the re-connects of fhem. After restarting the service, everything is fine again.
    Unfortunately I did see your post after that 😞
    But I checked the log and could not find the words "too" or "Too" in the log (running service with -d).
    Some minutes after restarting I checked how many open files there were with the command you supplied: 21

    In the meantime I have created a small udp listening service which restarts the service if a certain string is received, so I can restart the service by double-clicking one of my switches without the need of login to the gw (also for the wife)....

    @gieljnssns : I think you are experiencing exactly the same problem we are discussing 🙂

    Thanks again!
    Cheers,
    Otto


  • Mod

    I'm using dietpi and I am not having big issues even running 2 gateway instances with 2 different radios


  • Code Contributor

    @otto001 The second patch can be applied without the first one.



  • @gohan :
    dietpi looks interesting! did not know about this yet.
    what hardware are you using? and what version of mysgw?



  • @marceloaqno :
    THANKS! Just applied your patch.
    I will report in a few days when I can see if the problem is solved...
    Cheers,
    Otto



  • Can someone tell me how to apply this patch?


  • Mod

    @otto001 normal rpi3 and mysgw 2.2



  • I need help with my Rpi mqtt-gw.
    I tried to get dev-branch working but changed now to stable. All the install routines run without problems. The service just doesn't seem to work and I can't figure out why.

    1. Rpi W, Raspbian wheezy, nRF24-PA, MQTT-gw, Mosquitto and Openhab2 on same board
      Mosquitto-log:
    1521010232: New connection from 127.0.0.1 on port 1883.
    1521010232: New client connected from 127.0.0.1 as mygateway1 (c1, k15, u'xxxx').
    1521010232: Socket error on client mygateway1, disconnecting.
    

    syslog:

    Mar 14 08:51:02 GwMqOH2 systemd[1]: Starting MySensors Gateway daemon...
    Mar 14 08:51:02 GwMqOH2 systemd[1]: Started MySensors Gateway daemon.
    Mar 14 08:51:03 GwMqOH2 mysgw: Starting gateway...
    Mar 14 08:51:03 GwMqOH2 mysgw: Protocol version - 2.2.0
    Mar 14 08:51:03 GwMqOH2 mysgw: MCO:BGN:INIT GW,CP=RNNGLSQX,VER=2.2.0
    Mar 14 08:51:03 GwMqOH2 mysgw: TSF:LRT:OK
    Mar 14 08:51:03 GwMqOH2 mysgw: TSM:INIT
    Mar 14 08:51:03 GwMqOH2 mysgw: TSF:WUR:MS=0
    Mar 14 08:51:03 GwMqOH2 mysgw: TSM:INIT:TSP OK
    Mar 14 08:51:03 GwMqOH2 mysgw: TSM:INIT:GW MODE
    Mar 14 08:51:03 GwMqOH2 mysgw: TSM:READY:ID=0,PAR=0,DIS=0
    Mar 14 08:51:03 GwMqOH2 mysgw: MCO:REG:NOT NEEDED
    Mar 14 08:51:03 GwMqOH2 mysgw: MCO:BGN:STP
    Mar 14 08:51:03 GwMqOH2 mysgw: MCO:BGN:INIT OK,TSP=1
    Mar 14 08:51:03 GwMqOH2 mysgw: GWT:RMQ:MQTT RECONNECT
    Mar 14 08:51:03 GwMqOH2 mysgw: connected to 127.0.0.1
    Mar 14 08:51:03 GwMqOH2 mysgw: GWT:RMQ:MQTT CONNECTED
    Mar 14 08:51:03 GwMqOH2 mysgw: GWT:TPS:TOPIC=mysensors-out/0/255/0/0/18,MSG SENT
    Mar 14 08:51:03 GwMqOH2 systemd[1]: mysgw.service: main process exited, code=killed, status=11/SEGV
    Mar 14 08:51:03 GwMqOH2 systemd[1]: Unit mysgw.service entered failed state```
    
    
    
    GW configure-line:
    

    ./configure --my-transport=nrf24 --my-gateway=mqtt --my-controller-ip-address=127.0.0.1 --my-mqtt-publish-topic-prefix=mysensors-out --my-mqtt-subscribe-topic-prefix=mysensors-in --my-mqtt-client-id=mygateway1 --my-rf24-irq-pin=15 --my-leds-err-pin=12 --my-leds-rx-pin=16 --my-leds-tx-pin=18 --my-mqtt-user=xxxx --my-mqtt-password=yyyyy --my-signing=password --my-signing-password=zzzzzz```

    I have checked mosquitto has correct user-pw combination, but what should I check next? Help!


  • Mod

    @masmat said in 💬 Building a Raspberry Pi Gateway:

    --my-mqtt-client-id=mygateway1

    Do you have another client named mygateway1 connecting to mqtt? Try changing it to a different name just to play safe



  • @gohan Can I just edit mysgw.cpp and do "daemon-reload"?
    I have just this one gw. And openHab2 but that has a different id.


  • Mod

    No, you need to recompile it again in case you make that change. Have you ever tried dietpi for RPI?



  • @gohan OK. I did that, the same socket error remains in Mosquitto just under new id.
    Is my syntax correct or am I somehow having problems with mosquitto user-pw...?

    Haven't tried DietPi. Would Mys+Mosquitto+Openhab2 have trouble running on it? Or why should I change to it?


  • Mod

    have you tried connecting with another mqtt client like mqttfx to see if everything is working?


  • Code Contributor

    @masmat What is the mqtt broker / version you are using?


  • Code Contributor

    @gieljnssns One way is to replace the changed files, in this case EthernetServer.cpp for the first patch and EthernetClient.cpp for the second patch.

    You can download from:
    https://raw.githubusercontent.com/marceloaqno/MySensors/linux-fix-stability/drivers/Linux/EthernetServer.cpp
    https://raw.githubusercontent.com/marceloaqno/MySensors/linux-fix-stability/drivers/Linux/EthernetClient.cpp

    Here is a step-by-step:

    git clone https://github.com/mysensors/MySensors.git
    cd MySensors
    curl https://raw.githubusercontent.com/marceloaqno/MySensors/linux-fix-stability/drivers/Linux/EthernetServer.cpp -o drivers/Linux/EthernetServer.cpp
    curl https://raw.githubusercontent.com/marceloaqno/MySensors/linux-fix-stability/drivers/Linux/EthernetClient.cpp -o drivers/Linux/EthernetClient.cpp
    

    from here just run ./configure with your options and then make



  • @marceloaqno Mosquitto v1.4.14.
    The broker is working, at least sending & receiving command line (_sub & _pub) messages.



  • @gohan

    Can you provide some installation instructions for dietpi?
    I will try this...


  • Mod

    just download the image and do the same as a Raspian image. I haven't tried mqtt gateway yet, so I don't know if it may be a gateway bug or else.



  • @marceloaqno :
    Hi, unfortunately the latest patch did not work for me.
    Still the gw stops receiving, but without high cpu usage 😞
    Fortunately I can restart the gw now using a button and this udp-scripts 🙂

    Of cource I could give dietpi a try, but I would think, that a general solution would be better (for other users as well)

    cheers,
    Otto



  • @gohan I had another sd card and tried a ready image of DietPi with Mosquitto pre-installed.
    I tried it without user/password and mosquitto accepting anonymous but:

    /var/log/mosquitto/mosquitto.log:
    1521141160: Socket error on client <unknown>, disconnecting.
    1521141160: New connection from 127.0.0.1 on port 1883.
    ..keeps repeating...

    ...and sudo ./bin/mysgw -d:

    mysgw: Starting gateway...
    mysgw: Protocol version - 2.2.0
    mysgw: MCO:BGN:INIT GW,CP=RNNGLSQX,VER=2.2.0
    mysgw: TSF:LRT:OK
    mysgw: TSM:INIT
    mysgw: TSF:WUR:MS=0
    mysgw: TSM:INIT:TSP OK
    mysgw: TSM:INIT:GW MODE
    mysgw: TSM:READY:ID=0,PAR=0,DIS=0
    mysgw: MCO:REG:NOT NEEDED
    mysgw: MCO:BGN:STP
    mysgw: MCO:BGN:INIT OK,TSP=1
    mysgw: GWT:RMQ:MQTT RECONNECT
    mysgw: connected to 127.0.0.1
    mysgw: GWT:RMQ:MQTT RECONNECT
    mysgw: connected to 127.0.0.1
    mysgw: GWT:RMQ:MQTT RECONNECT```


  • 1st patch is still working good for me. have had no issues since applying it.

    question. is it normal/correct for the gateway to ping or spam? every 10 seconds i see the gateway announce it's version.
    its not doing the full restart or anything.. just giving the 2.2.0 every 10 seconds.


  • Mod

    @masmat have you tried with ethernet gateway? If I have time I'll try the mqtt this weekend

    @mvader I never noticed that.... is it the mqtt GW?



  • @gohan How would I interface the rest of my HA without MQTT...that's at the center of my plan really 😞


  • Mod

    I think OH should support it, but I was just asking to make a test.



  • @gohan I configured:
    ./configure --my-transport=nrf24 --my-gateway=ethernet --my-controller-ip-address=127.0.0.1 --my-rf24-irq-pin=15 --my-leds-err-pin=12 --my-leds-rx-pin=16 --my-leds-tx-pin=18 --my-signing=password --my-signing-password=ZZZZZZ

    ./bin/mysgw -d:

    mysgw: Starting gateway...
    mysgw: Protocol version - 2.2.0
    mysgw: MCO:BGN:INIT GW,CP=RNNGLSQX,VER=2.2.0
    mysgw: TSF:LRT:OK
    mysgw: TSM:INIT
    mysgw: TSF:WUR:MS=0
    mysgw: TSM:INIT:TSP OK
    mysgw: TSM:INIT:GW MODE
    mysgw: TSM:READY:ID=0,PAR=0,DIS=0
    mysgw: MCO:REG:NOT NEEDED
    mysgw: connect: Connection refused
    mysgw: failed to connect
    mysgw: GWT:TIN:ETH OK
    mysgw: connect: Connection refused
    mysgw: failed to connect
    mysgw: GWT:TPS:ETH OK
    mysgw: connect: Connection refused
    mysgw: failed to connect
    mysgw: GWT:TPS:ETH OK
    

    The controller doesn't exist on the DietPi card yet but I'm not sure if that's causing the problem.


  • Mod

    @masmat said in 💬 Building a Raspberry Pi Gateway:

    --my-controller-ip-address=127.0.0.1

    remove that parameter as it is not needed for ethernet


  • Code Contributor

    @masmat I did a test with the following configuration:

    • Raspberry Pi 1 with Raspbian (2017-11-29-raspbian-stretch-lite)

      pi@raspberrypi:~/MySensors $ lsb_release -a
      No LSB modules are available.
      Distributor ID: Raspbian
      Description:    Raspbian GNU/Linux 9.1 (stretch)
      Release:        9.1
      Codename:       stretch
      
    • MySensors master branch - Protocol version - 2.2.0

      ./configure --my-transport=nrf24 --my-gateway=mqtt --my-controller-ip-address=127.0.0.1 --my-mqtt-publish-topic-prefix=mysensors-out --my-mqtt-subscribe-topic-prefix=mysensors-in --my-mqtt-client-id=m ygateway1 --my-mqtt-user=rpi --my-mqtt-password=password
      
    • Mosquitto version 1.4.10 (build date Fri, 22 Dec 2017 08:19:25 +0000) [installed from apt-get]

      pi@raspberrypi:~/MySensors $ cat /etc/mosquitto/mosquitto.conf
      # Place your local configuration in /etc/mosquitto/conf.d/
      #
      # A full description of the configuration file is at
      # /usr/share/doc/mosquitto/examples/mosquitto.conf.example
      
      pid_file /var/run/mosquitto.pid
      
      persistence true
      persistence_location /var/lib/mosquitto/
      
      log_dest file /var/log/mosquitto/mosquitto.log
      
      allow_anonymous false
      password_file /etc/mosquitto/passwordfile
      
      include_dir /etc/mosquitto/conf.d
      

      Added the mosquitto user (user=rpi, password=password) with:

      sudo mosquitto_passwd -c /etc/mosquitto/passwordfile rpi
      

    It didn't show any error to connect to the MQTT broker:

    pi@raspberrypi:~/MySensors $ sudo ./bin/mysgw -d
    mysgw: Starting gateway...
    mysgw: Protocol version - 2.2.0
    mysgw: MCO:BGN:INIT GW,CP=RNNGL---,VER=2.2.0
    mysgw: TSF:LRT:OK
    mysgw: TSM:INIT
    mysgw: TSF:WUR:MS=0
    mysgw: TSM:INIT:TSP OK
    mysgw: TSM:INIT:GW MODE
    mysgw: TSM:READY:ID=0,PAR=0,DIS=0
    mysgw: MCO:REG:NOT NEEDED
    mysgw: MCO:BGN:STP
    mysgw: MCO:BGN:INIT OK,TSP=1
    mysgw: GWT:RMQ:MQTT RECONNECT
    mysgw: connected to 127.0.0.1
    mysgw: GWT:RMQ:MQTT CONNECTED
    mysgw: GWT:TPS:TOPIC=mysensors-out/0/255/0/0/18,MSG SENT
    mysgw: TSF:MSG:READ,5-5-0,s=255,c=3,t=24,pt=1,l=1,sg=0:1
    mysgw: TSF:MSG:PINGED,ID=5,HP=1
    mysgw: TSF:MSG:SEND,0-0-5-5,s=255,c=3,t=25,pt=1,l=1,sg=0,ft=0,st=OK:1
    mysgw: TSF:MSG:READ,5-5-0,s=255,c=3,t=32,pt=5,l=4,sg=0:500
    mysgw: GWT:TPS:TOPIC=mysensors-out/5/255/3/0/32,MSG SENT
    mysgw: TSF:MSG:READ,5-5-0,s=255,c=3,t=33,pt=5,l=4,sg=0:4951
    mysgw: GWT:TPS:TOPIC=mysensors-out/5/255/3/0/33,MSG SENT
    mysgw: TSF:MSG:READ,5-5-0,s=1,c=1,t=37,pt=4,l=4,sg=0:36053
    mysgw: GWT:TPS:TOPIC=mysensors-out/5/1/1/0/37,MSG SENT
    mysgw: TSF:MSG:READ,5-5-0,s=255,c=3,t=32,pt=5,l=4,sg=0:500
    mysgw: GWT:TPS:TOPIC=mysensors-out/5/255/3/0/32,MSG SENT
    mysgw: TSF:MSG:READ,5-5-0,s=255,c=3,t=33,pt=5,l=4,sg=0:5000
    mysgw: GWT:TPS:TOPIC=mysensors-out/5/255/3/0/33,MSG SENT
    mysgw: TSF:MSG:READ,5-5-0,s=1,c=1,t=37,pt=4,l=4,sg=0:36055
    mysgw: GWT:TPS:TOPIC=mysensors-out/5/1/1/0/37,MSG SENT
    mysgw: TSF:MSG:READ,5-5-0,s=255,c=3,t=32,pt=5,l=4,sg=0:500
    mysgw: GWT:TPS:TOPIC=mysensors-out/5/255/3/0/32,MSG SENT
    mysgw: TSF:MSG:READ,5-5-0,s=255,c=3,t=33,pt=5,l=4,sg=0:5000
    mysgw: GWT:TPS:TOPIC=mysensors-out/5/255/3/0/33,MSG SENT
    mysgw: TSF:MSG:READ,5-5-0,s=1,c=1,t=37,pt=4,l=4,sg=0:36055
    mysgw: GWT:TPS:TOPIC=mysensors-out/5/1/1/0/37,MSG SENT
    


  • @gohan said in 💬 Building a Raspberry Pi Gateway:

    @masmat have you tried with ethernet gateway? If I have time I'll try the mqtt this weekend

    @mvader I never noticed that.... is it the mqtt GW?

    I'm not using mqtt.
    for debug purposes i use MYSController
    every 10 seconds on the dot. it shows me the version of the gateway.

    201	3/15/2018 20:47:15	RX	0 - Gateway	INTERNAL	C_INTERNAL	NO	I_VERSION	2.2.0
    202	3/15/2018 20:47:25	RX	0 - Gateway	INTERNAL	C_INTERNAL	NO	I_VERSION	2.2.0
    203	3/15/2018 20:47:35	RX	0 - Gateway	INTERNAL	C_INTERNAL	NO	I_VERSION	2.2.0
    204	3/15/2018 20:47:45	RX	0 - Gateway	INTERNAL	C_INTERNAL	NO	I_VERSION	2.2.0
    205	3/15/2018 20:47:55	RX	0 - Gateway	INTERNAL	C_INTERNAL	NO	I_VERSION	2.2.0
    206	3/15/2018 20:48:05	RX	0 - Gateway	INTERNAL	C_INTERNAL	NO	I_VERSION	2.2.0
    
    

    @marceloaqno any ideas about that?


  • Mod

    @mvader oh, that's normal. I though you meant something else



  • Yesterday I cloned the latest version on a recent raspbian (9.3) and I applied the first patch of @marceloaqno .
    We will see. So long there were no problems. I will send an update in a few days...
    As a last help I could switch to mqtt and do a restart after a defined amount of time (if no events are received)....

    Cheers,
    Otto


  • Mod

    @marceloaqno I got my gw rfm69 gateway suddenly stopped communicating with nodes. I tried everything to reinstall it but without luck. I was able to have it running on my test rpi with a complete OS reinstall. Is there anything else I need need to clean up from my install to reset every settings? (besides the mysensors folder and mysensors.dat file I already deleted)



  • How can I monitor the traffic data between the raspberry and RF module (NRF24L01) on a Ethernet gateway ??

    My gateway is built for Ethernet. I start the gateway with "service mysgw start"
    Now, I would like to get the same data output than output debug (./bin/mysgw -d) but without stop mysgw service.
    I need to use MYSController as Ethernet client at the same time.

    Thanks


  • Mod



  • @marceloaqno What does your mosquitto.log show?
    I did a fresh install of DietPi (stretch), Mosquitto and MySensors --branch master. I left out everything and pretty much did the configure command as you did. I get the same result, but mosuiqtto log shows:

    1521584708: New connection from 127.0.0.1 on port 1883.
    1521584708: New client connected from 127.0.0.1 as mygateway1 (c1, k15, u'masi').
    1521584733: Socket error on client mygateway1, disconnecting.
    1521584778: New connection from 127.0.0.1 on port 1883.
    

    So is this normal?
    I have one sensors built that's not connecting (its log shows it just trying and trying..). I would like to user simple password and the LEDs, I will build one extra sensors just to help testing.



  • @MasMat : what does your mysgw.log show?



  • @mfalkvidd Thanks fer info, now I can see the serial protocol as well in the syslog. Next step should be to have a logfile dedicated to mysgw.



  • @otto001
    Syslog:

    Mar 21 20:06:05 DietPi systemd[1]: Started MySensors Gateway daemon.
    Mar 21 20:06:05 DietPi mysgw: Starting gateway...
    Mar 21 20:06:05 DietPi mysgw: Protocol version - 2.2.0
    Mar 21 20:06:05 DietPi mysgw: MCO:BGN:INIT GW,CP=RNNGL---,VER=2.2.0
    Mar 21 20:06:05 DietPi mysgw: TSF:LRT:OK
    Mar 21 20:06:05 DietPi mysgw: TSM:INIT
    Mar 21 20:06:05 DietPi mysgw: TSF:WUR:MS=0
    Mar 21 20:06:05 DietPi mysgw: TSM:INIT:TSP OK
    Mar 21 20:06:05 DietPi mysgw: TSM:INIT:GW MODE
    Mar 21 20:06:05 DietPi mysgw: TSM:READY:ID=0,PAR=0,DIS=0
    Mar 21 20:06:05 DietPi mysgw: MCO:REG:NOT NEEDED
    Mar 21 20:06:05 DietPi mysgw: MCO:BGN:STP
    Mar 21 20:06:05 DietPi mysgw: MCO:BGN:INIT OK,TSP=1
    Mar 21 20:06:05 DietPi mysgw: GWT:RMQ:MQTT RECONNECT
    Mar 21 20:06:05 DietPi mysgw: connected to 127.0.0.1
    Mar 21 20:06:05 DietPi mysgw: GWT:RMQ:MQTT CONNECTED
    Mar 21 20:06:05 DietPi mysgw: GWT:TPS:TOPIC=mysensors-out/0/255/0/0/18,MSG SENT
    

    Where is mysgw.log?



  • @MasMat : I just forgot, that I reconfigured rsyslogd to log mysgw to a different file. syslog is correct.

    I do not use mqtt for mysensors yet, but the syslog seems good?



  • Was pointed here from another post, having serious issues with high CPU utilization op the gateway, is there any workaround and the moment?

    top:

    asks: 157 total,   2 running, 155 sleeping,   0 stopped,   0 zombie
    %Cpu(s):  2.5 us, 23.0 sy,  0.0 ni, 74.3 id,  0.1 wa,  0.0 hi,  0.0 si,  0.0 st
    KiB Mem :   949580 total,   448732 free,   146912 used,   353936 buff/cache
    KiB Swap:   102396 total,   102396 free,        0 used.   737656 avail Mem 
    
      PID USER      PR  NI    VIRT    RES    SHR S  %CPU %MEM     TIME+ COMMAND                                                                                                                                         
      337 root      20   0   20492   1060    932 R 100.0  0.1  28:54.55 mysgw                                                                                                                                           
     3947 pi        20   0    8248   3324   2736 R   1.6  0.4   0:00.82 top                                                                                                                                             
      447 homeass+  20   0  340112  63684   9916 S   1.0  6.7   3:28.71 hass                                                                                                                                            
        7 root      20   0       0      0      0 S   0.3  0.0   0:04.18 rcu_sched                                                                                                                                       
      767 root      20   0  126572   8628   6544 S   0.3  0.9   0:00.95 piplight-daemon                                                                                                                                      
    
    PRETTY_NAME="Raspbian GNU/Linux 9 (stretch)"
    NAME="Raspbian GNU/Linux"
    VERSION_ID="9"
    VERSION="9 (stretch)"
    Linux raspberrypi 4.9.59-v7+ #1047 SMP Sun Oct 29 12:19:23 GMT 2017 armv7l GNU/Linux
    

    Rebooting the pi sometimes helps, sometimes freezes the pi
    seeing nothing strange in the mysensors log what so ever
    running MySensors Version 2.2.0
    and Home Assistant Version 0.64.0
    Anyone can point me in the direction where to troubleshoot this further ?
    its not a high traffic gateway (around 10 sensors connected of which 5 updating every 15 minutes)


  • Mod

    @richard-van-der-plas the best workaround so far is in the post I linked to.


  • Code Contributor

    @mvader The gateway will respond with an I_VERSION every time a controller connected to port 5003 sends an I_VERSION request.


  • Code Contributor

    @gohan Sorry to hear that, mysgw doesn't change any system files, a simple reboot and rebuild of the gateway should be enough to resume communication in a case of more serious error.


  • Code Contributor

    @masmat This is my mosquitto.log

    1521680648: mosquitto version 1.4.10 (build date Fri, 22 Dec 2017 08:19:25 +0000) starting
    1521680648: Config loaded from /etc/mosquitto/mosquitto.conf.
    1521680648: Opening ipv4 listen socket on port 1883.
    1521680648: Opening ipv6 listen socket on port 1883.
    1521762617: Saving in-memory database to /var/lib/mosquitto/mosquitto.db.
    1521763549: New connection from 127.0.0.1 on port 1883.
    1521763549: New client connected from 127.0.0.1 as mygateway1 (c1, k15, u'rpi').
    

    A socket error message:

    1521764339: Socket error on client mygateway1, disconnecting.
    

    shows only if I stop/exit mysgw.



  • @marceloaqno OK, I will look into that once I have an extra sensor feeding my gw (the one I built is a little complex and could be buggy).

    Another question: I configured mysgw without "simple password" to sort out problems.
    Now to reconfigure mysgw I have to run the "./configure --blah --blahblah..." command and "make", but do I also have to do "make install"? And do I have to re-start & enable the service? Should I stop it first also? Anybody got a step-by-step for this?


  • Mod

    You could also make a simple node running mock mysensors sketch that can simulate a working sensor, if you need some data running through the gateway. When I recompile the gateway I usually stop the service, uninstall the mysgw service and do the make and make install. I don't really know if it is actually required but I like to keep things clean


  • Code Contributor

    The two patches to fix ethernet stability have been merger into the development branch, and also some changes to the gateway logging. I updated the build instructions to reflect the changes.



  • @gohan I made a sensor that sends DHT11 temp+hum. This is the output (some of it..) from mosquitto_sub to topic mysensors-out. So I appear to have a something working. OpenHab2 is not finding any items still...

    pi@DietPi:~ $ mosquitto_sub  -u XXXXXX -P YYYYYY -v -t 'mysensors-out/#'
    mysensors-out/99/1/1/0/0 14.0
    mysensors-out/99/0/1/0/1 46.0
    mysensors-out/99/1/1/0/0 15.0
    mysensors-out/99/0/1/0/1 45.0
    mysensors-out/99/1/1/0/0 15.0
    mysensors-out/99/0/1/0/1 45.0
    mysensors-out/99/0/1/0/1 44.0
    mysensors-out/99/0/1/0/1 45.0
    mysensors-out/99/0/1/0/1 44.0
    mysensors-out/99/1/1/0/0 15.0
    mysensors-out/99/0/1/0/1 45.0
    mysensors-out/99/1/1/0/0 15.0
    mysensors-out/99/0/1/0/1 44.0
    mysensors-out/99/0/1/0/1 45.0
    mysensors-out/99/0/1/0/1 44.0
    mysensors-out/99/1/1/0/0 15.0
    mysensors-out/99/0/1/0/1 44.0
    mysensors-out/99/1/1/0/0 15.0
    

    Once I changed the config to include simple password, it's not showing anything anymore in mosquitto_sub
    It would appear that something is missing from my setup or there's a bug in the configure-line. Can someone tell if there's a bug here somewhere:

    sudo ./configure --my-transport=nrf24 --my-rf24-irq-pin=15 --my-signing=password --my-signing-password=ZZZZZZ --my-gateway=mqtt --my-controller-ip-address=127.0.0.1 --my-mqtt-user=XXXXXX --my-mqtt-password=YYYYYY --my-mqtt-publish-topic-prefix=mysensors-out --my-mqtt-subscribe-topic-prefix=mysensors-in --my-mqtt-client-id=mygateway1 --my-leds-err-pin=12 --my-leds-rx-pin=16 --my-leds-tx-pin=18
    

  • Mod

    Look also in node log, that's the first place to look at



  • @gohan I did, I will post it (but it appears to send normally). But the only things I changed was:

    1. Rpi configure added: --my-signing=password --my-signing-password=ZZZZZZ
    2. In the nodes code: #define MY_SIGNING_SIMPLE_PASSWD = "ZZZZZZ"

  • Mod

    I use also these parameters with the normal signing

    --my-signing=software --my-signing-request-signatures --my-signing-weak_security --my-signing-debug
    

    of course the debug parameter is there only for debug reasons


  • Contest Winner

    @masmat check that the version you are using (release or beta) match your use of the simple flags, as they differ at the moment.



  • @anticimex Both Arduino IDE is 2.2 and Rpi is compiled with 2.2 stable.
    I'm seeing !TSF:MSG:SIGN FAIL in the serial monitor so something is not compatible... I will try making password >8 characters next (currently 6).

    I will also add those parameters to see if that makes a difference before reuploading arduino code


  • Contest Winner

    @masmat if you add the signing debug flag and use the log parser on the homepage it should become clear what the problem is. You can also use the troubleshooting guide in the signing documentation.



  • @anticimex This is what's happening in the gw:

    TSF:MSG:READ,36-192-15,s=69,c=0,t=81,pt=1,l=21,sg=0:221
    !TSF:MSG:LEN,16!=28
    TSF:MSG:READ,75-68-77,s=48,c=1,t=110,pt=1,l=25,sg=1:249
    !TSF:MSG:LEN,16!=32

    The parser didn't really help much: more baffled than before....and I came away from the troubleshooting guide feeling really stupid 🙂


  • Contest Winner

    @masmat looks to me that your gateway is not set up for signing


  • Mod

    @anticimex I think he didn't use all the parameters for the configure, right?


  • Contest Winner

    @gohan the simple flags should not need more args, but I don't use a rPi as gw so I honestly am not sure exactly the args to use. The beta documentation has clear instructions for rPi signing, but those are specifically for beta branch and probably don't map exactly to the release yet.



  • @gohan The whole configure-line:

    sudo ./configure --my-transport=nrf24 --my-rf24-irq-pin=15 --my-signing=software --my-signing-request-signatures --my-signing-weak_security --my-signing-debug --my-signing=password --my-signing-password=ZZZZZZ --my-gateway=mqtt --my-controller-ip-address=127.0.0.1 --my-mqtt-user=XXXX --my-mqtt-password=YYYYY --my-mqtt-publish-topic-prefix=mysensors-out --my-mqtt-subscribe-topic-prefix=mysensors-in --my-mqtt-client-id=mygateway1 --my-leds-err-pin=12 --my-leds-rx-pin=16 --my-leds-tx-pin=18
    

    If anyone can tell what's missing or if there's a typo?


  • Contest Winner


  • Contest Winner

    @masmat you have redundant flags. The password option require no other signing flags. Only if you select software as signing backend you need other options (and none of the simple flags)

    And remember that if you use software signing and not password signing, you need to personalize the GW and/or node.



  • @anticimex I thought so too, but I'm grasping at straws to get the signing to work.
    To clarify, is the following enough for simple signing: --my-signing-debug --my-signing=password --my-signing-password=ZZZZZZ

    And the arduino code #define MY_SIGNING_SIMPLE_PASSWD = "ZZZZZZ"
    Any difference where it's placed in the code? Anything else to check for?


  • Contest Winner

    @masmat it needs to be defined prior to the inclusion of mysensors.h. That should be it. (on the arduino node that is).



  • While on the subject: what would be the flags needed for setting the gateway to only use the simple encryption but not the (simple) signing feature?

    I looked in the documentation and the node commands aren't mirrored for the gateway. I was hoping for something like:

    --MY_SIGNING_SIMPLE_PASSWD=flowerpot77
    --MY_ENCRYPTION_SIMPLE_PASSWD=spiderman41


  • Mod

    It's actually not needed since you can still set signing as optional on gateway


  • Contest Winner

    @alowhum that feature is still only available for beta and is documented here: https://www.mysensors.org/apidocs-beta/group__SecuritySettingGrpPub.html

    EDIT: not yet for rPi

    Pull requests are welcome. I don't have time for this at the moment.



  • Right. So is this correct?

    NODES (arduino nano)
    On all my nodes I will update them to have this code at the top:

    #define MY_ENCRYPTION_SIMPLE_PASSWD spiderman41 // unfortunately Nano hardware doesn't really have enough memory for signing.
    #define MY_RF24_CHANNEL 100 // in EU the default channel 76 overlaps with wifi.
    #define MY_RF24_DATARATE RF24_1MBPS // slower datarate makes the network more stable?

    GATEWAY (Raspberry Pi Zero W)
    On my gateway I will use this configure code:

    --my-security-password=spiderman41
    --my-rf24-encryption-enabled
    --my-signing-weak_security
    --my-rf24-channel=100
    --extra-cxxflags="-DMY_RF24_DATARATE=(RF24_1MBPS)"


  • Contest Winner

    @alowhum you will need to enable weak security as well as that will enable both signing and encryption with signature requirements from all nodes on the gw



  • @Anticimex thanks!

    as that will enable both signing and encryption with signature requirements from all nodes on the gw
    But I don't want signing? Or do you mean that it will remove that requirement?

    I only need to set that on the gateway, right?
    I've also added a slower datarate, thinking that will also create a more stable connection. I am in a busy urban environment with lots of RF noise. Is that smart?


  • Contest Winner

    @alowhum I thought you did not want signing: "but not the (simple) signing feature?"



  • Yes, I don't want signing. But what you wrote said that it wil ENABLE signing. Check your sentence. Probably a typo, but I wanted to make sure 🙂


  • Contest Winner

    @alowhum the simple security flag enables signing yes.



  • @alowhum said in 💬 Building a Raspberry Pi Gateway:

    --my-signing-weak_security

    But does the "--my-signing-weak_security" enable signing?

    I want to disable signing completely. What flags do I need to use when building a gateway that only uses encryption?


  • Contest Winner

    @alowhum just don't use any flags mentioning signing, personalize the gw according to the documentation and pick the appropriate encryption flag.



  • @anticimex I've built a new node, DHT11 that sends temp&hum data. I reconfigured Rpi with this:

    sudo ./configure --my-transport=nrf24 --my-rf24-irq-pin=15 --my-signing-debug --my-signing=password --my-signing-password=XXXXXX --my-gateway=mqtt --my-controller-ip-address=127.0.0.1 --my-mqtt-user=YYYY --my-mqtt-password=ZZZZZ --my-mqtt-publish-topic-prefix=mysensors-out --my-mqtt-subscribe-topic-prefix=mysensors-in --my-mqtt-client-id=mygateway1 --my-leds-err-pin=12 --my-leds-rx-pin=16 --my-leds-tx-pin=18
    

    This is what I get in gw syslog:

    Apr  2 22:53:11 DietPi mysgw: Starting gateway...
    Apr  2 22:53:11 DietPi mysgw: Protocol version - 2.2.0
    Apr  2 22:53:11 DietPi mysgw: MCO:BGN:INIT GW,CP=RNNGLSQX,VER=2.2.0
    Apr  2 22:53:11 DietPi mysgw: !SGN:BND:PWD<8
    Apr  2 22:53:11 DietPi mysgw: !SGN:INI:BND FAIL
    Apr  2 22:53:11 DietPi mysgw: TSF:LRT:OK
    Apr  2 22:53:11 DietPi mysgw: TSM:INIT
    Apr  2 22:53:11 DietPi mysgw: TSF:WUR:MS=0
    Apr  2 22:53:11 DietPi mysgw: TSM:INIT:TSP OK
    Apr  2 22:53:11 DietPi mysgw: TSM:INIT:GW MODE
    Apr  2 22:53:11 DietPi mysgw: TSM:READY:ID=0,PAR=0,DIS=0
    Apr  2 22:53:11 DietPi mysgw: MCO:REG:NOT NEEDED
    Apr  2 22:53:11 DietPi mysgw: MCO:BGN:STP
    Apr  2 22:53:11 DietPi mysgw: MCO:BGN:INIT OK,TSP=1
    Apr  2 22:53:11 DietPi mysgw: GWT:RMQ:MQTT RECONNECT
    Apr  2 22:53:11 DietPi mysgw: connected to 127.0.0.1
    Apr  2 22:53:11 DietPi mysgw: GWT:RMQ:MQTT CONNECTED
    Apr  2 22:53:11 DietPi mysgw: GWT:TPS:TOPIC=mysensors-out/0/255/0/0/18,MSG SENT
    Apr  2 22:53:23 DietPi mysgw: TSF:MSG:READ,99-99-255,s=255,c=3,t=7,pt=0,l=0,sg=0:
    Apr  2 22:53:23 DietPi mysgw: TSF:MSG:BC
    Apr  2 22:53:23 DietPi mysgw: TSF:MSG:FPAR REQ,ID=99
    Apr  2 22:53:23 DietPi mysgw: TSF:PNG:SEND,TO=0
    Apr  2 22:53:23 DietPi mysgw: TSF:CKU:OK
    Apr  2 22:53:23 DietPi mysgw: TSF:MSG:GWL OK
    Apr  2 22:53:23 DietPi mysgw: SGN:SKP:MSG CMD=3,TYPE=8
    Apr  2 22:53:23 DietPi mysgw: TSF:MSG:SEND,0-0-99-99,s=255,c=3,t=8,pt=1,l=1,sg=0,ft=0,st=OK:0
    Apr  2 22:53:25 DietPi mysgw: TSF:MSG:READ,99-99-0,s=255,c=3,t=24,pt=1,l=1,sg=0:1
    Apr  2 22:53:25 DietPi mysgw: SGN:SKP:MSG CMD=3,TYPE=24
    Apr  2 22:53:25 DietPi mysgw: TSF:MSG:PINGED,ID=99,HP=1
    Apr  2 22:53:25 DietPi mysgw: SGN:SKP:MSG CMD=3,TYPE=25
    Apr  2 22:53:25 DietPi mysgw: TSF:MSG:SEND,0-0-99-99,s=255,c=3,t=25,pt=1,l=1,sg=0,ft=0,st=OK:1
    Apr  2 22:54:18 DietPi mysgw: TSF:MSG:READ,99-99-0,s=1,c=3,t=16,pt=0,l=0,sg=0:
    Apr  2 22:54:18 DietPi mysgw: SGN:SKP:MSG CMD=3,TYPE=16
    Apr  2 22:54:18 DietPi mysgw: !SGN:NCE:GEN
    Apr  2 22:54:23 DietPi mysgw: TSF:MSG:READ,99-99-0,s=0,c=3,t=16,pt=0,l=0,sg=0:
    Apr  2 22:54:23 DietPi mysgw: SGN:SKP:MSG CMD=3,TYPE=16
    Apr  2 22:54:23 DietPi mysgw: !SGN:NCE:GEN
    

    This is kicking my butt... I cant understand that last part about the nonce 😞
    I will add the code from the node as soon as possible.


  • Mod

    @masmat according to the log parser

    mysgw: !SGN:BND:PWD<8
    

    means the password is too short.


  • Contest Winner

    @masmat and this

    !SGN:INI:BND FAIL
    

    Means the signing backend failed to initialize. So you need to make the password longer.



  • @mfalkvidd Made the password 10 characters. From looks of the logs, it's working now.
    I cant believe I skipped the step of making the password longer... Just got too fixated on the password I came up with.


  • Contest Winner

    @masmat the nonce failures is because the backend never initialized so basically any call to the backend that can fail will fail.



  • I just discovered these USB-to-NRF24 devices. Would it be possible to use that instead of connecting to the GPIO pins?

    https://www.aliexpress.com/item/USB-wireless-serial-module-serial-to-nRF24L01-digital-communication-remote-control-acquisition-module-nRF2401/32722937957.html


  • Mod

    @alowhum not with the existing code. Is there a datasheet that describes how these modules work?

    One of the reviews says "have no idea wath software to use with this" so documentation might be hard to come by.


  • Hardware Contributor

    Background: I use signing software on some nodes + whitelisting on a node (of course only PI serial is on the whitelist).

    With current --development branch (I think 2.3.0alpha) I cannot anymore set my previous personalized flags on gateway RPI3.

    In detail, with current master (2.2.0) I can do:

    sudo mysgw --set-soft-hmac-key=F618D4[...]848992B
    sudo mysgw --set-soft-serial-key=26[...]9
    sudo mysgw --set-aes-key=EC7[...]CEB4
    

    WIth development I did see only the --get[...] flags and cannot set anymore. Can you confirm?

    How can I set my previous values for signing?


 

Suggested Topics

387
Online

7.6k
Users

8.5k
Topics

91.2k
Posts