devices a long time away from controller.....



  • ok so this is possibly answered elsewhere, and i did look but couldnt find exactly what i was looking for

    im thinking of garage remote for the car...
    can i create a node that does nothing but sleep unless one of 3 buttons on it is pushed?
    im thinking of easy to use car remotes for my garage....
    but im concerned about its mapping ability if the device is away form the controller for a couple of days to a week

    i was orginally going to make one of these that automattically detected approach of car, but it became too much of a risk

    do the devices have lease life times? where they may change there ID without warning...

    i will be working with domoticz, and another mysensors node for the actual door operation


  • Mod

    https://forum.mysensors.org/topic/3355/count-car-starts might have some good information for this use case



  • @mfalkvidd
    thanks for that....judging by his operation of the device it shouldnt matter how long its away..seems to be only thing he did was use a static ID, as im guessing it might change if its away for long enough....

    seems pretty simple as its a send only device.....
    only thing that i can think of that i may want feedback for is to light up buttons when they are available....

    not sure if im going to do these as powered by car...or if they should be battery powered...im guessing if battery powered lit up buttons is a bad idea


  • Hero Member

    @markjgabb said in devices a long time away from controller.....:

    do the devices have lease life times? where they may change there ID without warning...

    As far as I am aware the node id's are persistent. You would need to manually delete the node on your controller to re allocate the id to a new node. So you should be ok with the node being away for extended periods of time.

    can i create a node that does nothing but sleep unless one of 3 buttons on it is pushed?

    Yes that is possible, you would need to use an interrupt for that.


Log in to reply
 

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.