Not all of a node's children sensors are visible in HA



  • Howdy,

    I have added a new SenseBender NodeManger which is visible in the dev-states screen. However one of the children sensors is not showing in the dev-states screen in HA . Specifically the door sensor which is child sensor #3. Below is a copy and paste from the dev-states screen.

    sensor.nodemanager_113_1	24.99	battery_level: 100
    child_id: 1
    description: 
    device: /dev/ttyACM1
    node_id: 113
    V_TEMP: 24.99
    unit_of_measurement: °C
    friendly_name: NodeManager 113 1
    sensor.nodemanager_113_2	69.01	battery_level: 100
    child_id: 2
    description: 
    device: /dev/ttyACM1
    node_id: 113
    V_HUM: 69.01
    unit_of_measurement: %
    friendly_name: NodeManager 113 2
    sensor.nodemanager_113_200	SLEEPING	battery_level: 100
    child_id: 200
    description: 
    device: /dev/ttyACM1
    node_id: 113
    V_CUSTOM: SLEEPING
    friendly_name: NodeManager 113 200
    sensor.nodemanager_113_201	3.34	battery_level: 100
    child_id: 201
    description: 
    device: /dev/ttyACM1
    node_id: 113
    V_VOLTAGE: 3.34
    unit_of_measurement: V
    friendly_name: NodeManager 113 201
    

    I'm successfully running a number of other NodeManager SenseBender nodes on HA with just temp and humidity.

    The mysensors.json file appears to be showing the correct number of children sensors, including sensor #3 which is the door sensor:

    "113": {
        "sensor_id": 113,
        "children": {
          "1": {
            "id": 1,
            "type": 6,
            "description": "",
            "values": {
              "0": "24.99"
            }
          },
          "2": {
            "id": 2,
            "type": 7,
            "description": "",
            "values": {
              "1": "69.01"
            }
          },
          "3": {
            "id": 3,
            "type": 23,
            "description": "",
            "values": {
              "16": "1"
            }
          },
          "200": {
            "id": 200,
            "type": 23,
            "description": "",
            "values": {
              "48": "SLEEPING"
            }
          },
          "201": {
            "id": 201,
            "type": 30,
            "description": "",
            "values": {
              "38": "3.34"
            }
          }
        },
    

    I know that the door sensor is working as child sensor #200 shows the change to the wake / sleeping state when the NodeManager wakes up from the door sensor interrupt. Also, I can see that the NodeManager is sending the message in the serial console on change to the door sensor,

    Any thoughts as to why child sensor #3 is not showing in HA?

    Thanks,
    Simon



  • I'm an idiot.......

    I just noticed a binary_sensor.nodemanager_113_3 was created in the dev-state page.


 

287
Online

7.6k
Users

8.5k
Topics

91.3k
Posts