Windows GUI/Controller for MySensors



  • Thanks @ @tekka I saw the button "gw mode" but pimatic unfortunately only supports serial gateways. so if i use the "gw mode" i need a package like net2ser (instead of ser2net). But i think something like that does not exist

    edit:
    okay, it works with socat

    sudo socat -d -d pty,link=/dev/ttyPimaticGW,raw,echo=0,waitslave tcp:192.168.170.32:5003;


  • Admin

    @Harrdy cool, thanks for reporting 👍



  • @Harrdy I made the experience that a socat tcp tunnel is not stable all the time. I was trying to establish a connection between my ESP8266 gateway and a serial port (to be used with pimatic), but that tended to disconnect after few hours/days. This was also reported by other users in the pimatic forum. But maybe this is only a problem in relation with a ESP gateway.
    I would just recommend to check your connection regularly.
    If it is also unstable for you, I am testing node-red for that purpose at the moment and it looks promising. I will report when testing is finished.



  • Maybe this helps any one else:
    I run openHAB on a RPI3 and i have made a Mysensors serial GW on a arduino nano.
    I want to use openHAB for the interface and MySController for the managment. So i need to forward my serial communication to a TCP socket.

    ser2net is a nice tool works fast but it block the Serial connection for openHAB.
    socat works better for me by executing the following command:
    $ sudo socat tcp-l:5003,reuseaddr,fork file:/dev/mySensorsCOM,nonblock,waitlock=/var/run/mySensorsCOM.lock

    next step will be to put it in a script and sends the process to the background and restarts it if there went something go's wrong.



  • @Harrdy there is a ethernet branch of the mysensors plugin for pimatic now under development. You can have a look at the mysensors thread in the pimatic forum to find the instructions.



  • Does anyone know how to allow multiple TCP connections forwarded to one MYS tty port? This socat command blocks second TCP connection until first one disconnected.

    I just want to connect MYSController using TCP without disconnecting my custom MQTT<=>serial controller script. I'm using RPi with USB-serial gateway.

    P.S. @tekka is there any chances that MQTT access will be implemented in MYSController?

    @techRH said:

    $ sudo socat tcp-l:5003,reuseaddr,fork file:/dev/mySensorsCOM,nonblock,waitlock=/var/run/mySensorsCOM.lock



  • @tekka great work! thank you for sharing this.
    Your controller and great contribution had me quickly started with mysensors. I am interested in a way to do OTA updates using MYSController via api or a script call or even rewriting the logic in an outside code. I'll try to explain the need based on my setup below.

    Given that I am using jeedom right now as a controller, but sadly it doesn't seem to support yet OTA updates. I'd like to be able to reuse or even contribute to this feature and I'd appreciate pointers to start doing that.
    My setup has it that jeedom runs off a raspi and has a mysensors serial gateway attached. (1 to 2 Watts draw for this setup). MYSController can work as an ethernet relay gateway, but if I understand correctly I have to run it on windows (more moving parts), or a much hungrier box than my raspi.

    Is there a way I can make that work somehow? I am ready and appreciate any type of suggestions with the current setup I have or an evolution which goes into that direction.



  • @robosensor you could try nodered. It can connect multiple inputs (mqtt, tcp,...) and merge it to a single serial output and vice versa. You might have to add some logic, but that shouldn't be a problem.



  • @robosensor I wrote a bridge to use on the Linino side of the Arduino Yun for this:
    https://github.com/peterdey/Yun-Linino-NewBridge

    But there's no reason you couldn't use this on an rPi - you'll probably just need to turn the baud rate down to 115200.


  • Admin

    @jmkhael You can use "GW mode" (=proxy mode) in the tab bar



  • I thought the socat command is to slow in switching so i have created a python script which will readout the mysensors serial GW and sends the data to a virtual serial port to connect to openhab and a TCP socket for the MySensors controller.

    https://github.com/Rutger798/serial_to_serial_and_tcp/blob/master/serial_to_serial_and_tcp.py



  • How do i use MYSController with a Raspberry Pi ?
    I have a RPi2 with a NRF24 radio as a gateway and want to troubleshoot some communication issues i have been having. I usually log into the RPi2 via ssh to make adjustments.
    Can I just download the files and rund the .exe via command-line?

    Thanks



  • I think it's windows software only. If you want to use it this way you should make you gateway device accessible via ethernet, maybe socat or nodered is an option for you.



  • ok thanks for clarifying.

    gonna give the node-red a try



  • @pdey said:

    @Mark-Swift : If you're happy to modify the MySensors library in an unsupported way, I've added a logMessage function to transmit text/debug messages from remote nodes:
    https://github.com/peterdey/MySensors-Arduino/commit/f5f339b71620ec3cd896304a2ca6aba40ad40218

    Found it useful, particularly in conjunction with MYSController OTA firmware updates.

    is it possible to use with mysensor 2.0 API ?



  • Very cool. It also works on Ubuntu with Wine.
    You have to create a COM port like this:

    ln -s /dev/ttyUSB0 ~/.wine/dosdevices/com1
    


  • How do I get MYSController to save info about each node?
    I always have to set "battery-powered" after each upload and it does not save sketch name etc.



  • Ok this might be a realy stupid question but im what you call a "nuub" 😉

    If i want to monitor my current setup (serial gateway on a pi3) on windows/mint. Do i build another gateway and plug it in the pc?

    Sorry if i missed the instructions on this


  • Admin

    @meanmrgreen no, you can only have one GW in your setup. You could connect your GW to the PC, configure it for serial input, enable GW mode and have your rpi controller pointing at it (IP).



  • @tekka
    How about I'f i replace my serial with a Ethernet gw?

    Do not want my pc running all the time. Just to debug


  • Hardware Contributor

    Hi @tekka - I'm currently running OpenHAB connected to mysensors by a GatewayW5100MQTTClient gateway and at the moment I have to manual upgrades to the nodes by disconnecting them and plugging them into the PC and recompiling all the software for each node. Would there be any way around this setup? I would like to keep OpenHAB as my controller and I really like the MQTT Client software too. Its simple and it just works for me. However, i would be open to change from MQTT if needed.

    What is your recommendation of implementing MYScontroller to use for OTA firmware updates only?



  • @tekka how do I initiate a reboot of a node from gateway side? I don't know how, but it's needed for updating OTA. Thanks in advance.



  • @Anduril said in Windows GUI/Controller for MySensors:

    itiate a reboot of a node from gateway side? I don't know how, but it's needed for updating OTA. Th

    Right click on the node and than "reboot"



  • @techRH that doesn't work for the new bootloader/MySensors 2.x


  • Admin

    @Anduril it does work, unless your node is sleeping and not able to process incoming messages



  • @tekka ok and whats the way to deal with sleeping nodes? Do I have to add a wait(xx) to receive reboot commands?


  • Admin

    @Anduril The solution is to use smart sleep. If you are on MySensors 2.1.x, use:

    sleep(xyz_MS, true);
    

    This will issue a heartbeat message followed by a short wait() interval to process incoming messages, and finally send the node to sleep. The heartbeat message triggers the release of pending messages (i.e. reboot request) in MYSController (node has to be defined as battery-powered / sleeping node).

    In the upcoming MySensors 2.2.0 release we will introduce a dedicated sleep intention message.



  • @tekka thanks for your hint. Is smartsleep supported if the controller (pimatic) does not? So do I get problems when using withoug MYSController for debug?

    And another thing is that this node tries to save power and only sends updates if values have changed. So using smartsleep and sending a messag every sleep cycle would be against that. Can I simply put a wait(50) after the first message sending is triggered? What would be the necessary time to do wait(x)?


  • Admin

    @Anduril Yes, smartsleep is just a sequence of events (sending heartbeat message, wait(default=500), sleep()) that gives the controller the possibility to react before the node is going to sleep.



  • I have problems using the OTA feature with MYSController.

    1. "undefined firmware/type" reported.
      My setup:
    • ESP8266 Gateway 2.1.1
    • MYSController Version 1.0.0beta (build 3314)
    • atmega328p chip with own pcb, internal osc 8MHz, and MYSBootloaderV13pre.hex (taken from the same zip file as MYSController.exe)

    The log file in MYSController shows "undefined firmware/type" :
    alt text

    Where can I find the latest software (exe and boot loader)?

    1. the "Reload repo" toolbar button is always greyed, but the "firmware_config" is available, has all entries and the hex files are in the same directory.

    2. is there a more detailed description available for the columns of the "firmware_config" file?

    thanks in advance


  • Admin

    @dirkc If you are using MYSBootloader there is no need to define MY_OTA_FIRMWARE_FEATURE since the FW update happens offline, see here for additional infos.

    See here for a firmware_config.csv example:

    Type,Name,Version,File,Comments
    1,DoorSensor_V1,1,DoorSensorV1.hex,Door sensor version 1
    1,DoorSensor_V2,2,DoorSensorV2.hex,Door sensor version 2
    1,DoorSensor_V3,3,DoorSensorV3.hex,Door sensor version 3
    10,TestSensor,1,TestSensor.hex,Test FW
    11,LightSensor,1,LightSensor.hex,Light sensor
    20,TempSensor Indoor V1,1,TempSensorIndoorV1.hex,Temp. Sensor indoor V1
    20,TempSensor Indoor V2,2,TempSensorIndoorV2.hex,Temp. Sensor indoor V2
    30,TempSensor Outdoor V1,1,TempSensorOutdoorV1.hex,Temp. Sensor outdoor V2
    

    Impotant: All defined files need to be present in the directory, only comma delimiters are allowed.



  • With MSController 1.0.0 & SerialGateway with 2.2.0 MySensor lib, 1 problem occurs.

    MSController crash at the presentation step by the node

    Below what the node send when reeboot. (Debug log via Serial)

    0 MCO:BGN:INIT NODE,CP=RNNNA---,VER=2.2.0-beta
    26 TSM:INIT
    27 TSF:WUR:MS=0
    34 TSM:INIT:TSP OK
    35 TSM:INIT:STATID=1
    37 TSF:SID:OK,ID=1
    39 TSM:FPAR
    75 TSF:MSG:SEND,1-1-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    1051 TSF:MSG:READ,0-0-1,s=255,c=3,t=8,pt=1,l=1,sg=0:0
    1056 TSF:MSG:FPAR OK,ID=0,D=1
    2083 TSM:FPAR:OK
    2084 TSM:ID
    2085 TSM:ID:OK
    2087 TSM:UPL
    2091 TSF:MSG:SEND,1-1-0-0,s=255,c=3,t=24,pt=1,l=1,sg=0,ft=0,st=OK:1
    2101 TSF:MSG:READ,0-0-1,s=255,c=3,t=25,pt=1,l=1,sg=0:1
    2106 TSF:MSG:PONG RECV,HP=1
    2109 TSM:UPL:OK
    2110 TSM:READY:ID=1,PAR=0,DIS=1
    2115 TSF:MSG:SEND,1-1-0-0,s=255,c=3,t=15,pt=6,l=2,sg=0,ft=0,st=OK:0100
    2122 TSF:MSG:READ,0-0-1,s=255,c=3,t=15,pt=6,l=2,sg=0:0100
    2129 TSF:MSG:SEND,1-1-0-0,s=255,c=0,t=17,pt=0,l=10,sg=0,ft=0,st=OK:2.2.0-beta
    2139 TSF:MSG:SEND,1-1-0-0,s=255,c=3,t=6,pt=1,l=1,sg=0,ft=0,st=OK:0
    2155 TSF:MSG:READ,0-0-1,s=255,c=3,t=6,pt=0,l=1,sg=0:M
    2162 TSF:MSG:SEND,1-1-0-0,s=255,c=3,t=11,pt=0,l=10,sg=0,ft=0,st=OK:OTA Test 2
    2171 TSF:MSG:SEND,1-1-0-0,s=255,c=3,t=12,pt=0,l=3,sg=0,ft=0,st=OK:2.0
    2180 TSF:MSG:SEND,1-1-0-0,s=1,c=0,t=3,pt=0,l=8,sg=0,ft=0,st=OK:Sensor 1
    2187 MCO:REG:REQ
    2190 TSF:MSG:SEND,1-1-0-0,s=255,c=3,t=26,pt=1,l=1,sg=0,ft=0,st=OK:2
    2197 TSF:MSG:READ,0-0-1,s=255,c=3,t=27,pt=1,l=1,sg=0:1
    2202 MCO:PIM:NODE REG=1
    2204 MCO:BGN:STP
    2205 MCO:BGN:INIT OK,TSP=1
    

    Below is the log in MSController

    08/05/2017 18:12:26	RX	0;255;3;0;9;33925 TSF:MSG:READ,1-1-255,s=255,c=3,t=7,pt=1,l=1,sg=0:0
    08/05/2017 18:12:26	RX	0;255;3;0;9;33931 TSF:MSG:BC
    08/05/2017 18:12:26	RX	0;255;3;0;9;33933 TSF:MSG:FPAR REQ,ID=1
    08/05/2017 18:12:26	RX	0;255;3;0;9;33937 TSF:PNG:SEND,TO=0
    08/05/2017 18:12:26	RX	0;255;3;0;9;33940 TSF:CKU:OK
    08/05/2017 18:12:26	RX	0;255;3;0;9;33943 TSF:MSG:GWL OK
    08/05/2017 18:12:26	RX	0;255;3;0;9;34102 TSF:MSG:SEND,0-0-1-1,s=255,c=3,t=8,pt=1,l=1,sg=0,ft=0,st=OK:0
    08/05/2017 18:12:29	RX	0;255;3;0;9;37248 TSF:MSG:READ,1-1-255,s=255,c=3,t=7,pt=1,l=1,sg=0:0
    08/05/2017 18:12:29	RX	0;255;3;0;9;37254 TSF:MSG:BC
    08/05/2017 18:12:29	RX	0;255;3;0;9;37257 TSF:MSG:FPAR REQ,ID=1
    08/05/2017 18:12:29	RX	0;255;3;0;9;37260 TSF:CKU:OK,FCTRL
    08/05/2017 18:12:29	RX	0;255;3;0;9;37263 TSF:MSG:GWL OK
    08/05/2017 18:12:30	RX	0;255;3;0;9;37669 TSF:MSG:SEND,0-0-1-1,s=255,c=3,t=8,pt=1,l=1,sg=0,ft=0,st=OK:0
    08/05/2017 18:12:32	RX	0;255;3;0;9;40570 TSF:MSG:READ,1-1-0,s=255,c=3,t=15,pt=6,l=2,sg=0:0100
    08/05/2017 18:12:32	RX	0;255;3;0;9;40579 TSF:MSG:SEND,0-0-1-1,s=255,c=3,t=15,pt=6,l=2,sg=0,ft=0,st=OK:0100
    08/05/2017 18:12:33	RX	0;255;3;0;9;40729 TSF:MSG:READ,1-1-0,s=255,c=4,t=0,pt=6,l=10,sg=0:28000100E803E5750103
    08/05/2017 18:12:33	RX	1;255;4;0;0;28000100E803E5750103
    08/05/2017 18:12:33	INFO	BL version=259
    08/05/2017 18:12:33	INFO	No FW assigned
    08/05/2017 18:12:36	RX	0;255;3;0;9;44053 TSF:MSG:READ,1-1-0,s=255,c=4,t=0,pt=6,l=10,sg=0:28000100E803E5750103
    08/05/2017 18:12:36	RX	1;255;4;0;0;28000100E803E5750103
    08/05/2017 18:12:36	INFO	BL version=259
    08/05/2017 18:12:36	INFO	No FW assigned
    08/05/2017 18:12:39	RX	0;255;3;0;9;47376 TSF:MSG:READ,1-1-0,s=255,c=4,t=0,pt=6,l=10,sg=0:28000100E803E5750103
    08/05/2017 18:12:39	RX	1;255;4;0;0;28000100E803E5750103
    08/05/2017 18:12:39	INFO	BL version=259
    08/05/2017 18:12:39	INFO	No FW assigned
    08/05/2017 18:12:43	RX	0;255;3;0;9;50700 TSF:MSG:READ,1-1-0,s=255,c=4,t=0,pt=6,l=10,sg=0:28000100E803E5750103
    08/05/2017 18:12:43	RX	1;255;4;0;0;28000100E803E5750103
    08/05/2017 18:12:43	INFO	BL version=259
    08/05/2017 18:12:43	INFO	No FW assigned
    08/05/2017 18:12:46	RX	0;255;3;0;9;54213 TSF:MSG:READ,1-1-255,s=255,c=3,t=7,pt=0,l=0,sg=0:
    08/05/2017 18:12:46	RX	0;255;3;0;9;54219 TSF:MSG:BC
    08/05/2017 18:12:46	RX	0;255;3;0;9;54222 TSF:MSG:FPAR REQ,ID=1
    08/05/2017 18:12:46	RX	0;255;3;0;9;54226 TSF:PNG:SEND,TO=0
    08/05/2017 18:12:46	RX	0;255;3;0;9;54230 TSF:CKU:OK
    08/05/2017 18:12:46	RX	0;255;3;0;9;54232 TSF:MSG:GWL OK
    08/05/2017 18:12:47	RX	0;255;3;0;9;55224 TSF:MSG:SEND,0-0-1-1,s=255,c=3,t=8,pt=1,l=1,sg=0,ft=0,st=OK:0
    08/05/2017 18:12:48	RX	0;255;3;0;9;56261 TSF:MSG:READ,1-1-0,s=255,c=3,t=24,pt=1,l=1,sg=0:1
    08/05/2017 18:12:48	RX	0;255;3;0;9;56267 TSF:MSG:PINGED,ID=1,HP=1
    08/05/2017 18:12:48	RX	0;255;3;0;9;56273 TSF:MSG:SEND,0-0-1-1,s=255,c=3,t=25,pt=1,l=1,sg=0,ft=0,st=OK:1
    08/05/2017 18:12:48	RX	0;255;3;0;9;56286 TSF:MSG:READ,1-1-0,s=255,c=3,t=15,pt=6,l=2,sg=0:0100
    08/05/2017 18:12:48	RX	0;255;3;0;9;56294 TSF:MSG:SEND,0-0-1-1,s=255,c=3,t=15,pt=6,l=2,sg=0,ft=0,st=OK:0100
    08/05/2017 18:12:48	RX	0;255;3;0;9;56302 TSF:MSG:READ,1-1-0,s=255,c=0,t=17,pt=0,l=10,sg=0:2.2.0-beta
    08/05/2017 18:12:48	RX	1;255;0;0;17;2.2.0-beta
    08/05/2017 18:12:48	DEBUG	Update child id=255, type=S_ARDUINO_NODE
    08/05/2017 18:12:48	RX	0;255;3;0;9;56309 TSF:MSG:READ,1-1-0,s=255,c=3,t=6,pt=1,l=1,sg=0:0
    08/05/2017 18:12:48	RX	1;255;3;0;6;0
    08/05/2017 18:12:48	TX	1;255;3;0;6;M
    08/05/2017 18:12:48	RX	0;255;3;0;9;56328 TSF:MSG:SEND,0-0-1-1,s=255,c=3,t=6,pt=0,l=1,sg=0,ft=0,st=OK:M
    08/05/2017 18:12:48	RX	0;255;3;0;9;56335 TSF:MSG:READ,1-1-0,s=255,c=3,t=11,pt=0,l=10,sg=0:OTA Test 2
    08/05/2017 18:12:48	RX	1;255;3;0;11;OTA Test 2
    08/05/2017 18:12:48	RX	0;255;3;0;9;56343 TSF:MSG:READ,1-1-0,s=255,c=3,t=12,pt=0,l=3,sg=0:2.0
    08/05/2017 18:12:48	RX	1;255;3;0;12;2.0
    08/05/2017 18:12:48	RX	0;255;3;0;9;56351 TSF:MSG:READ,1-1-0,s=1,c=0,t=3,pt=0,l=8,sg=0:Sensor 1
    

    Here a screenshot when MSController crash.

    0_1494260885106_MSController.jpg

    When I click on "request presentation", same error.

    This error is only with SerialGateway & Library 2.2.0 beta
    With library 2.1.1that's ok


  • Admin

    @romeo01 Thanks for reporting, this is a known issue with build 3314 and lib 2.2.0: The msg parser requires some changes - build 3316 is in preparation (also supporting new 2.2.0 features).



  • Hi, I am trying your software but I only get "connection refused" though in the status bar it says Connected... what can I do?



  • @tekka hi, can we access the previous build if that is working for MySensors2.1.1?


  • Admin

    @siod Seems like something is wrong with your GW - either GW is not working or too many connections.


  • Admin

    @vikasjee What build are you looking for?



  • @tekka , I upgraded Arduino IDE from 1.6.0 to 1.8.2 recently. Burnt the gateway with the MySensors2.1.1 gateway sketch and the nodes bootloader with MysBootloader1.3.0beta3 from the master branch on github.

    As per my understanding the Node with MysBootloader should connect to the Gateway (checked with MysController 1.0beta b3314) where i can specify the Firmware for this new node. But i am not able to get the Node entry in the left hand side tree in MysController. Upon checking the MysController Debug, there are a stream of messages from the node but are being endlessly repeated:

    6/12/2017 19:24:59	RX	0;255;3;0;9;TSF:CKU:OK,FCTRL
    6/12/2017 19:24:59	RX	0;255;3;0;9;TSF:MSG:GWL OK
    6/12/2017 19:25:01	RX	0;255;3;0;9;TSF:MSG:SEND,0-0-255-255,s=255,c=3,t=8,pt=1,l=1,sg=0,ft=0,st=OK:0
    6/12/2017 19:25:06	RX	0;255;3;0;9;TSF:MSG:READ,255-255-255,s=255,c=3,t=7,pt=1,l=1,sg=0:235
    6/12/2017 19:25:06	RX	0;255;3;0;9;TSF:MSG:BC
    6/12/2017 19:25:06	RX	0;255;3;0;9;TSF:MSG:FPAR REQ,ID=255
    6/12/2017 19:25:06	RX	0;255;3;0;9;TSF:CKU:OK,FCTRL
    6/12/2017 19:25:06	RX	0;255;3;0;9;TSF:MSG:GWL OK
    6/12/2017 19:25:08	RX	0;255;3;0;9;TSF:MSG:SEND,0-0-255-255,s=255,c=3,t=8,pt=1,l=1,sg=0,ft=0,st=OK:0
    6/12/2017 19:25:09	RX	0;255;3;0;9;TSF:MSG:READ,255-255-255,s=255,c=3,t=7,pt=1,l=1,sg=0:235
    6/12/2017 19:25:09	RX	0;255;3;0;9;TSF:MSG:BC
    6/12/2017 19:25:09	RX	0;255;3;0;9;TSF:MSG:FPAR REQ,ID=255
    6/12/2017 19:25:09	RX	0;255;3;0;9;TSF:CKU:OK,FCTRL
    6/12/2017 19:25:09	RX	0;255;3;0;9;TSF:MSG:GWL OK
    

    I am unable to get to the root of the problem... and could not find any mention of a similar problem on this forum (searched far and wide 🙂 )

    Any pointers to a solution or hint of what may be wrong will definitely help me save time...



  • @tekka , there seems to be an issue with the build 3314 and MYSBootloader for MySensors 2.1.1,as noted above. Any good, working previous version should do...



  • @tekka please help with the MysController build 3312 if that one works with MYSBootloader for MySensors 2.1.1 master.


  • Admin

    @vikasjee Apologies for the late reply. This issue is not related to MYSController:
    The debug log hints to some issues with the radio (range, connection) and/or power supply (node does not receive the find_parent_response message), please double-check the wiring, power supply (appropriate caps on both, GW and node), change the distance between GW and node, or try with different radio modules.



  • @tekka No Issues. Thanks for the response.

    I have tried all of these with all my 35 radios (were all working before the upgrade) and equal number of nodes! 😞

    I will go through all this sequence once again though... Thanks for clearing the doubts on MYSController build. Indebted!



  • Newbie can't make it happen...

    I've been struggling for the last couple of days, trying to make the mysensors world to fly. But unfortunately i have no success so i will try to post one of my many trials, would be very glad if you could let me know what i'm missing...

    Hardware:

    • Aurduino Mini Pro
    • W5100 ETH interface
    • long-distance NRF24L01 (Gateway)
    • NRF24L01+ 2.4GHz Antenna Wireless Transceiver Module (Sensor)

    Software:

    All i did was to load both sketch to the according mini.
    Of course changing the IP of the gateway.

    I can ping the gateway using Windows terminal, but i can't access the gateway using the MYSController. As soon i try to dicover any node the connection is terminated by the remot side (entry in the debug window of MYSCtrl)

    If i did understand it correct i do not have to load the Bootloader as of now (as long i do not need OTA)

    Any help would be highly appriciated,
    matt


  • Mod

    Welcome to the MySensors community @swiss 🙂
    What does the debug output from the gateway say?
    How is the gateway powered?

    If you haven't already, take a look at https://forum.mysensors.org/topic/666/debug-faq-and-how-ask-for-help/ for the most common problems and how to fix them.



  • @mfalkvidd
    wow that was quick 🙂
    The gateway is powered thru a breadboard 3.3V psu.
    Here is teh log dump of the gateway:

    0;255;3;0;9;TSF:MSG:SEND,0-0-255-255,s=255,c=3,t=8,pt=1,l=1,sg=0,ft=0,st=OK:0
    0;255;3;0;9;TSF:MSG:READ,255-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0:
    0;255;3;0;9;TSF:MSG:BC
    0;255;3;0;9;TSF:MSG:FPAR REQ,ID=255
    0;255;3;0;9;TSF:CKU:OK,FCTRL
    0;255;3;0;9;TSF:MSG:GWL OK
    0;255;3;0;9;TSF:MSG:SEND,0-0-255-255,s=255,c=3,t=8,pt=1,l=1,sg=0,ft=0,st=OK:0
    0;255;3;0;9;TSF:MSG:READ,255-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0:
    0;255;3;0;9;TSF:MSG:BC
    0;255;3;0;9;TSF:MSG:FPAR REQ,ID=255
    0;255;3;0;9;TSF:CKU:OK,FCTRL

    Thank you so much!


  • Mod

    @swiss could you post the entire log?

    EDIT: How much current can the breadboard psu provide? Which capacitor(s) are you using?


  • Mod

    and yes, you are correct that bootloader is only needed for FOTA.



  • @mfalkvidd
    0;255;3;0;9;MCO:BGN:INIT GW,CP=RNNGA--,VER=2.1.1
    0;255;3;0;9;TSM:INIT
    0;255;3;0;9;TSF:WUR:MS=0
    0;255;3;0;9;TSM:INIT:TSP OK
    0;255;3;0;9;TSM:INIT:GW MODE
    0;255;3;0;9;TSM:READY:ID=0,PAR=0,DIS=0
    0;255;3;0;9;MCO:REG:NOT NEEDED
    IP: 192.168.8.155
    0;255;3;0;9;MCO:BGN:STP
    0;255;3;0;9;MCO:BGN:INIT OK,TSP=1
    0;255;3;0;9;TSF:MSG:READ,255-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0:
    0;255;3;0;9;TSF:MSG:BC
    0;255;3;0;9;TSF:MSG:FPAR REQ,ID=255
    0;255;3;0;9;TSF:PNG:SEND,TO=0
    0;255;3;0;9;TSF:CKU:OK
    0;255;3;0;9;TSF:MSG:GWL OK
    0;255;3;0;9;TSF:MSG:SEND,0-0-255-255,s=255,c=3,t=8,pt=1,l=1,sg=0,ft=0,st=OK:0
    0;255;3;0;9;TSF:MSG:READ,255-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0:
    0;255;3;0;9;TSF:MSG:BC


  • Mod

    @swiss nothing at all happens after TSF:MSG:BC ?



  • its repeating

    0;255;3;0;9;TSF:MSG:FPAR REQ,ID=255
    0;255;3;0;9;TSF:CKU:OK,FCTRL
    0;255;3;0;9;TSF:MSG:GWL OK
    0;255;3;0;9;TSF:MSG:SEND,0-0-255-255,s=255,c=3,t=8,pt=1,l=1,sg=0,ft=0,st=OK:0
    0;255;3;0;9;TSF:MSG:READ,255-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0:
    0;255;3;0;9;TSF:MSG:BC
    0;255;3;0;9;TSF:MSG:FPAR REQ,ID=255
    0;255;3;0;9;TSF:CKU:OK,FCTRL
    0;255;3;0;9;TSF:MSG:GWL OK
    0;255;3;0;9;TSF:MSG:SEND,0-0-255-255,s=255,c=3,t=8,pt=1,l=1,sg=0,ft=0,st=OK:0
    0;255;3;0;9;TSF:MSG:READ,255-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0:
    0;255;3;0;9;TSF:MSG:BC
    0;255;3;0;9;TSF:MSG:FPAR REQ,ID=255
    0;255;3;0;9;TSF:CKU:OK,FCTRL
    0;255;3;0;9;TSF:MSG:GWL OK
    0;255;3;0;9;TSF:MSG:SEND,0-0-255-255,s=255,c=3,t=8,pt=1,l=1,sg=0,ft=0,st=OK:0
    0;255;3;0;9;TSF:MSG:READ,255-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0:
    0;255;3;0;9;TSF:MSG:BC
    0;255;3;0;9;TSF:MSG:FPAR REQ,ID=255
    0;255;3;0;9;TSF:PNG:SEND,TO=0
    0;255;3;0;9;TSF:CKU:OK
    0;255;3;0;9;TSF:MSG:GWL OK
    0;255;3;0;9;TSF:MSG:SEND,0-0-255-255,s=255,c=3,t=8,pt=1,l=1,sg=0,ft=0,st=OK:0
    0;255;3;0;9;TSF:MSG:READ,255-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0:
    0;255;3;0;9;TSF:MSG:BC
    0;255;3;0;9;TSF:MSG:FPAR REQ,ID=255
    0;255;3;0;9;TSF:CKU:OK,FCTRL
    0;255;3;0;9;TSF:MSG:GWL OK
    0;255;3;0;9;TSF:MSG:SEND,0-0-255-255,s=255,c=3,t=8,pt=1,l=1,sg=0,ft=0,st=OK:0
    0;255;3;0;9;TSF:MSG:READ,255-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0:
    0;255;3;0;9;TSF:MSG:BC
    0;255;3;0;9;TSF:MSG:FPAR REQ,ID=255
    0;255;3;0;9;TSF:CKU:OK,FCTRL
    0;255;3;0;9;TSF:MSG:GWL OK
    0;255;3;0;9;TSF:MSG:SEND,0-0-255-255,s=255,c=3,t=8,pt=1,l=1,sg=0,ft=0,st=OK:0
    0;255;3;0;9;TSF:MSG:READ,255-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0:
    0;255;3;0;9;TSF:MSG:BC
    0;255;3;0;9;TSF:MSG:FPAR REQ,ID=255
    0;255;3;0;9;TSF:CKU:OK,FCTRL
    0;255;3;0;9;TSF:MSG:GWL OK
    0;255;3;0;9;TSF:MSG:SEND,0-0-255-255,s=255,c=3,t=8,pt=1,l=1,sg=0,ft=0,st=OK:0
    0;255;3;0;9;TSF:MSG:READ,255-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0:
    0;255;3;0;9;TSF:MSG:BC
    0;255;3;0;9;TSF:MSG:FPAR REQ,ID=255
    0;255;3;0;9;TSF:PNG:SEND,TO=0
    0;255;3;0;9;TSF:CKU:OK
    0;255;3;0;9;TSF:MSG:GWL OK
    0;255;3;0;9;TSF:MSG:SEND,0-0-255-255,s=255,c=3,t=8,pt=1,l=1,sg=0,ft=0,st=OK:0
    0;255;3;0;9;TSF:MSG:READ,255-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0:
    0;255;3;0;9;TSF:MSG:BC
    0;255;3;0;9;TSF:MSG:FPAR REQ,ID=255
    0;255;3;0;9;TSF:CKU:OK,FCTRL
    0;255;3;0;9;TSF:MSG:GWL OK
    0;255;3;0;9;TSF:MSG:SEND,0-0-255-255,s=255,c=3,t=8,pt=1,l=1,sg=0,ft=0,st=OK:0
    0;255;3;0;9;TSF:MSG:READ,255-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0:
    0;255;3;0;9;TSF:MSG:BC
    0;255;3;0;9;TSF:MSG:FPAR REQ,ID=255
    0;255;3;0;9;TSF:CKU:OK,FCTRL
    0;255;3;0;9;TSF:MSG:GWL OK



  • @mfalkvidd
    the psu provides 350 mA


  • Mod

    ok. So from the log parser we see that the gateway sends a response to the id request, but the node keeps requesting a new id anyway.

    Could you post the log from the node?


  • Mod

    @swiss which capacitor(s) do you use? The nrf radio is extremely sensitive to power fluctuations.



  • @mfalkvidd
    0 MCO:BGN:INIT NODE,CP=RNNNA--,VER=2.1.1
    4 TSM:INIT
    4 TSF:WUR:MS=0
    12 TSM:INIT:TSP OK
    14 TSM:FPAR
    16 TSF:MSG:SEND,255-255-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    2025 !TSM:FPAR:NO REPLY
    2027 TSM:FPAR
    2029 TSF:MSG:SEND,255-255-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    4038 !TSM:FPAR:NO REPLY
    4040 TSM:FPAR
    4042 TSF:MSG:SEND,255-255-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    6051 !TSM:FPAR:NO REPLY
    6053 TSM:FPAR
    6055 TSF:MSG:SEND,255-255-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    8065 !TSM:FPAR:FAIL
    8067 TSM:FAIL:CNT=1
    8069 TSM:FAIL:PDT
    18073 TSM:FAIL:RE-INIT
    18075 TSM:INIT
    18081 TSM:INIT:TSP OK
    18085 TSM:FPAR
    18087 TSF:MSG:SEND,255-255-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    20097 !TSM:FPAR:NO REPLY
    20099 TSM:FPAR
    20101 TSF:MSG:SEND,255-255-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    22110 !TSM:FPAR:NO REPLY
    22112 TSM:FPAR
    22114 TSF:MSG:SEND,255-255-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    24123 !TSM:FPAR:NO REPLY
    24125 TSM:FPAR
    24127 TSF:MSG:SEND,255-255-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    26136 !TSM:FPAR:FAIL
    26138 TSM:FAIL:CNT=2
    26140 TSM:FAIL:PDT
    36143 TSM:FAIL:RE-INIT
    36145 TSM:INIT
    36151 TSM:INIT:TSP OK
    36155 TSM:FPAR
    36157 TSF:MSG:SEND,255-255-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    38166 !TSM:FPAR:NO REPLY
    38168 TSM:FPAR
    38170 TSF:MSG:SEND,255-255-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    40179 !TSM:FPAR:NO REPLY
    40181 TSM:FPAR
    40183 TSF:MSG:SEND,255-255-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    42194 !TSM:FPAR:NO REPLY
    42196 TSM:FPAR
    42199 TSF:MSG:SEND,255-255-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    44208 !TSM:FPAR:FAIL
    44210 TSM:FAIL:CNT=3
    44212 TSM:FAIL:PDT
    54216 TSM:FAIL:RE-INIT
    54218 TSM:INIT
    54224 TSM:INIT:TSP OK
    54228 TSM:FPAR
    54231 TSF:MSG:SEND,255-255-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    56240 !TSM:FPAR:NO REPLY
    56242 TSM:FPAR
    56244 TSF:MSG:SEND,255-255-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    58253 !TSM:FPAR:NO REPLY
    58255 TSM:FPAR
    58257 TSF:MSG:SEND,255-255-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    60266 !TSM:FPAR:NO REPLY
    60268 TSM:FPAR
    60270 TSF:MSG:SEND,255-255-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    62279 !TSM:FPAR:FAIL
    62281 TSM:FAIL:CNT=4
    62283 TSM:FAIL:PDT
    72286 TSM:FAIL:RE-INIT
    72288 TSM:INIT
    72294 TSM:INIT:TSP OK
    72298 TSM:FPAR
    72300 TSF:MSG:SEND,255-255-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    74309 !TSM:FPAR:NO REPLY
    74311 TSM:FPAR
    74313 TSF:MSG:SEND,255-255-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    76322 !TSM:FPAR:NO REPLY
    76324 TSM:FPAR
    76326 TSF:MSG:SEND,255-255-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    78336 !TSM:FPAR:NO REPLY
    78338 TSM:FPAR
    78340 TSF:MSG:SEND,255-255-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    80349 !TSM:FPAR:FAIL
    80351 TSM:FAIL:CNT=5
    80353 TSM:FAIL:PDT

    at the moment i have no capacitors in place since i thought the communication was ok...


  • Mod

    @swiss ok. No use to troubleshoot further without capacitors.



  • @mfalkvidd
    ok sorry will ad them right now - sorry for using your time



  • thank you so much for kicking me into the right direction...
    now the log of the node looks different:

    0 MCO:BGN:INIT NODE,CP=RNNNA--,VER=2.1.1
    4 TSM:INIT
    4 TSF:WUR:MS=0
    12 TSM:INIT:TSP OK
    14 TSM:FPAR
    16 TSF:MSG:SEND,255-255-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    2025 !TSM:FPAR:NO REPLY
    2027 TSM:FPAR
    2029 TSF:MSG:SEND,255-255-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    2037 TSF:MSG:READ,0-0-255,s=255,c=3,t=8,pt=1,l=1,sg=0:0
    2043 TSF:MSG:FPAR OK,ID=0,D=1
    3500 TSF:MSG:READ,0-0-255,s=255,c=3,t=8,pt=1,l=1,sg=0:0
    4038 TSM:FPAR:OK
    4038 TSM:ID
    4040 TSM:ID:REQ
    4044 TSF:MSG:SEND,255-255-0-0,s=255,c=3,t=3,pt=0,l=0,sg=0,ft=0,st=OK:
    6051 TSM:ID
    6051 TSM:ID:REQ
    6055 TSF:MSG:SEND,255-255-0-0,s=255,c=3,t=3,pt=0,l=0,sg=0,ft=0,st=OK:
    8065 TSM:ID
    8065 TSM:ID:REQ
    8069 TSF:MSG:SEND,255-255-0-0,s=255,c=3,t=3,pt=0,l=0,sg=0,ft=0,st=OK:
    10076 TSM:ID
    10076 TSM:ID:REQ
    10080 TSF:MSG:SEND,255-255-0-0,s=255,c=3,t=3,pt=0,l=0,sg=0,ft=0,st=OK:
    12089 !TSM:ID:FAIL
    12091 TSM:FAIL:CNT=1
    12093 TSM:FAIL:PDT
    22097 TSM:FAIL:RE-INIT
    22099 TSM:INIT
    22106 TSM:INIT:TSP OK
    22110 TSM:FPAR
    22112 TSF:MSG:SEND,255-255-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    24004 TSF:MSG:READ,0-0-255,s=255,c=3,t=8,pt=1,l=1,sg=0:0
    24010 TSF:MSG:FPAR OK,ID=0,D=1
    24121 TSM:FPAR:OK
    24123 TSM:ID
    24123 TSM:ID:REQ
    24127 TSF:MSG:SEND,255-255-0-0,s=255,c=3,t=3,pt=0,l=0,sg=0,ft=0,st=OK:
    26136 TSM:ID
    26136 TSM:ID:REQ
    26140 TSF:MSG:SEND,255-255-0-0,s=255,c=3,t=3,pt=0,l=0,sg=0,ft=0,st=OK:
    28149 TSM:ID
    28149 TSM:ID:REQ
    28153 TSF:MSG:SEND,255-255-0-0,s=255,c=3,t=3,pt=0,l=0,sg=0,ft=0,st=OK:
    30164 TSM:ID
    30164 TSM:ID:REQ
    30169 TSF:MSG:SEND,255-255-0-0,s=255,c=3,t=3,pt=0,l=0,sg=0,ft=0,st=OK:
    32178 !TSM:ID:FAIL
    32180 TSM:FAIL:CNT=2
    32182 TSM:FAIL:PDT
    42186 TSM:FAIL:RE-INIT
    42188 TSM:INIT
    42194 TSM:INIT:TSP OK
    42199 TSM:FPAR
    42201 TSF:MSG:SEND,255-255-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    44097 TSF:MSG:READ,0-0-255,s=255,c=3,t=8,pt=1,l=1,sg=0:0
    44103 TSF:MSG:FPAR OK,ID=0,D=1
    44210 TSM:FPAR:OK
    44212 TSM:ID
    44212 TSM:ID:REQ
    44216 TSF:MSG:SEND,255-255-0-0,s=255,c=3,t=3,pt=0,l=0,sg=0,ft=0,st=OK:
    46225 TSM:ID
    46225 TSM:ID:REQ
    46229 TSF:MSG:SEND,255-255-0-0,s=255,c=3,t=3,pt=0,l=0,sg=0,ft=0,st=OK:
    48238 TSM:ID
    48238 TSM:ID:REQ
    48242 TSF:MSG:SEND,255-255-0-0,s=255,c=3,t=3,pt=0,l=0,sg=0,ft=0,st=OK:
    50251 TSM:ID
    50251 TSM:ID:REQ
    50255 TSF:MSG:SEND,255-255-0-0,s=255,c=3,t=3,pt=0,l=0,sg=0,ft=0,st=OK:
    52267 !TSM:ID:FAIL
    52269 TSM:FAIL:CNT=3
    52271 TSM:FAIL:PDT

    If understand it correct it got feedback from parent and is now requesting its id ? correct?
    Is it correct that the ID should come from the Controller, in my case the Myscontroller ?
    unfortunately i cant connect the controller to the Gateway, is there anything else i can check beside the IP and the port ?

    thank you so much for your assistance would really love to make it happen...
    matt


  • Mod

    @swiss yes, that's correct.

    What does the gateway log say when you connect the controller?



  • Here is the log of the gateway, it starts when i press "discover" on the software (after i connected)
    0;255;3;0;9;Eth: connect
    0;255;3;0;9;MCO:BGN:INIT GW,CP=RNNGA--,VER=2.1.1
    0;255;3;0;9;TSM:INIT
    0;255;3;0;9;TSF:WUR:MS=0
    0;255;3;0;9;TSM:INIT:TSP OK
    0;255;3;0;9;TSM:INIT:GW MODE
    0;255;3;0;9;TSM:READY:ID=0,PAR=0,DIS=0
    0;255;3;0;9;MCO:REG:NOT NEEDED
    IP: 192.168.8.155
    0;255;3;0;9;MCO:BGN:STP
    0;255;3;0;9;MCO:BGN:INIT OK,TSP=1
    0;255;3;0;9;TSF:MSG:READ,255-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0:
    0;255;3;0;9;TSF:MSG:BC
    0;255;3;0;9;TSF:MSG:FPAR REQ,ID=255
    0;255;3;0;9;TSF:CKU:OK,FCTRL
    0;255;3;0;9;TSF:MSG:GWL OK
    0;255;3;0;9;TSF:MSG:SEND,0-0-255-255,s=255,c=3,t=8,pt=1,l=1,sg=0,ft=0,st=OK:0
    0;255;3;0;9;TSF:MSG:READ,255-255-0,s=255,c=3,t=3,pt=0,l=0,sg=0:
    0;255;3;0;9;MCO:BGN:INIT GW,CP=RNNGA--,VER=2.1.1
    0;255;3;0;9;TSM:INIT
    0;255;3;0;9;TSF:WUR:MS=0
    0;255;3;0;9;TSM:INIT:TSP OK
    0;255;3;0;9;TSM:INIT:GW MODE
    0;255;3;0;9;TSM:READY:ID=0,PAR=0,DIS=0
    0;255;3;0;9;MCO:REG:NOT NEEDED
    IP: 192.168.8.155
    0;255;3;0;9;MCO:BGN:STP
    0;255;3;0;9;MCO:BGN:INIT OK,TSP=1
    0;255;3;0;9;TSF:MSG:READ,255-255-0,s=255,c=3,t=3,pt=0,l=0,sg=0:
    0;255;3;0;9;MCO:BGN:INIT GW,CP=RNNGA--,VER=2.1.1
    0;255;3;0;9;TSM:INIT
    0;255;3;0;9;TSF:WUR:MS=0
    0;255;3;0;9;TSM:INIT:TSP OK
    0;255;3;0;9;TSM:INIT:GW MODE
    0;255;3;0;9;TSM:READY:ID=0,PAR=0,DIS=0
    0;255;3;0;9;MCO:REG:NOT NEEDED
    IP: 192.168.8.155
    0;255;3;0;9;MCO:BGN:STP
    0;255;3;0;9;MCO:BGN:INIT OK,TSP=1
    0;255;3;0;9;TSF:MSG:READ,255-255-0,s=255,c=3,t=3,pt=0,l=0,sg=0:
    0;255;3;0;9;MCO:BGN:INIT GW,CP=RNNGA--,VER=2.1.1
    0;255;3;0;9;TSM:INIT
    0;255;3;0;9;TSF:WUR:MS=0
    0;255;3;0;9;TSM:INIT:TSP OK
    0;255;3;0;9;TSM:INIT:GW MODE
    0;255;3;0;9;TSM:READY:ID=0,PAR=0,DIS=0
    0;255;3;0;9;MCO:REG:NOT NEEDED
    IP: 192.168.8.155
    0;255;3;0;9;MCO:BGN:STP
    0;255;3;0;9;MCO:BGN:INIT OK,TSP=1
    0;255;3;0;9;TSF:MSG:READ,255-255-0,s=255,c=3,t=3,pt=0,l=0,sg=0:
    0;255;3;0;9;MCO:BGN:INIT GW,CP=RNNGA--,VER=2.1.1
    0;255;3;0;9;TSM:INIT
    0;255;3;0;9;TSF:WUR:MS=0
    0;255;3;0;9;TSM:INIT:TSP OK
    0;255;3;0;9;TSM:INIT:GW MODE
    0;255;3;0;9;TSM:READY:ID=0,PAR=0,DIS=0
    0;255;3;0;9;MCO:REG:NOT NEEDED
    IP: 192.168.8.155
    0;255;3;0;9;MCO:BGN:STP
    0;255;3;0;9;MCO:BGN:INIT OK,TSP=1

    but no node is found... and if i press discover again i got error 10054 in the software and the connection is terminated by the remote...


  • Mod

    @swiss I would guess you are using Arduino AVR board version 1.6.19 (check in the board manager). If that is the case, the solution seems to be to downgrade. See https://forum.mysensors.org/post/72423



  • MAN,YOU ARE MY HERO!!!
    IT WORKS - THANK YOU FOR ALL YOUR SUPPORT
    TAKE CARE
    MATT


  • Mod

    @swiss great! Thanks for reporting back.



  • How can I increase the number of blocks greater than 2048?

    [2017-12-05 16:04:36.925 Info] REPO FW "STM32_RS485_Node_Relay" loaded. t=100, v=7, blocks=2048, crc=0xCC88
    [2017-12-05 16:04:36.926 Info] REPO FW repository loaded. Items=2
    [2017-12-05 16:04:52.544 Info] INFO FW "STM32_RS485_Node_Relay" assigned to node 100
    [2017-12-05 16:04:52.545 Info] INFO Send FW info to node 100: type=64, version=7, blocks=0x0800, CRC=0xCC88

    For STM32F407ZGT6, it may take up to 65k blocks. And in the controller, I understand it is a hard limit on 2048?





  • Hi all

    I have an issue which I've documented in the Troubleshooting section. When I've searched for a resolution, this program has been mentioned. What I'm trying to do is get my controller to see the part of the gateway sketch that references a sensor that I added. Can this program help? What does this program actually do?


  • Hardware Contributor

    @Homer
    Try it 😉
    It's a handy controller software for debugging MySensors.


 

210
Online

8.6k
Users

9.4k
Topics

99.0k
Posts