Hi MySensors team,
as I am working a lot with the MySensors library at the moment, I just found a little inconsistency between the API and the protocol documentation (https://www.mysensors.org/download/serial_api_20).
The documentation says that messages consists of these parts: node-id ; child-sensor-id ; message-type ; ack ; sub-type ; payload.
In the source code (class MyMessage.h) you don't use "message-type" and "sub-type" but instead "command" and "(message) type".
As I think the latter terms are more suitable for the protocol understanding I'd like to raise the discussion whether it would we better using "command-type" and "message-type" in the protocol documentation as well instead. Then docs and sources would be "in sync" again and I think the protocol structure would be even better understandable.
Finally another little improvement request: The protocol docs are still talking about "Serial Protocol - 2.0.x" - maybe you should update this to "2.x".