The IDs for humidity and temperature shown on the HA screenshot and written in the sketch don't match up. It looks like you have already presented the sensor node with different child IDs before and HA is still expecting the previous configuration. If you reassign an existing ID to a different type (say, S_HUM to S_TEMP), HA won't update automatically. I would suggest doing the following: Power down your sensor node and shutdown the HA docker Delete the existing .pickle persistance file, which may still contain the previous node configuration Edit configuration.yaml and change the file type of the persistance file from .pickle to .json, because it's human readable (and editable). You may also enable debug logging temporarily to get more info about what's happening when a node sends data Restart HA and once the MySensors integration has finished initialization, power up the sensor node again If you don't change the current sketch, temperature should show up with the ID 1 and humidity with the ID 2 in HA. I can't spot anything wrong with it. If it still doesn't work, have a look at the HA log, e.g. with journalctl -u your-ha.service -f -n 100 | grep mysensors You should see that messages are incoming from the sensor node (ID 2) including the sketch name and values for every sensor, that HA subscribes to a MQTT topic for every sensor ID and that HA has saved changes to the persistante.json file.