LED name wrong in 2.0.0 beta
-
In MyConfig.h names are:
#define MY_DEFAULT_ERR_LED x #define MY_DEFAULT_TX_LED x #define MY_DEFAULT_RX_LED x
In MyLeds.ccp they are:
#define MY_DEFAULT_TX_LED_PIN #define MY_DEFAULT_ERR_LED_PIN #define MY_DEFAULT_RX_LED_PIN
-
Thanks for reporting, will fix the comment.
-
Variable name is wrong, not the comments
-
MY_DEFAULT_TX_LED _PIN
Is the correct suffix. I could only find a commented section in MyConfig.h without the correct suffix. Or what do you mean? Show me a link/line number to github where you found the incorrect declaration.
-
My pull from the development hub is a few weeks old, I'll check my pull from current master when I get home tonight ....
-
I pulled the current development version... on 3 Mar 2016
In myconfig.h at line 167, we have the block below:
if you un comment one of the LED define, they do NOT enable the LED, only if you use the 2nd versions as defined in MyLeds.ccp.
#define MY_DEFAULT_ERR_LED 15 <--- not working
#define MY_DEFAULT_ERR_LED_PIN 15 <--- working/********************************** * Information LEDs blinking ***********************************/ // This feature enables LEDs blinking on message receive, transmit // or if some error occurred. This was commonly used only in gateways, // but now can be used in any sensor node. Also the LEDs can now be // disabled in the gateway. //#define MY_LEDS_BLINKING_FEATURE // The following setting allows you to inverse the blinking feature MY_LEDS_BLINKING_FEATURE // When MY_WITH_LEDS_BLINKING_INVERSE is enabled LEDSs are normally turned on and switches // off when blinking //#define MY_WITH_LEDS_BLINKING_INVERSE // The following defines can be used to set the port pin, that the LED is connected to // If one of the following is defined here, or in the sketch, MY_LEDS_BLINKING_FEATURE will be // enabled by default. (Replace x with the pin number you have the LED on) //#define MY_DEFAULT_ERR_LED x //#define MY_DEFAULT_TX_LED x //#define MY_DEFAULT_RX_LED x ~~
-
You could create a PR to change this (We would love to get contributions to the code)