Error During presentation



  • Hi Folks,

    I'm getting the following error during presentation: As you can see some of the children are being picked up correctly but some of them are not

    2021-03-01 19:07:44 DEBUG (MainThread) [mysensors.gateway_mqtt] Receiving 250;255;3;0;11;Heatpump Control
    2021-03-01 19:07:44 DEBUG (MainThread) [homeassistant.components.mysensors.gateway] Node update: node 250 child 255
    2021-03-01 19:07:44 DEBUG (MainThread) [mysensors.gateway_mqtt] Receiving 250;255;3;0;12;1.1
    2021-03-01 19:07:44 DEBUG (MainThread) [homeassistant.components.mysensors.gateway] Node update: node 250 child 255
    2021-03-01 19:07:44 DEBUG (MainThread) [homeassistant.components.mysensors.device] Entity update: heatpump 2: value_type 0, value = 21
    2021-03-01 19:07:44 DEBUG (MainThread) [homeassistant.components.mysensors.device] Entity update: heatpump 0: value_type 2, value = 0
    2021-03-01 19:07:44 DEBUG (MainThread) [mysensors.gateway_mqtt] Receiving 250;0;0;0;3;Power
    2021-03-01 19:07:44 WARNING (MainThread) [mysensors.sensor] child_id 0 already exists in children of node 250, cannot add child
    2021-03-01 19:07:44 DEBUG (MainThread) [mysensors.gateway_mqtt] Receiving 250;1;0;0;29;Set Point Temp
    2021-03-01 19:07:44 WARNING (MainThread) [mysensors] Invalid <Message data="250;1;0;0;29;Set Point Temp">: Not valid message sub-type: 29 for object value @ data['sub_type']. Got 29
    2021-03-01 19:07:44 DEBUG (MainThread) [mysensors.gateway_mqtt] Receiving 250;2;0;0;6;Room Temp
    2021-03-01 19:07:44 WARNING (MainThread) [mysensors.sensor] child_id 2 already exists in children of node 250, cannot add child
    2021-03-01 19:07:44 DEBUG (MainThread) [mysensors.gateway_mqtt] Receiving 250;3;0;0;29;Fan Speed
    2021-03-01 19:07:44 WARNING (MainThread) [mysensors] Invalid <Message data="250;3;0;0;29;Fan Speed">: Not valid message sub-type: 29 for object value @ data['sub_type']. Got 29
    2021-03-01 19:07:44 DEBUG (MainThread) [mysensors.gateway_mqtt] Receiving 250;4;0;0;29;Mode
    2021-03-01 19:07:44 WARNING (MainThread) [mysensors] Invalid <Message data="250;4;0;0;29;Mode">: Not valid message sub-type: 29 for object value @ data['sub_type']. Got 29
    2021-03-01 19:07:44 DEBUG (MainThread) [mysensors.gateway_mqtt] Receiving 250;5;0;0;29;Vane Dir
    2021-03-01 19:07:44 WARNING (MainThread) [mysensors] Invalid <Message data="250;5;0;0;29;Vane Dir">: Not valid message sub-type: 29 for object value @ data['sub_type']. Got 29
    2021-03-01 19:07:44 DEBUG (MainThread) [mysensors.gateway_mqtt] Receiving 250;6;0;0;36;Operating
    2021-03-01 19:07:44 WARNING (MainThread) [mysensors] Invalid <Message data="250;6;0;0;36;Operating">: Not valid message sub-type: 36 for object value @ data['sub_type']. Got 36
    

    I've also run the example mqtt.py from pymysensors outside of home assistant to see if my heatpump sensor was generically sending rubbish. But that didn't throw out any errors.

    So could this be a problem with the mysensors integration in home-assistant?

    TIA

    Steve

    [0_1614579780203_ard_hvac.ino](Uploading 100%)



  • Hey @sfozz

    Without further information about your setup, I assume that you have the MySensors integration in configuration.yaml configured incorrectly. It looks like you either didn't specify the MySensors protocol version at all or wrongly, in which case it defaults to the very old 1.4 protocol version that doesn't support many of the newer types like S_HVAC or S_INFO.

    It needs to look like this:

    mysensors:
      gateways:
        - device: ...
          # other things ...
      version: "2.3"
    

    Do not include the patch level (as in 2.3.2). It doesn't ask for the MySensors version used in the Arduino sketch, but for the protocol version implemented by pymysensors.



  • Hey @BearWithBeard

    I'd not put in a version: as I'd assumed it would default to most recent... those assumptions always get you!

    Pretty much working now, many thanks!


Log in to reply
 

Suggested Topics

160
Online

10.0k
Users

10.5k
Topics

108.4k
Posts