Help, version 2.4-alpha, PI-4 64bits & Mac OS



  • Hi there,
    My Gateway was on a Raspberry Pi 4, with the last stable version.
    I upgrade the OS of the PI to Raspberry PI OS Lite 64 bits, and the compililation of the 2.3 fails.
    To compile the 2.4 alpha. I had to remove the flag "-mfpu=neon-fp-armv8 -mfloat-abi=hard " in the Makefile.inc. After this, mysgw seam working fine on my PI Gateway.
    So I try to start some of my nodes, build on arduino IDE on Mac OS with the 2.3 librairies ... And it didn't work. It is probably normal (gateway on 2.4 and node on 2.3).
    I try to build the 2.4 for Arduino IDE on Mac OS, but I failed because I do not how to do it.
    So I need help ... :
    How to find / install or build the 2.4 for the Arduino IDE on MacOs Montery in order to reprogram my nodes ?
    Thanks for your help.



  • @briseis I would just switch back to 2.3.2
    I also believe 2.4 on the gateway should work with nodes on 2.3.2. what kind of errors did you get when doing this?


Log in to reply
 

Suggested Topics

  • 1
  • 198
  • 1
  • 5
  • 2
  • 2

0
Online

11.3k
Users

11.1k
Topics

112.5k
Posts