Radio doesn't work properly powered by 3.3V - only 5V



  • Hi Folks,

    I've had some troubles with the radio and ACKs not being sent properly - as a background.

    Anyway today I set up an acuator - a Servo which controls my heating. It all works fine (although the Servo is a bit unpredicable when starting up, even with an external power supply and a capacitor - but I digress) - but I just suddenly had a realisation that I hooked up the radio to 5V not 3.3V - so I went to fix my mistake - however when running off 3.3V, I found that the radio would send it's hello messages, I saw them on MQTT - but it wouldn't do anything when sending it a MQTT message - switching back to 5V and it all works fine.

    I'm using a capacitor, a 100uF one.

    My questions really are, is this safe leaving it on 5V? Is the worse that could happen that the radio just stops working (ie is it a fire hazard?) - Also, is it just possible that my batch just prefers 5V? It just seems odd! The radio is the only thing running off the arduino nano power supply - the servo is on it's own.

    Any ideas?



  • @britcowboy

    Wait a minute... are you running your radio on 5vdc? Doesn't the spec say 1.9 ~ 3.6V? I'm actually having the same issue. I know it's something to do with the power but haven't really tried anything yet other than a 100uf cap. You know what, I'm going to try running mine at 5V and see if anything happen. And if it burns the radio I'm cool with that. The least I get some closure.



  • Have you tried it with a different radio? It is possible that this radio may have been partially damaged when you powered it with 5v?

    I look forward for the result.



  • Hi Folks,

    Tried with a different radio, on 3.3v - same result - I see it appear in my MQTT broker speaking to the network - announcing it's presence - but sending it messages results in nothing happening.



  • @britcowboy

    What controller are you using ?



  • I think I might have fixed this now, I think the capacitor may have been connected a bit loose.

    However something I'm slightly concerned by, and I've noticed this with 5v and 3.3v - is occassionally the message won't come through. Now that's not a massive problem when you're dealing with temp sensors, but when this is a message that controls heating and could mean that it's not switched off as the message didn't come through, it's a bit more worrying. Is there a retry method of some kind?



  • I'm using the MQTT Client Gateway with OpenHab and Mosquotto Sub (when testing) as the controller


Log in to reply
 

Suggested Topics

  • 4
  • 11
  • 9
  • 4
  • 7
  • 2
  • 14
  • 23

152
Online

9.8k
Users

10.3k
Topics

106.7k
Posts