MySensors and Vera UI7


  • Hero Member

    Any information on compatibility of MySensors and Vera UI7?


  • Admin

    @clippermiami

    No.. do you wanna make the jump 🙂


  • Hero Member

    @hek I spent a long time on the "Bleeding Edge" of IT, in my dotage I think I'll just wait thank you very much 🙂


  • Hero Member

    Getting old John? 😉
    I just picked up a second Vera (on ebay) just to test UI7, and then to have as a dev system for MySensors and anything else i want to play around with without blowing up the hard earned WAF in my HA setup!

    So...as this is far more interesting than my day job, i have just spent the last hour or so setting up the Vera lite with UI7, installing a few plugins ( Imperihome, WeatherUnderground). All went smoothly!!

    So ..to MySensors plugin. Right now i dont have a mysensors ethernet gateway here at work, but to add the plugin, the process is exactly the same as it is for UI5...
    They have changed the upload of the luup files - you can now drag and drop the files ( i used 1.4 versions for this Vera) and it will automatically reload luup when done - i think this is a nice improvement.

    The inclusion button placement is a bit out of wack for Start/Stop - i think this is set in the D_Arduino1.json so ill have a go at fixing this tonight.

    I also found some user guides last night for UI7 - take a look if your interested .
    http://support.getvera.com/customer/portal/topics/677044--vera-ui7-2-vera-ui7-dashboard-navigation-tabs?b_id=712


  • Hero Member

    With respect to the Start and Stop buttons being out of wack - it seems other plugins also have this issue.
    http://forum.micasaverde.com/index.php/topic,26649.0.html

    I did try to fix this in the D_Arduino1.json but as far as i can see any changes to the positioning only changes this in the "Settings" tab and not the dashboard "Device" view.


  • Admin

    @gregl

    Thanks investigating this! I only got one Vera so testing UI7 would be very strenuous in my setup. And the family would probably not be happy during the transition.


  • Hero Member

    @gregl Not so much old as beat up 🙂

    I have a Vera Lite with a bad USB so I suppose I could set it up with UI7 and do my part to try to contribute to the combined knowledge. I must admit to some curiosity about the new UI. Is there anything to watch out for in setting it up alongside two bridged Vera 3 units on UI5? Will my Vera account complain that you know of?

    Right now my plate is full with trying to build a custom video camera installation for the front entry to feed the Blue Iris security system. The gods are conspiring against me on this one 🙂


  • Hero Member

    I set my "test" vera up using a completely new account. Ive only ever used UI5 and the "old" authentication system, so my Vera's arnt linked in any way - i chose to use a different email address to try to ensure they didnt see it as an invitation to migrate my existing UI5 unit to UI6 or 7!

    Given your in the US, perhaps give them a call with the serial/mac and ask them to split it away from your "account" or give reassurance nothing will touch your existing setup!

    UI7....Having played with it last night for a few hours, i don't think it really offers me anything better than UI5 did in terms of functionality - the interface is certainly better( and playing with something new and shiny is always nice) , but then I dont/shouldnt really care about that so much as i use Imperihome for UI purposes ( which happily also works perfectly with UI7!).

    For a newcomer to Vera though...its a massive step forward!

    I cant see they have added any real improvements to the rules engine so PLEG is still going to be needed for more advanced logic.

    So for me...this Vera's key use is to provide me the platform to test MySensors 1.4 and beyond! ( and back on ebay if when something better comes along....)

    Its funny...Ive been using Windows Media Center since it first came out..and ive always kept my eye on other systems - XBMC,Myth.MediaPortal etc etc etc... still to this day none of them do Live TV very well ( i keep trying every so often). So i stay with WMC....it works and works well. I do use the excellent MediaBrowser3 plugin for my media collection which runs seamlessly within WMC. Super high WAF there...not going to risk that!!
    Anyway... my point is... all these other HA solutions seem to be a really long way behind Vera when it comes to just working ( ive had basically zero issues with my Vera and Zwave devices) which is the number one factor when it comes to being able to switch on a light! , cost ( ongoing monthly costs are something i have no interest in) , "cloud" - I would never rely on the "cloud" for my HA needs... Configuration in the cloud? yes ok, but the engine MUST run on my lan!
    Vera does its job well...and with the community plugins, esp, MySensors,PLEG etc its pretty much got it covered... Add UI apps and again - beautiful, functional and customisable! No other platform is coming close! Im watching OpenHAB and a few others..lots of promise, but still not there!!

    Sorry for the rant...running low on beer!


  • Hero Member

    I did set up my Vera Lite with UI7 RC. Frankly I'm underwhelmed.

    For day to day usage I use ImperiHome and I'm very happy with that. I occasionally resort to Authomation but less and less as I improve my ImperiHome configuration. I . Played with UI7 and frankly I think compared to UI5 it's a step backwards for setup and configuring things. For a new user who will use UI7 as their standard window into the system it's probably better this UI5 but to set up devices, configure them, etc I find the constant back and forth movement irritating compared to TABs in the current UI5

    Clearly there are still some major holes in the RC yet, most obviously there doesn't appear to be a way to create multiple instances of an App. I've installed DSC (although haven't configured it to my alarm system yet), PLEG, Virtual Switch, Day and Night, Blue Iris.

    When it becomes production and we all end up having to move I just hope that it installs clean and preserves the configuration, I really don't want to reenter my LEGS, cameras, and what have you 🙂



  • Soooo, anyone mucking around with UI7 yet? I've been trying to get things to work, but having trouble getting new sensors to work properly. The gateway is configured and working correctly. i was adding a simple door sensor to see if it would work and it registers, but the sensor is basically empty, Any pointers (aside form the usual downgrade to UI5)?

    • EDIT -
      The gateway shows up correctly and the first node shows up corectly as well in UI7. Now how do i add the child device for the door sensor?

  • Admin

    @gregl seems to have it working on UI7 using Ethernet gateway. Not sure if serial gateway works though.



  • well, i guess patience is a virtue i don't possess... i did find an error in my code where i forgot to add the gw.sendSketchInfo() to the gateway, so i fixed that and it finally created the child device. Now testing other sensor types. will try to post updates if there are any issues. thanks for the help!



  • @hek : Do you have plans to upgrade the plugin for UI7 use ? I know the guys at MCV are willing to assist any developer with the upgrade :
    http://forum.micasaverde.com/index.php/topic,27645.0.html


  • Admin

    Don't think my family would enjoy the failing home automation which probably would be the result if I upgrade our "production" Vera.

    Would be great if someone who actually is running UI7 would assist with the necessary changes. What is not working for you?


  • Hero Member

    Yeah i wouldnt be using UI7 on a production Vera yet.

    That said i dont think there is anything actually broken with the mySensors plugin with it other than some cosmetic issues...


  • Contest Winner

    I am stuck on UI7 (device refuses to downgrade and I have not bothered about contacting support to have them unlock it) and I have so far only experienced HW/FW failures with my gateway (not that Vera is a good product, far from it). But I also cannot point on anything specific with UI7 that is not compatible with MySensors plugin v1.4 apart from said cosmetic details.



  • New version Vera have 1 USB and 1 ethernet and wifi, it will be on sale in a few weeks with ui7.
    I dont know why some plugins work with ui5 but not compatiable with ui7.

    Do you have any plan to make an update for mysensors plugin?


  • Admin

    I don't run UI7 myself.
    But others have reported here and on micasa that it works fine in UI7 (part from some GUI alignment).



  • I just purchased a veraedge and manage to get the usb gateway to be recognized. Unfortunatly I do not know how to get my sensors to be recognized. Inhave tried the discover button followed by a reset of the sensor without succes. I have also tried to create a new device with the dArduino1.xml but can not get this configured with my device.

    So after reading everything I could find on the topic I am desperate to find a solution with the vera edge or an another controller that could work as stand alone or on a pc.


  • Admin

    @legaultf Which UI7 firmware are you running on your VeraEdge?



  • A trick I learned right after creating devises is to click on " Reload Luup". Then give it a couple of minutes and you should see the created devices on DEVICES on VERA.

    " Reload Luup". could be access from Apps -> Develop apps -> Serial Port configuration -> Reload Luup



  • I've learnt the same trick. Reload Luup from the serial config screen.
    After a couple of trials and then finding the UI7 on Github - all's working fine with my first light sensor.
    Now to building my solar HWS sensors. Thanks Hek for all your work and patience with everyone, a donation is on the way for you to buy a UI7 device. Cheers!


 

Suggested Topics

283
Online

8.7k
Users

9.5k
Topics

99.5k
Posts