• hey all,

    I have installed freedomotic on my pc and up and running with the mysensors plugin.
    there is a serial gateway(arduino duemilanove) connected via USB. i also have one sensor in the field with a relay switch.

    The serial connection of the gateway to the mysensors plugin is open. I verified this through the log view plugin where i saw the gateway presenting itself and telling the gateway startup is complete.

    The problem however is that when the sensor presents itsself asking for a node-ID, the controller never responds with anything. The node just keeps asking for a node ID by presenting as ID 255.
    Is there some kind of option in freedomotic or the mysensors plugin where i have to enable the vending of node ID's ? Or am i doing something wrong here..

    Thanks in advance,


  • Plugin Developer

    Hi Vincent,
    please can you give me more details? What's the expected reply from the controller (freedomotic)?
    And your sensor request? I developed the plugin by simulating devices communications. Maaybe something is not complete.
    Thanks for your support.

  • Admin

    Hi @freedomotic

    I think @diamantmatch wants to use the AUTO-id feature from a sensor-node.
    The node expects controller to reply to this id-request with a unique number between 1-254. Controller keep track of which numbers that is "taken" and only hand out a number once.

    <nodeId>;255;3;0;4<new id>

    See for a explanation of the 3;0;4 part.

  • hey @freedomotic

    The AUTO-id feature @hek explains is exactly what i mean.
    The node in my network doesnt know what ID to listen to and requests a unique ID from the controller.

    I like the plugin for freedomotics a lot! and i hope the AUTO-id feature can be functional with my setup anytime soon.


  • Plugin Developer

    Hi, I got it now.
    This feature isn't yet implemented.
    Can you give me a complete example?
    Node sends on serial 255;???? What exactly?
    Controller freedomotic replies writing on serial what? 255;3;0;4;<id-assigned>\n ?

  • Admin

    @freedomotic said:

    Node sends on serial 255;???? What exactly?


  • hi,

    Awesome that you want to implement the support for the AUTO assigning of unique ID's!

    yes, as far as i got it now it starts out with the sensor presenting itself by shouting 255;255;3;0;3; across the network.
    Decoded this means the following:
    node-id: "255;" this means the node has no ID
    child-sensor-id: "255;" this means the node has no child sensor ID's assigned to any sensors attached ( i do not know if this would also be automatically assigned aswell.. but i hope @hek could give us some clarification on this? )
    message-type: "3;" the message type defines the type of message and basicaly why the message is send. the number 3 means that it is an internal message (propably for configuration)
    ack: "0;" no ack needed
    sub-type: "3;" this is where the magic happens. since in the message type it was defined this is an internal message we can state what type of internal message it is in this parameter. the 3 means "I_ID_REQUEST" wich means internal ID request. The node is requesting an ID.
    payload: "(NULL, nothing, empty)" there is no payload, the request is simply enough.

    the controller recieves this request and defines what ID's are already in use. the controller picks a unique number between 1 and 254 and assignes it to the node using the same message-type but a different sub-message-type ( sub-message-type 4 means "Id response back to sensor. Payload contains sensor id" .
    The assigned ID will be transmitted in the payload section.

    The node boots and looks in his EEPROM memory if it already has a node-ID. if it doesnt it wil broadcast a request for the ID with: 255;255;3;0;3;

    The controller then looks in his table of vended ID's and sends back the first number available (in this example i have only one sensor so number 1 would be vended) and transmits the assigned ID to the node with: 255;255;3;0;4;1

    The node then owns the number 1.
    when something would be transmitted to the node it will listen to this number.

    i dont yet know how the child-sensor-id's work.. sorry for that 😐

    thanks for the help !
    i hope i made it a bit more clear what is needed to vend a node ID.


  • Admin

    @diamantmatch said:

    i dont yet know how the child-sensor-id's work.. sorry for that 😐

    The child sensor Id is defined in the arduino sketch by yourself.

    for example the following code:

    MySensor gw;

    Setup() {
    gw.present(0,S_TEMP); // Present child sensor ID 0 as temperature sensor

    Loop() {

    / Thomas

  • Thanks @tbowmo !
    I uploaded two standard sketches to the node and the gateway so i never noticed before.
    It seems quite logical to define the child-sensor-ID in the sketches on the sensor node itself.
    will do that next time i upload a new sketch!

  • Plugin Developer

    Hi all,
    thanks for your explanations. I have some questions:

    1. when the controller assigned an ID, this is stored on the node. If the controller restarts, is this address maintained in the node? or does the node detect this restarting and ask again a new address?
    2. is the address changed only after a specific request by the node?
      Hope my questions are clear. Every freedomotic object must have a fixed address, so if it assign an ID, this shouldn't change at any restarting of software or node.
      Thanks for your support.

  • Admin

    1. yes node remembers id and won't ask again.

    2. Normally the node wont ask again (unless you clear the eeprom).

  • (might be a silly question..) How do you clean the eeprom? Is it not enought to write another sketch to the chip?

  • Admin

    I've created a ClearEpromConfig in examples.

  • hey,

    i really feel like i'm just nagging about things here.. sorry about that.
    i can not seem to get the sensor to listen to the serial output from the plugin..
    i suspect the plugin from not transmitting a newline, every string transmitted should end with \n

    thanks 🙂

  • Plugin Developer

    Hi @diamantmatch,
    I implemented a first draft of Auto-ID feature.
    If you want you can test it using the attached file (you must extract thejar in it), substituting the old in the plugin folder. Starting Freedomotic from command line you can see all plugin activity.
    I'm reviewing the entire plugin, to improve it and support an increasing number of devices.
    Let me know and thanks for support

  • Hi Mauro,

    I read somewhere there's currently no web frontend. Is this still the case? And if so, how do you access freedomotic remotely?

    / Thomas

  • Plugin Developer

    Hi Thomas,
    the web client is under development. We hope to realease soon a first demo. If you are interested you can take a look at our repository (Polymer). Now is it possible to interact remotely using our REST API (under development). It's the base to create customized clients in every programming languages. More info at
    Remember that Freedomotic is a "framework" to create custom iot/home/building automations solutions.
    Thanks for your interest

  • @freedomotic

    Hi freedomotic, I'm traying to test you plug-in in freedomotic, but dont make it works. Could you please give me a mini setup advise, for example for a** RelayActuator** using Lights General Switch. I set

    protocolo: mysensors
    dirección: 7;1 //static ip because i don`t use AUTO mode (or should I use AUTO mode? to make it works)
    actions: turn on/of MySensors light

        <property name="serial.port" value="COM5"/>       
        <property name="serial.baudrate" value="115200"/>
        <property name="serial.databits" value="8"/>
        <property name="serial.parity" value="0"/>
        <property name="serial.stopbits" value="1"/>

    There is allways the same message:
    my sensors is reciving a command while is not running. Turn on the plugin first.

    but the plugin is turned on, what im doing wrong???

  • Plugin Developer

    Hi @asterisco
    can you post a complete console log? If you double click on plugin icon (to stop it) and do the same to restart it do you receive the same error? Thanks for support

  • Hi.
    I download and try your freedomotic .. Install MySensor Plugin ..
    But show : Plugin started failed , see log for detail.

    Is possible make tutorial for WIndows 7 user ?
    What all need install , download and set..


  • Plugin Developer

    Hi @dzairo
    I need more info, for example your configuration data. Probably your serial port is not set correctly.
    Start Freedomotic, go to Plugins->Configure (in Main menu), select MySensors and set your gateway port.
    If you can start freedomotic from command line as "java -jar freedomotic.jar" so you can see all error messages.
    I'm improving documentation and log messages.
    Thanks for support

  • @asterisco said:

    my sensors is reciving a command while is not running. Turn on the plugin first.

    quite similar errors with the plugin started or stoped

    plugin stoped: my sensors is reciving a command while is not running. Turn on the plugin first.
    ** plugin started:** Succesfull test receives a command while is not ruuning. Turn on the plugin firsr

    the logs appear and disappear as quikly thar they are almost imposible to read and i de log file is empty


  • Plugin Developer

    Hi @asterisco
    I uploaded a new version with improved log messages. Can you remove the old plugin folder and reinstall it?
    Are you using the last dailybuild?

  • I get an exception when i try to use mysensor plugin
    Windows 8.1
    INFO <AWT-EventQueue-0> [Plugin] Starting plugin MySensors
    Exception in thread "AWT-EventQueue-0" java.lang.NoClassDefFoundError: com/freed
    at com.freedomotic.plugins.devices.mysensors.MySensors.loadConfiguredObj
    at com.freedomotic.plugins.devices.mysensors.MySensors.onStart(MySensors
    at com.freedomotic.api.Protocol$

    1. at

    at com.freedomotic.api.Protocol.start(
    at com.freedomotic.jfrontend.PluginJList$1$1.actionPerformed(PluginJList
    at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
    at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
    at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
    at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
    at javax.swing.AbstractButton.doClick(Unknown Source)
    at javax.swing.plaf.basic.BasicMenuItemUI.doClick(Unknown Source)
    at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(Unknown
    at java.awt.Component.processMouseEvent(Unknown Source)
    at javax.swing.JComponent.processMouseEvent(Unknown Source)
    at java.awt.Component.processEvent(Unknown Source)
    at java.awt.Container.processEvent(Unknown Source)
    at java.awt.Component.dispatchEventImpl(Unknown Source)
    at java.awt.Container.dispatchEventImpl(Unknown Source)
    at java.awt.Component.dispatchEvent(Unknown Source)
    at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
    at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
    at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
    at java.awt.Container.dispatchEventImpl(Unknown Source)
    at java.awt.Window.dispatchEventImpl(Unknown Source)
    at java.awt.Component.dispatchEvent(Unknown Source)
    at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
    at java.awt.EventQueue.access$200(Unknown Source)
    at java.awt.EventQueue$ Source)
    at java.awt.EventQueue$ Source)
    at Method)
    at$1.doIntersectionPrivilege(Unknown Sour
    at$1.doIntersectionPrivilege(Unknown Sour
    at java.awt.EventQueue$ Source)
    at java.awt.EventQueue$ Source)
    at Method)
    at$1.doIntersectionPrivilege(Unknown Sour
    at java.awt.EventQueue.dispatchEvent(Unknown Source)
    at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
    at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
    at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
    at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
    at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
    at Source)
    Caused by: java.lang.ClassNotFoundException: com.freedomotic.objects.EnvObjectPe
    at$ Source)
    at$ Source)
    at Method)
    at Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    ... 48 more

  • Plugin Developer

    Thanks for your report.
    I'll take a look ASAP.

  • Hi @freedomotic
    I've read over all the posts and would like to get an update on the status of the plugin, also would like to know where to get the latest version. If I can get this installed I can help you test in on a very large system with over 50 nodes with various sensors on a ranch. Thanks,

  • Plugin Developer

    Hi @sdndba
    thanks for your offer. We are working on a new version. When it is available I'll post here.
    Happy new year!!!

  • Plugin Developer

    @sdndba you can try a new version (in attachment)
    Download from{build.number}.zip
    Extract it, then extract the plugin into freedomotic_folder/plugins/devices.
    Let me know
    Thanks for

  • @freedomotic Good morning and thanks to all for the hard work you put in.

    I went to Domotic website - downloaded the zip files , all fine but when trying to load the Mysensors plugin it was unavailable!!
    I'm just starting with win 7 but will upgrade to pi when I get a bit of experience.
    Any idea whrn the plugin will be available?


  • Plugin Developer

    Hi @BobC
    we are working on the plugin but we need some testers. Nobody is helping us now. Did you try the post attached zip file? If you want we can collaborate. Thanks

  • Plugin Developer

    We are very glad to announce that Freedomotic is on Canonical Ubuntu Snappy Official Page ("Our Partners" section). A great result for our efforts!

  • Hi, what about the mysensor plugin? I would like to try the freedomotic frontend with raspberrypi as a (serial)gateway. Are there any tutorials about?

  • Plugin Developer

    Hi Roberto
    thanks for your interest. The plugin is in stand-by because I don't have any hardware for tests. I asked some help on this forum with no success. If you want we can collaborate. I tried a first draft using a fake serial connection on Windows. Let me know your idea with Raspi. Bye

  • Plugin Developer

    Hi @Roberto-Brunialti
    are you still interested?

  • Yes, I' am. Still to understand the needs in terms of sensors, gw and so on...
    Never used before mysensor, but i've got 4 sensordend boards.
    I should be able to setup a gw with nrf+ in a raspberry 2.

  • Hi, Freedomotic!
    I'm too interesting in testing hardware (sensors & rellays) with MySensor Plugin on Pi B+. Do You need one more tester?

  • Plugin Developer

    Of course @virgus1970 , I need all possible testers.
    I'm updating the plugin to start testing. For now you can install Freedomotic on your raspberry and try it. The plugin works with the upcoming version 5.6 you can download from{build.number}.zip

  • Ok. I'm going to start next week & will keep You up to date

  • Plugin Developer

    Hi, in attachment the new development version. You need to download freedomotic from the previous link (teamcity), extract the plugin zip to freedomotic_root/plugins/devices folder and then modify your serial port name in mysensors-manifest.xml.
    Start Freedomotic and double click on Mysensors icon.

  • @freedomotic

    When you say you dont have hardware for testing, what do you mean?

    Do you have ate least 2 Arduinos?

    Im working on a way to simulate sensors, still alpha and not tested (im travelling) but so far it should be capable of simulating 12 sensors.

    Would this work for you?

  • Plugin Developer

    Now I have only an Arduino Uno and no radio transceiver and sensors.
    I made some tests sending "fake" serial protocol strings via software.

  • Plugin Developer

    any news about your simulator?

  • @freedomotic
    Actually yes.

    I did a major refactor recently (here) and in a last minute update it ended up on the development branch of the 1.5 library, here

    This is intented to be used with at least 2 arduinos, a normal gateway and a fake sensors arduino mocking signals. It should support all the 24 sensors from lib 1.4.1.

    Not sure how you could take this and adapt to your situation since i'm using the MySensors library and it wont run without the radios.


  • Plugin Developer

    My plugin is based on serial protocol so I need to generate some "serial" strings as the gateway does. Now I'm using a serial data port emulator to write manually these strings. If I read your fake frames from serial (without using a gateway) maybe I could solve the problem

  • Admin

    The MySensors project could perhaps support you by donating a couple of radios and arduino boards so you can make the necessary tests properly. Please contact me.

  • Plugin Developer

    Hi @hek
    thanks for your offer.

  • Plugin Developer

    a new version of our plugin is available on the marketplace.
    More info on

  • Plugin Developer

    Hi all
    finally the first Release Candidate version of Commander is available.
    You can download it from
    We ask your help: try it and share your feedback here or filling out the form at
    Share your experience about Freedomotic: only 5 minutes of time to answer our survey at
    Thanks in advance

  • Plugin Developer

    we are looking for Swedish translators for our project. If you want to give us a hand please reply.

  • Plugin Developer

    Hi all
    Freedomotic 5.6 Commander RC2 is out and can be downloaded from
    We fixed some bugs and in particular included the first draft of a web client.
    After starting Freedomotic go to http://localhost:8090 in your browser and digit admin/admin as username/password.
    You can access from another pc in your network by changing in the previous URL "localhost" with the ip of the machine running Freedomotic.
    The web client doesn't have all features included in the java frontend but they can run at the same time.
    If you want to use only the web client please remove the folder "frontend-java" under plugins/devices.
    We need your help in different areas:

    • testing (not all browsers are 100% html5-compatible)
    • functionality
    • usability/UX
    • graphics/layout

    So report your comments/issues on
    If you want to contribute take a look at the source code and at our tracking system

    Stay tuned!

  • Plugin Developer

    Hi all,
    we moved our issues tracker to github.
    Take a look at

  • Plugin Developer

    in this video you can see our Telegram bot plugin in action.
    We need your feedback to improve it.

  • Plugin Developer

    Hi all
    Freedomotic 5.6 Commander RC4 is out and can be downloaded from
    We fixed some bugs and introduced new functionalities.

    So report your comments/issues on
    If you want to contribute take a look at the source code and

    Stay tuned!

  • Plugin Developer

    Hi all
    we are working on a new web client for our domotic framework.
    Here some screenshots
    alt text
    alt text
    alt text

    It's a WIP so we need any help to complete it.
    The code is available at