Trying to upgrade my Ethernet GW -> 1.4



  • Hi

    I have tryied to upgrade my Ethernet GW to 1.4 but as i change the code
    for my Ethernet ENC28J60 shield i get this when i compiling the code

    In file included from /Users/nh/Documents/Arduino/libraries/UIPEthernet/Dhcp.h:7,
    from /Users/nh/Documents/Arduino/libraries/UIPEthernet/UIPEthernet.h:25,
    from EthernetGateway.ino:53:
    /Users/nh/Documents/Arduino/libraries/UIPEthernet/UIPUdp.h:26:29: error: utility/mempool.h: No such file or directory
    /Users/nh/Documents/Arduino/libraries/UIPEthernet/UIPUdp.h:28:28: error: utility/uip.h: No such file or directory
    In file included from EthernetGateway.ino:53:
    /Users/nh/Documents/Arduino/libraries/UIPEthernet/UIPEthernet.h:27:37: error: utility/Enc28J60Network.h: No such file or directory
    /Users/nh/Documents/Arduino/libraries/UIPEthernet/UIPEthernet.h:34:31: error: utility/uip_timer.h: No such file or directory
    In file included from /Users/nh/Documents/Arduino/libraries/UIPEthernet/Dhcp.h:7,
    from /Users/nh/Documents/Arduino/libraries/UIPEthernet/UIPEthernet.h:25,
    from EthernetGateway.ino:53:
    /Users/nh/Documents/Arduino/libraries/UIPEthernet/UIPUdp.h:46: error: 'memaddress' does not name a type
    /Users/nh/Documents/Arduino/libraries/UIPEthernet/UIPUdp.h:47: error: 'memhandle' does not name a type
    /Users/nh/Documents/Arduino/libraries/UIPEthernet/UIPUdp.h:48: error: 'memhandle' does not name a type
    /Users/nh/Documents/Arduino/libraries/UIPEthernet/UIPUdp.h:49: error: 'memhandle' does not name a type
    In file included from /Users/nh/Documents/Arduino/libraries/UIPEthernet/UIPEthernet.h:28,
    from EthernetGateway.ino:53:
    /Users/nh/Documents/Arduino/libraries/UIPEthernet/UIPClient.h:48: error: 'memhandle' does not name a type
    /Users/nh/Documents/Arduino/libraries/UIPEthernet/UIPClient.h:54: error: 'memhandle' does not name a type
    /Users/nh/Documents/Arduino/libraries/UIPEthernet/UIPClient.h:55: error: 'memhandle' does not name a type
    /Users/nh/Documents/Arduino/libraries/UIPEthernet/UIPClient.h:56: error: 'memaddress' does not name a type
    /Users/nh/Documents/Arduino/libraries/UIPEthernet/UIPClient.h:85: error: 'UIP_CONNS' was not declared in this scope
    /Users/nh/Documents/Arduino/libraries/UIPEthernet/UIPClient.h:92: error: ISO C++ forbids declaration of 'memhandle' with no type
    /Users/nhDocuments/Arduino/libraries/UIPEthernet/UIPClient.h:92: error: expected ';' before '*' token
    /Users/nh/Documents/Arduino/libraries/UIPEthernet/UIPClient.h:93: error: 'memhandle' has not been declared
    /Users/nh/Documents/Arduino/libraries/UIPEthernet/UIPClient.h:94: error: 'memhandle' has not been declared
    In file included from EthernetGateway.ino:53:
    /Users/nh/Documents/Arduino/libraries/UIPEthernet/UIPEthernet.h:88: error: field 'periodic_timer' has incomplete type
    /Users/nh/Documents/Arduino/libraries/UIPEthernet/UIPEthernet.h:90: error: 'memhandle' does not name a type
    /Users/nh/Documents/Arduino/libraries/UIPEthernet/UIPEthernet.h:91: error: 'memhandle' does not name a type
    /Users/nh/Documents/Arduino/libraries/UIPEthernet/UIPEthernet.h:95: error: 'Enc28J60Network' does not name a type

    What am i missing, i have download the new arduino file


  • Admin

    @Hoffan

    Which version of the Arduino IDE are you using?



  • @hek

    Hope i understand right 1.0.5 on MAC


  • Admin

    Could you give a try with 1.5.5(+)?



  • @hek

    Yes i will, BRB



  • I only find 1.5.7 beta No 1.5.5

    the only non beta i find is 1.0.5


  • Admin

    Go for 1.5.7.



  • Today i compiled it serveral times with IDE 1.0.5 under windows without a problem. And after some time i got exact the same error message as you. So i decited to use 1.5.7 beta to compile, there are some other ugly compiling messages, but at the end it was successfull for me.



  • @klim

    Yes i see the same message here, But i think i get it to work rikght now..



  • I get it to work to program my Gateway, But
    nothing happens when i put the start button for inclusion new sensors

    And i have pure the new files into my Vera and i have Ui5 on that one

    The GW seriel log looks like this all the time

    0;0;3;0;9;send: 0-0-255-255 s=255,c=3,t=8,pt=1,l=1,st=fail:0
    0;0;3;0;9;read: 255-255-255 s=255,c=3,t=7,pt=0,l=0:
    0;0;3;0;9;send: 0-0-255-255 s=255,c=3,t=8,pt=1,l=1,st=fail:0
    0;0;3;0;9;read: 255-255-255 s=255,c=3,t=7,pt=0,l=0:
    0;0;3;0;9;send: 0-0-255-255 s=255,c=3,t=8,pt=1,l=1,st=fail:0
    0;0;3;0;9;read: 255-255-255 s=255,c=3,t=7,pt=0,l=0:
    0;0;3;0;9;send: 0-0-255-255 s=255,c=3,t=8,pt=1,l=1,st=ok:0
    0;0;3;0;9;read: 255-255-255 s=255,c=3,t=7,pt=0,l=0:
    0;0;3;0;9;send: 0-0-255-255 s=255,c=3,t=8,pt=1,l=1,st=fail:0



  • @hek

    Do you have any solutions for my problem??

    I have seen that i lost ping when i try to ping the gateway
    it work to ping when i restart the GW but if i test for ex 10 minutes later it don't work



  • bild.jpg

    Should it looks like this. Why is Lib version empty..


  • Admin

    Two threads with the same problem:

    http://forum.mysensors.org/topic/371/errors-compiling-ethernetgateway-with-uipeternet-h

    Lib is empty because your Vera plugin is unable to communicate with the ethernet gateway.



  • Hi, got some problems wth ethGW (wiznet + uno)
    latest version from git is not for me (no blinks and eth communication with vera)
    but old dev version http://pastebin.com/6YFrs6HT works fine. could someone help me plz.

    thx



  • add: blinks and inclusion starts and stops works fine (with old version), but no lib version and new devices in vera after that



  • What ethernet module do you have?



  • @Hoffan - wiznet


Log in to reply
 

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.