Re-assign ID



  • Hi.
    I try find in this formum solution why not possible manualy reassign new id to my node.
    I use Ethernet Gateway with MYSController 0.1.2.282 .
    I can Assign new firmware from list .. work perfect .. but if try change - reassign new ID then still use same ..
    In sketch is :

    gw.begin(incomingMessage, AUTO, true);
    

    this define auto .. then not problem to reassign .. I think ..
    If try it manualy also not working .. if try .. clear eeprom ...and must automatic reassign .. still use same ID ..

    regards.


  • Admin

    @dzairo please provide logs with debug enabled.



  •  [2016-04-27 20:55:10.973 Info] INFO	*** Logging START ***
     [2016-04-27 20:55:10.974 Info] VERSION	MYSController 0.1.2.282
     [2016-04-27 20:55:33.569 Info] NODE	New node discovered, node id=2
     [2016-04-27 20:55:33.570 Info] CHILD	New child discovered, node id=2, child id=internal
     [2016-04-27 20:55:33.570 Info] DEBUG	Assigned firmware=Blink to node=2
     [2016-04-27 20:55:33.571 Info] INFO	BL version=257
     [2016-04-27 20:55:33.572 Info] INFO	Send FW info to node 2: type=A, version=1, blocks=0x02C8, CRC=0xB718
     [2016-04-27 20:55:33.573 Info] TX	2;0;4;0;1;0A000100C80218B7
     [2016-04-27 20:55:33.574 Info] RX	2;255;4;0;0;0A000100C80218B70101
     [2016-04-27 20:55:33.655 Info] SIGNING	Node 2 does not require signing
     [2016-04-27 20:55:33.656 Info] SIGNING	MYSController is not signing
     [2016-04-27 20:55:33.656 Info] TX	2;255;3;0;15;0
     [2016-04-27 20:55:33.658 Info] RX	2;255;3;0;15;0
     [2016-04-27 20:55:33.658 Info] DEBUG	Update child id=255, type=ARDUINO_NODE
     [2016-04-27 20:55:33.659 Info] RX	2;255;0;0;17;1.5.4
     [2016-04-27 20:55:33.662 Info] TX	2;255;3;0;6;M
     [2016-04-27 20:55:33.663 Info] RX	2;255;3;0;6;0
     [2016-04-27 20:55:35.671 Info] RX	2;255;3;0;11;Bin.Sensor Sleep
     [2016-04-27 20:55:35.674 Info] RX	2;255;3;0;12;1.0
     [2016-04-27 20:55:35.676 Info] CHILD	New child discovered, node id=2, child id=3
     [2016-04-27 20:55:35.677 Info] DEBUG	Update child id=3, type=DOOR
     [2016-04-27 20:55:35.678 Info] RX	2;3;0;0;0;
     [2016-04-27 20:55:35.679 Info] CHILD	New child discovered, node id=2, child id=4
     [2016-04-27 20:55:35.679 Info] DEBUG	Update child id=4, type=DOOR
     [2016-04-27 20:55:35.681 Info] RX	2;4;0;0;0;
     [2016-04-27 20:55:35.722 Info] RX	2;3;1;0;16;1
     [2016-04-27 20:55:35.745 Info] RX	2;255;3;0;0;79
     [2016-04-27 20:55:40.876 Info] RX	2;4;1;0;16;0
     [2016-04-27 20:55:41.375 Info] RX	2;4;1;0;16;1
     [2016-04-27 20:55:42.819 Info] RX	2;3;1;0;16;0
     [2016-04-27 20:55:43.461 Info] RX	2;3;1;0;16;1
     [2016-04-27 20:55:54.189 Info] TX	2;0;3;0;13;0
     [2016-04-27 20:56:13.510 Info] REPO	FW "Blink" loaded. t=10, v=1, blocks=712, crc=0xB718
     [2016-04-27 20:56:13.523 Info] REPO	FW "TimeReporter" loaded. t=20, v=1, blocks=840, crc=0x4AC5
     [2016-04-27 20:56:13.542 Info] REPO	FW "Sensebender Micro" loaded. t=100, v=1, blocks=1344, crc=0x3482
     [2016-04-27 20:56:13.552 Info] REPO	FW "Sensebender Blink" loaded. t=110, v=1, blocks=768, crc=0x1314
     [2016-04-27 20:56:13.552 Info] REPO	FW repository loaded. Items=4
     [2016-04-27 20:56:17.551 Info] TX	2;0;3;0;13;0
     [2016-04-27 20:57:00.075 Info] CHILD	New child discovered, node id=2, child id=3
     [2016-04-27 20:57:00.076 Info] RX	2;3;1;0;16;0
     [2016-04-27 20:57:00.439 Info] RX	2;3;1;0;16;1
     [2016-04-27 20:57:02.092 Info] CHILD	New child discovered, node id=2, child id=4
     [2016-04-27 20:57:02.094 Info] RX	2;4;1;0;16;0
     [2016-04-27 20:57:02.363 Info] RX	2;4;1;0;16;1
    

Log in to reply
 

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.