Humidity and Temp sensor problem



  • Hi to all
    I have arduino nano and Domoticz on raspberry pi.
    Yesterday everything was working but today my sketch from Mysensor library (Humidyty sketch - I have DHT 11) sends data only once at begginning and stop sending anything.
    My Domoticz see temp and humidity values only once when arduino starts. After that no new values are received
    I don't know what is happenning
    Any idea?
    Best regards


  • Mod

    @Łukasz-Kostrzewa the default behavior is to only send values if they have changed from laste measurement. Could it be that there are no changes?

    Serial debug log from the sensor is usually one of the first things to look at, it can be very helpful.



  • Thx for quick answer.
    I was thinking the same. But I have been using this sketch for about a month and temp values was sending to my raspberry pi Domoticz every second.
    Suddenly sketch sends values at the beggining and dies:(

    I Wonder what means:
    delay(dht.getMinimumSamplingPeriod());
    in Humidity sketch from My sensors library.
    When I use my serial debug log I see that my temp and humidity values are send but only once and script stops. Yesterday sketch send this values all the time.
    This is weird


  • Mod

    @Łukasz-Kostrzewa try adding a Serial.println statement before and after the sensor goes to sleep to see if they both get executed.

    dht.getMinimumSamplingPeriod() returns the time to wait when the dht takes a measurement. You can do a Serial.println(dht.getMinimumSamplingPeriod()); if you eant to see the value.


  • Contest Winner

    I have some sensors with DHT that behave the same. I know the node keeps working cause the values from the barometer sensor, which is on the some node, keeps working. The most interesting thing is that the temp and humidity values are being reported again after a couple of days.

    So far I've noticed that this happens when I add or remove the power plugs of other devices that are in the same outlet. It's a funny problem ;-). And think it's power related.



  • Hi again
    I've done a simple test.
    I grab my dht11 sensor in my hand and after some time values are being see my values being send in my serial debug. I don't know why yesterday values was sending all the time but...
    Sketch is working and reports temp changes by 1 degree.
    Best regards and thx for answers



  • Hi
    After hour script back to the beginning and now it sends temp + hum values every second:)
    I don't understand what is going on :)
    Best regards


  • Hardware Contributor

    Most likely power issues. Does the node run on battery? Otherwise is the power source stable and do you use a capacitor at the radio?



  • Hi
    Powers source - phone charger 5V 1Aand Yes...I use 4,7 capacitor at the radio.


  • Hardware Contributor

    @Łukasz-Kostrzewa 5V, so you are using a voltage converter to 3.3V? Have you checked that one (stable output, not overheating,...)?


  • Hero Member

    Have you consider that The DHT is broken? These sensors have a short lifetime (and are inaccurate etc., there are much better alternatives.



  • Hi
    Maybe it is broken. I don't know :(I have couple of DHT11 sensors and some of them are working sam of them are not :(
    From yesterday (so far) everything works great :)
    I report later if something will broke.
    Best regards



  • One hour ago Temp and humidity sensor stopped working :( I'm not strong enough to use arduino and my sensors:( I need to buy another raspberry pi and set it as a slave (I have 4 in my house and I have no problem with them).
    Best regards


Log in to reply
 

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.