💬 Water Meter Pulse Sensor



  • Has it ever received a pulse count?



  • When its about 2 metres far from gateway its received. Afterthat can be moved 10 metres away and it works. But after reset has to be moved close to gateway again.
    I run also power meter pulse sensor. This has got different issue. It falls asleep before receiving pulse count from gw.



  • @ladislav Sounds like a radio problem. Are you using a capacitor on the radio power supply pins? A capacitor on all radios in your network. I have a an Ethernet gateway in our basement and a node in our attic that is two floors above it and it works fine using a NRF24 for all radios and the radio power is on the default setting and it communicates fine.



  • I having problem to place the tcrt5000 on the correct place. Can anyone please show where to put it? Is it over the black (that spins every 0.5 l)?

    I have this type of water meter alt text



  • @smilvert I am afraid your water meter does not work. On many other watermeters the black spinning wheel is somewhat bigger and has a small mirror attached. The light from the IR LED is reflected by the mirror and the IR sensor picks up the reflection as a pulse every rotation (in your case 0.5 L). I suggest you buy another water meter that has a sensor build in and provides you with a direct signal. In my home I have separate water meters for each water consumer (such shower, hot water, kitchen, etc.).

    I am using a Honeywell C7195A2001B which has a hall sensor that pulses at 7 Hz per liter/min, so you will get 420 pulses per liter. These meters are typically used in boiler or central heating systems that also can provide hot water for your shower. You need to modify the source code a bit to handle the high pulse frequency, but the nice thing is that the measurement is very accurate.

    regards

    Bart



  • @smilvert You could try a magnometer. I successfully used one on my gas meter that didn't have a magnet in it. Look up "gas meter using a magnometer" in this forum. The code is much different than using the standard water meter sketch.



  • @smilvert @dpcr
    I really doubt this type of water meter having a magnet to sense. Gas meters often are prepared to use a special reed swich to be mounted somewhere outside on the enclosure, and the magnet comes pretty close to the enclosure to be sensed.

    I somewhere found a different solution approach using a modified TCRT5000 board with green LED and a specific lightsensor (see here for details, german).

    The idea behind it is to use complementary (green) light to one of the red pointer wheels to improve contrast when the small pointer passes.

    I recently did some first test wrt. to this, but different to the mentioned solution, I used the original LED/sensor places to connect these two parts (and also changed the resistors values). Unfortunately, I wasn't able to test it "at the right place" until now. As far as I can see, the TCRT5000 inside just also consist of two seperate parts inside a housing. So you may try to do it like that: just pull of the plastic housing, change the LED (see TCRT datasheet which one) with a green one, focus LED and sensor a little more than normal and see, if you get reasonable results whith the trimming resistor.

    Glad for feedback, if this works...



  • @rejoe2 A magnetometer doesn't need a magnet to work, my gas meter doesn't have a magnet and it works fine. Most all smartphones have magnetometers in them to sense direction. However your solution looks to work as well and probably with less code.



  • @dpcr Thanks for clarification.
    Today there was a new post that may be of interest wrt. to the "green" LED sensing modification: https://forum.fhem.de/index.php?action=post;quote=702342;topic=71341.0;last_msg=702342
    This one seems to be close to a "professional" solution also wrt. to the other parts used (but most likely not on a TCRT5000-Base)...



  • I have a question and need some advise,
    is it possible to expand the sketch to two meters.
    In my case I want to combine a this Water Meter with a Gas Meter.
    Can both meters use an interrupt, each?


  • Mod

    @rpunkt welcome to the MySensors community!

    it depends on which microcontroller you use, and what type of interrupt.

    Atmega328 can use pin 2 and 3 at the same time by merging the sketches. More/other pins can be used but that will require some code changes.



  • @smilvert
    I also have same meter as the picture. Yesterday I installed my sensor
    I took a TCRT5000 IR sensor, https://www.mysensors.org/store/water
    A cap from a soda bottle, cut it so it fits above left red wheel(X0,0001) which means one lap i 1 liter
    It works but it counts little bit wrong, I have change the

    if (interval<500000L)
    

    to

    if (interval<2500000L)
    

    but anyway it counts about 3 times to much. I will check it later today

    0_1518429857989_vatten.png
    0_1518429910010_water.png



  • @flopp
    This didn't worked so well, I got a lot of errors everytime nRF was sending data, then I got one pulse.
    Anyone know how to protect the digital input to NOT fall when nRF sends?
    Wait, when I was writing this text 🙂 I just remember that nRF is using Pin 2, is that correct?
    I will try to use pin 3 instead, as interrupt pin



  • @flopp
    tried pin3, didn't help

    Can it be something wrong with LM393(pcb)?



  • @flopp Nice. You don't use a green led? I tried that and it seems to work better but then I struggle with the mounting.

    Need to try this again!



  • @smilvert said in 💬 Water Meter Pulse Sensor:

    You don't use a green led? I tried that and it seems to work better but then I struggle with the mounting.

    I am using IR to detect movements. Green LED is flashing eveytime the IR detects movement and Red LED is power for PCB.
    I am using Digital Output from PCB to pin 2 or 3 on my UNO. I have tried both with INPUT_PULLUP and without, also tried 20K between Digital Output and GND. nothing is helping

    How do you use green LED with water meter?



  • Hi all i just wanna see The OUTPUT of Serial Monitor for this project sow i can see results .


  • Mod

    Just enable the my_debug



  • How can i get the pulses from SonOff.... i cannot find any digital pin 3 in sonoff... im new to this please guide me


  • Hardware Contributor

    Any one used this approach? From the text I see that the node sleeps! How does it measures the consumption if the node is sleeping?

    Thank you


  • Mod

    @soloam could you clarify what you refer to when saying "this"? Earlier posts discuss infrared, led, magnetometer and other solutions so it is a bit hard to answer your question.


  • Hardware Contributor

    @mfalkvidd hello!

    I was referring to this statement in the site:

    "Use this mode if you power the sensor with a battery. In this mode the sensor will sleep most of the time and only report the cumulative water volume."

    Thank you


  • Mod

    according to the sensor you use, each pulse should wake the node and add a count, then back to sleep.


  • Hardware Contributor

    That is nice! But I would have to test it out! Probably that would make the node all the time awake during a long bath! Ok, it would not use the radio all the time, but I would like to know who that would affect the battery!

    Thank you all for the feedback



  • @soloam
    We sometimes forgot about other circuit than Arduino.
    Use CMOS counter IC and wake up your Arduino for example every 20 impulse and read counter status.
    If you want Safe battery.


  • Hero Member

    @flopp Did you ever manage to stabilize the readings? Am I understanding you correctly that the readings were fine but the transmission got the reading scrambled?

    Did you try to find a magnetic field with the meter instead? I have a similar meter and I'm wondering how best to approach the problem. I've seen people hook up Raspberries and cameras to do OCR basically but that seems like way too complex for an easy problem.



  • @flopp said in 💬 Water Meter Pulse Sensor:

    TCRT5000 IR senso

    I have not had good results using TCRT5000 IR sensor, did you?
    @bjornhallberg well I still think this is the best approach to use RPI + OCR

    https://forum.mysensors.org/topic/1594/automatic-water-meter-reading-with-a-webcam
    https://blog.m.nu/vattenmatning-med-raspberry-pi-och-webkamera/


  • Hero Member

    While looking into the water meter I realized that we are getting a "smart" meter replacement soon. I'll see if I can speed up the replacement schedule. Anyhow, the replacement is a Kamstrup Multical 21 (https://www.kamstrup.com/en-en/water-solutions/water-meters/multical-21) which has several options for reading:

    • Requesting the data via optical interface?
    • Enabling the pulse function via optical interface, and then reading the IR pulse at 1imp/10lit.
    • Reading the wireless mbus signal? (e.g. https://github.com/weetmuts/wmbusmeters)


  • @bjornhallberg Suggest you discuss with your water supplier, and see what THEY intend to deploy for comms and explain what your own objectives are, that may refine what you are looking at, and they MIGHT actually help rather than be play "stupid" which is unfortunately common nowadays. In all probability they will be looking at wireless m-bus for drive-by readings, this is the predominant method of retrieval.
    I admit to surprise at them deploying ultrasonics, they are on the expensive end of the market but they are extremely reliable and accurate.



  • @bjacobse said in 💬 Water Meter Pulse Sensor:

    @flopp said in 💬 Water Meter Pulse Sensor:

    TCRT5000 IR senso

    I have not had good results using TCRT5000 IR sensor, did you?

    I didn’t get it to work.
    I was so lucky that my water company change the meter to a meter with wireless m-bus.
    So I bought a box for this and now I have 100% correct readings.



  • @bjacobse Another option perhaps to consider (if it is physically viable), is to insert a meter and sensor of your choice within your property, they are not expensive nowadays and easy enough to fit ?
    A simple meter and reed switch such as this link text or similar perhaps.



  • @zboblamont
    In Sweden you need a certified installer to exchange your pipes, else in case of water damage your insurance won't cover.
    so cheapest for me is a RPI with camera - but yes I would prefer a "real" measuring from a dedicated sensor



  • @bjacobse Pardon my laughter, insurers look for any excuse for sure, but I have never heard yet where a water meter or any other competent insertion damaged a building, let alone an insurance company refused to compensate for a building which burned to the ground (99.9%) on the basis the water meter was not a verified install. For sure some loss adjusters will use any excuse, but really?
    To clarify, in many countries a certified inspector or Engineer must certify that work is carried out within the regulations, it does not state that HE/SHE has carried out the work, only that it has been inspected and verified as compliant. You know any certified local plumbers with 5 minutes to spare, because that is how long it takes me to fit one, and about the time it takes a certified pipe-jockey to verify it's right and sign it off, if it really concerns you ?

    I have 2 self fitted water meters with sensors, gas meter sensor etc, and a huge amount of DIY stuff any smartass insurer could IMPLY was a contributory factor to the disaster which befell my house, but frankly it wouldn't stand 1 second in Court before being laughed out...
    Place hasn't burned down yet, fallen over in earthquakes, or been subjected to landslide, but luckily I don't have Swedish Insurers.... 😉
    PS- I should clarify that the standing regulations are framed to quite rightly protect consumers as well as the service provider against cowboys interfering with apparatus. Changing light switches or sockets falls under the same overall umbrella despite everyone and their mother changing them.



  • @bjacobse I believe you can replace the meter yourself if you own it yourself and have the necessary skills. I live in such an area and was told I could mount it myself if I was confident enough. But of course, the fault will be yours if your bad job causes damages. In reality it is quite unlikely that you can mount it badly and not notice the problem immediately.

    A more critical issue is that water meters are usually owned by the municipality or water company and they are sealed. It is impossible to replace the meter without breaking the seal and when the company notices they won't be happy at all.



  • @fredswed And by extension (Possibly Swedish water suppliers differ from UK or Romanian counterparts?) the data retrieved from their devices is often regarded as their property also, and brick walls begin to appear ino what should be readily shared data. If they will not share, fitting a downstream device within your own control can often be the only solution, don't interfere, augment...

    As a perverse example, my own gas and electricity suppliers are the German monolith EON who provide and enable access to their 'graphs' online, updated with 1 or 2 month readings (gas and electricity).
    Having checked the base data for their graphs, I realised they were presenting a lovely graph based on complete bunkum, and developed and maintained my own ever since, which IS accurate. I checked recently and their graphs are still pretty but complete rubbish.
    Installing a gas meter sensor caused EON palpitations until they realised it was the commercial device for the meter and could not object on technicalities then quietly dropped objections, I don't care how they respond when I fit meters to the Consumer box, it is nowhere near their SMART meter which tells me nothing but tells them much, mainly that I halved their 2 monthly bill 😉 .
    If the service provider will allow detailed sharing of YOUR data, all good and well as it is mutually beneficial, but if not, easy enough to solve at your own expense.
    I fitted two replacement upgraded radiators in the last month, somewhere a Romanian regulation lurks that I should not have done so, but the insurer doesn't give a damn unless it is found to have caused the demise of the insured property.. Is it worth the risk? Hell yes...



  • It looks very interesting. I complied and uploaded successful, but it ran without run the loop function at all. infrared sensor lighted up but no print out attached Serial.print.
    Can you give us the url to the library #include <MySensors.h>?. I am using MySensors 2.3.1 loaded from Adruino IDE->Tools->Manage Libary->search My Sensors from https://www.mysensors.org

    4:55:53.476 -> 60127 TSM:FAIL:RE-INIT
    14:55:53.476 -> 60129 TSM TSM:FAIL:DIS
    14:55:53.476 -> 900384 TSF:TDI:TSL
    14:55:54.962 ->
    14:55:54.962 -> __ __ ____
    14:55:54.962 -> | / |_ / | ___ _ __ ___ ___ _ __ ___
    14:55:54.962 -> | |/| | | | _
    \ / _ \ _ \/ __|/ _ \|
    / |
    14:55:54.962 -> | | | | |
    | |
    | | / | | _ \ _ | | _
    14:55:54.962 -> |
    | |
    |_, |/ _|| ||/_/|| |/
    14:55:54.962 -> |
    _/ 2.3.1
    14:55:54.962 ->
    14:55:54.962 -> 16 MCO:BGN:INIT NODE,CP=RNNNA---,REL=255,VER=2.3.1
    14:55:54.962 -> 26 TSM:INIT
    14:55:54.962 -> 27 TSF:WUR:MS=0
    14:55:54.997 -> 33 !TSM:INIT:TSP FAIL
    14:55:54.997 -> 35 TSM:FAIL:CNT=1
    14:55:54.997 -> 37 TSM:FAIL:DIS


  • Mod

    it looks like it is can't find the radio module. Check cables and pins numering



  • Sorry to hijack the thread a bit,
    I'm using a TCRT5000 sensor to read a water meter (Zenner), it works ok until it stops detecting pulses, I have to increase the sensitivity (clockwise turn the trimpot) and it works ok for another few days/weeks, then again it needs an increase in sensitivity, like somehow it's loosing it's sensitivity .
    I'm already with my second sensor, the first one got to the end of the trimpot and couldn't adjust anymore.

    Has this happened to anyone else? It's powered by 5V, it's the LED losing power or the photosensor losing sensitivity? Any ideas?
    Thanks.


  • Mod

    Don't you have another sensor to try?



  • @flopp which box did you buy for m-bus readings? did you work it out?
    ''I was so lucky that my water company change the meter to a meter with wireless m-bus.
    So I bought a box for this and now I have 100% correct readings.''



  • Water Meter shows up in mysensors.json and homeassistant logs but fails to appear in Homeassistant GUI.
    I have a dozen Nodes already successfully operating
    I used the default sketch on this page. Just added Node 6
    Looks like values are not getting through
    Thank you for your help



  • this is HA log:

    2019-07-04 23:24:05 DEBUG (MainThread) [homeassistant.components.mqtt] Received message on mygateway1-out/6/255/3/0/11: b'Water Meter',
    2019-07-04 23:24:05 DEBUG (MainThread) [mysensors.gateway_mqtt] Receiving 6;255;3;0;11;Water Meter,
    2019-07-04 23:24:23 DEBUG (MainThread) [homeassistant.components.mqtt] Received message on mygateway1-out/6/255/3/0/11: b'Water Meter',
    2019-07-04 23:24:23 DEBUG (MainThread) [mysensors.gateway_mqtt] Receiving 6;255;3;0;11;Water Meter



  • here is the sketch:

    // Enable debug prints to serial monitor
    #define MY_DEBUG
    
    // Enable and select radio type attached
    #define MY_RADIO_RF24
    #define MY_NODE_ID 6
    //#define MY_RADIO_NRF5_ESB
    //#define MY_RADIO_RFM69
    //#define MY_RADIO_RFM95
    
    #include <MySensors.h>
    
    #define DIGITAL_INPUT_SENSOR 3                  // The digital input you attached your sensor.  (Only 2 and 3 generates interrupt!)
    
    #define PULSE_FACTOR 1000                       // Number of blinks per m3 of your meter (One rotation/liter)
    
    #define SLEEP_MODE false                        // flowvalue can only be reported when sleep mode is false.
    
    #define MAX_FLOW 40                             // Max flow (l/min) value to report. This filters outliers.
    
    #define CHILD_ID 1                              // Id of the sensor child
    
    uint32_t SEND_FREQUENCY =
        30000;           // Minimum time between send (in milliseconds). We don't want to spam the gateway.
    
    MyMessage flowMsg(CHILD_ID,V_FLOW);
    MyMessage volumeMsg(CHILD_ID,V_VOLUME);
    MyMessage lastCounterMsg(CHILD_ID,V_VAR1);
    
    double ppl = ((double)PULSE_FACTOR)/1000;        // Pulses per liter
    
    volatile uint32_t pulseCount = 0;
    volatile uint32_t lastBlink = 0;
    volatile double flow = 0;
    bool pcReceived = false;
    uint32_t oldPulseCount = 0;
    uint32_t newBlink = 0;
    double oldflow = 0;
    double volume =0;
    double oldvolume =0;
    uint32_t lastSend =0;
    uint32_t lastPulse =0;
    
    void setup()
    {
      // initialize our digital pins internal pullup resistor so one pulse switches from high to low (less distortion)
      pinMode(DIGITAL_INPUT_SENSOR, INPUT_PULLUP);
    
      pulseCount = oldPulseCount = 0;
    
      // Fetch last known pulse count value from gw
      request(CHILD_ID, V_VAR1);
    
      lastSend = lastPulse = millis();
    
      attachInterrupt(digitalPinToInterrupt(DIGITAL_INPUT_SENSOR), onPulse, FALLING);
    }
    
    void presentation()
    {
      // Send the sketch version information to the gateway and Controller
      sendSketchInfo("Water Meter", "1.1");
    
      // Register this device as Water flow sensor
      present(CHILD_ID, S_WATER);
    }
    
    void loop()
    {
      uint32_t currentTime = millis();
    
      // Only send values at a maximum frequency or woken up from sleep
      if (SLEEP_MODE || (currentTime - lastSend > SEND_FREQUENCY)) {
        lastSend=currentTime;
    
        if (!pcReceived) {
          //Last Pulsecount not yet received from controller, request it again
          request(CHILD_ID, V_VAR1);
          return;
        }
    
        if (!SLEEP_MODE && flow != oldflow) {
          oldflow = flow;
    
          Serial.print("l/min:");
          Serial.println(flow);
    
          // Check that we don't get unreasonable large flow value.
          // could happen when long wraps or false interrupt triggered
          if (flow<((uint32_t)MAX_FLOW)) {
            send(flowMsg.set(flow, 2));                   // Send flow value to gw
          }
        }
    
        // No Pulse count received in 2min
        if(currentTime - lastPulse > 120000) {
          flow = 0;
        }
    
        // Pulse count has changed
        if ((pulseCount != oldPulseCount)||(!SLEEP_MODE)) {
          oldPulseCount = pulseCount;
    
          Serial.print("pulsecount:");
          Serial.println(pulseCount);
    
          send(lastCounterMsg.set(pulseCount));                  // Send  pulsecount value to gw in VAR1
    
          double volume = ((double)pulseCount/((double)PULSE_FACTOR));
          if ((volume != oldvolume)||(!SLEEP_MODE)) {
            oldvolume = volume;
    
            Serial.print("volume:");
            Serial.println(volume, 3);
    
            send(volumeMsg.set(volume, 3));               // Send volume value to gw
          }
        }
      }
      if (SLEEP_MODE) {
        sleep(SEND_FREQUENCY);
      }
    }
    
    void receive(const MyMessage &message)
    {
      if (message.type==V_VAR1) {
        uint32_t gwPulseCount=message.getULong();
        pulseCount += gwPulseCount;
        flow=oldflow=0;
        Serial.print("Received last pulse count from gw:");
        Serial.println(pulseCount);
        pcReceived = true;
      }
    }
    
    void onPulse()
    {
      if (!SLEEP_MODE) {
        uint32_t newBlink = micros();
        uint32_t interval = newBlink-lastBlink;
    
        if (interval!=0) {
          lastPulse = millis();
          if (interval<500000L) {
            // Sometimes we get interrupt on RISING,  500000 = 0.5 second debounce ( max 120 l/min)
            return;
          }
          flow = (60000000.0 /interval) / ppl;
        }
        lastBlink = newBlink;
      }
      pulseCount++;
    }```


  • looks like the problem is the node is NOT sending initial value to gw
    need your help modifying the sketch accordingly
    thank you



  • Is it possible to get any help on this page or not?



  • @bereska said in 💬 Water Meter Pulse Sensor:

    Is it possible to get any help on this page or not?

    Crying out loud most likely will not help...
    Seems your setup is a little special, so just some assumptions from one using a serial GW and not MyS-MQTT:
    Your controller is asked for sending an initial value, but has none yet. So no answer is sent out. Triggering the counter on Node side could help to send one (after waiting time has passed). Then have a look at your controller, if there's a value available. If, you might set the correct value, restart your node afterwards and see, if everything now works as expected?



  • @rejoe2 thank you. How do i trigger "the counter on Node side"?



  • ...just let the node count some pulses (your code states: FALLING). So just pull the counter PIN (here: D3) to ground several times.



  • @rejoe2 i did like you said, still no show in HA
    here is the serial log:

     __  __       ____
    |  \/  |_   _/ ___|  ___ _ __  ___  ___  _ __ ___
    | |\/| | | | \___ \ / _ \ `_ \/ __|/ _ \| `__/ __|
    | |  | | |_| |___| |  __/ | | \__ \  _  | |  \__ \
    |_|  |_|\__, |____/ \___|_| |_|___/\___/|_|  |___/
            |___/                      2.3.0
    
    16 MCO:BGN:INIT NODE,CP=RNNNA---,VER=2.3.0
    26 TSM:INIT
    28 TSF:WUR:MS=0
    34 !TSM:INIT:TSP FAIL
    36 TSM:FAIL:CNT=1
    38 TSM:FAIL:DIS
    40 TSF:TDI:TSL
     
     __  __       ____
    |  \/  |_   _/ ___|  ___ _ __  ___  ___  _ __ ___
    | |\/| | | | \___ \ / _ \ `_ \/ __|/ _ \| `__/ __|
    | |  | | |_| |___| |  __/ | | \__ \  _  | |  \__ \
    |_|  |_|\__, |____/ \___|_| |_|___/\___/|_|  |___/
            |___/                      2.3.0
    
    16 MCO:BGN:INIT NODE,CP=RNNNA---,VER=2.3.0
    26 TSM:INIT
    28 TSF:WUR:MS=0
    34 TSM:INIT:TSP OK
    36 TSM:INIT:STATID=6
    38 TSF:SID:OK,ID=6
    40 TSM:FPAR
    77 TSF:MSG:SEND,6-6-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    532 TSF:MSG:READ,0-0-6,s=255,c=3,t=8,pt=1,l=1,sg=0:0
    538 TSF:MSG:FPAR OK,ID=0,D=1
    624 TSF:MSG:READ,31-31-6,s=255,c=3,t=8,pt=1,l=1,sg=0:1
    1267 TSF:MSG:READ,21-21-6,s=255,c=3,t=8,pt=1,l=1,sg=0:1
    1546 TSF:MSG:READ,41-41-6,s=255,c=3,t=8,pt=1,l=1,sg=0:1
    2088 TSM:FPAR:OK
    2088 TSM:ID
    2091 TSM:ID:OK
    2093 TSM:UPL
    2097 TSF:MSG:SEND,6-6-0-0,s=255,c=3,t=24,pt=1,l=1,sg=0,ft=0,st=OK:1
    2103 TSF:MSG:READ,0-0-6,s=255,c=3,t=25,pt=1,l=1,sg=0:1
    2109 TSF:MSG:PONG RECV,HP=1
    2113 TSM:UPL:OK
    2115 TSM:READY:ID=6,PAR=0,DIS=1
    2119 TSF:MSG:SEND,6-6-0-0,s=255,c=3,t=15,pt=6,l=2,sg=0,ft=0,st=OK:0100
    2127 TSF:MSG:READ,0-0-6,s=255,c=3,t=15,pt=6,l=2,sg=0:0100
    2138 TSF:MSG:SEND,6-6-0-0,s=255,c=0,t=17,pt=0,l=5,sg=0,ft=0,st=OK:2.3.0
    2148 TSF:MSG:SEND,6-6-0-0,s=255,c=3,t=6,pt=1,l=1,sg=0,ft=0,st=OK:0
    2242 TSF:MSG:READ,0-0-6,s=255,c=3,t=6,pt=0,l=1,sg=0:M
    2250 TSF:MSG:SEND,6-6-0-0,s=255,c=3,t=11,pt=0,l=11,sg=0,ft=0,st=OK:Water Meter
    2260 TSF:MSG:SEND,6-6-0-0,s=255,c=3,t=12,pt=0,l=3,sg=0,ft=0,st=OK:1.1
    2273 TSF:MSG:SEND,6-6-0-0,s=1,c=0,t=21,pt=0,l=0,sg=0,ft=0,st=OK:
    2281 MCO:REG:REQ
    2289 TSF:MSG:SEND,6-6-0-0,s=255,c=3,t=26,pt=1,l=1,sg=0,ft=0,st=OK:2
    2297 TSF:MSG:READ,0-0-6,s=255,c=3,t=27,pt=1,l=1,sg=0:1
    2304 MCO:PIM:NODE REG=1
    2306 MCO:BGN:STP
    2310 TSF:MSG:SEND,6-6-0-0,s=1,c=2,t=24,pt=0,l=0,sg=0,ft=0,st=OK:
    2318 MCO:BGN:INIT OK,TSP=1
    32319 TSF:MSG:SEND,6-6-0-0,s=1,c=2,t=24,pt=0,l=0,sg=0,ft=0,st=OK:
    


  • @bereska said in 💬 Water Meter Pulse Sensor:

    32319 TSF:MSG:SEND,6-6-0-0,s=1,c=2,t=24,pt=0,l=0,sg=0,ft=0,st=OK:

    Logparser states: there was nothing counted (empty payload). So make sure, there really was counted anything.
    (I didn't check your sketch, just assuming, it's the default one and everything is wired correctly; if that's the case, you should be able to see a different payload than nothing or "0", that your controller might treat as non existent).


 

219
Online

8.9k
Users

9.6k
Topics

100.9k
Posts