RFM69HW make a chance in Myconfig.h



  • Hello,

    I am trying to make a gateway and sensor with RFM 69HW.
    Stil now it is not working and i don't no what it is.
    I see in the MyConfig bij the RFM69HW a remark // standing and i use 433 Mhz and in the Myconfig.h is 862 Mhz.
    Can some one tell mee that i have to make chance in his Myconfig.h file.

    2e questing can i test the gateway?
    I see the gateway in domoticz is it than working.

    Ton Rijnaard


  • Admin

    @TON-RIJNAARD

    It should not be necessary to change the MyConfig.h file. All you need is to include the following in your sketch (before you include MySensors.h)

    #define MY_RFM69_FREQUENCY  RF69_433MHZ
    


  • Hello,

    Thanks for the fast re[ly but with the RF69_433MHZ it is not work.
    I get from the GW the next information.

    0;255;3;0;9;Starting gateway (RRNGA-, 2.0.0)
    0;255;3;0;9;TSM:INIT
    0;255;3;0;9;TSM:RADIO:OK
    0;255;3;0;9;TSM:GW MODE
    0;255;3;0;9;TSM:READY
    0;255;3;0;14;Gateway startup complete.
    0;255;0;0;18;2.0.0
    0;255;3;0;9;No registration required
    0;255;3;0;9;Init complete, id=0, parent=0, distance=0, registration=1
    0;255;3;0;9;TSP:SANCHK:OK

    Tis information from the node:

    Starting sensor (RRNNA-, 2.0.0)
    TSM:INIT
    TSM:RADIO:OK
    TSP:ASSIGNID:OK (ID=1)
    TSM:FPAR
    TSP:MSG:SEND 1-1-255-255 s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=bc:
    TSM:FPAR
    TSP:MSG:SEND 1-1-255-255 s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=bc:
    TSM:FPAR
    TSP:MSG:SEND 1-1-255-255 s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=bc:
    TSM:FPAR
    TSP:MSG:SEND 1-1-255-255 s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=bc:
    !TSM:FPAR:FAIL
    !TSM:FAILURE
    TSM:PDT

    The GW is Arduino uno with RFM69HW + 47 uf capacitor
    The Node is Mini pro with RFM69HW + 47 uf cacitor and 3.3 volt regulator.
    Can some one tell me of the information from the GW is correct.
    And what there is fals with the node that the !TSM:FPAR:FAIL means.

    Ton Rijnaard



  • @TON-RIJNAARD Do not forget - you have H version, so put the following in your sketch or change it in Myconfig.h

    #define MY_IS_RFM69HW
    

    EDIT: !TSM:FPAR:FAIL means the parent (GW) not found. Your node is not communicating

    to the GW. Try to put (1) the same frequencies and (2) as above in the GW and node sketches



  • Hello,

    I have chance the sketch like under:

    // Enable and select radio type attached
    // #define MY_RADIO_NRF24
    #define MY_RADIO_RFM69HW_FREQUENCY RF69_433MHZ

    #include <SPI.h>
    #include <MySensors.h>

    unsigned long SLEEP_TIME = 120000; // Sleep time between reports (in milliseconds)
    #define DIGITAL_INPUT_SENSOR 3 // The digital input you attached your motion sensor. (Only 2 and 3 generates interrupt!)
    #define CHILD_ID 1 // Id of the sensor child

    Now i can not compile the sketch i get this error:

    In file included from C:\Users\tonri\AppData\Local\Temp\arduino_modified_sketch_877909\MotionSensor.ino:38:0:

    C:\Users\tonri\Documents\Arduino\libraries\arduino_572221/MySensors.h:287:4: error: #error No forward link or gateway feature activated. This means nowhere to send messages! Pretty pointless.

    #error No forward link or gateway feature activated. This means nowhere to send messages! Pretty pointless.

    ^
    

    exit status 1
    Fout bij het compileren van board Arduino Pro or Pro Mini

    When i get the // away #define MY_RADIO_NRF24 then ik can compile wth out error

    Now give the monitor that no radio:
    Starting sensor (RNNNA-, 2.0.0)
    TSM:INIT
    !TSM:RADIO:FAIL
    !TSM:FAILURE
    TSM:PDT
    TSM:INIT
    !TSM:RADIO:FAIL
    !TSM:FAILURE
    TSM:PDT

    I have also change the Myconfig.h but no chance

    Ton


  • Mod

    @TON-RIJNAARD The rfmhw radio needs to be enabled. Add this before including MySensors.h

    #define MY_RADIO_RFM69
    

    with no transport enabled, there would be nowhere to send messages.



  • @mfalkvidd

    Thanks for your help.
    Look ad my piece of sketch that is be enabled or do i see somting about the head.

    Ton


  • Hero Member

    Hi @TON-RIJNAARD did you manage to get this to work?

    Here is how I have configured my RFM69 nodes and gateway when using RFM69 with 433MHz:

    Code in the beginning of Gateway sketch:

    // Enable debug prints to serial monitor
    //#define MY_DEBUG
    
    // Enable and select radio type attached
    //#define MY_RADIO_NRF24
    #define MY_RADIO_RFM69
    #define MY_RFM69_FREQUENCY RF69_433MHZ
    

    Code in the beginning of each sensor node:

    // Enable debug prints to serial monitor
    //#define MY_DEBUG 
    
    // Enable and select radio type attached
    //#define MY_RADIO_NRF24
    #define MY_RADIO_RFM69
    #define MY_RFM69_FREQUENCY RF69_433MHZ
    
    #include <SPI.h>
    #include <MySensors.h>
    

    I have not done any chages to the Myconfig.h

    Hope this helps...



  • @korttoma Why disabling MY_DEBUG? This is a useful function?

    You can either introduce your code in each sketch (like you did) or change MyConfig.h to make it default


  • Hero Member

    @alexsh1 I usually disable debug once I have confirmed that my node is working as expected. While testing I do have it enabled.



  • Hello

    Thanks for all the help i have it working now!!

    The problem was that in the GW this line was not there.

    #define MY_RFM69_PA_LEVEL RF69_PA_LOW

    here was standing, i have not chance that line

    #define MY_RF24_PA_LEVEL RF24_PA_LOW

    ton


Log in to reply
 

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.