Missing mysensors_XYZ.pretty files

  • I have installed KiCad on my Windows 8.1 PC and am trying to learn it so I can start making PCBs for some sensors. I am using the MySensors KiCad REPO and have followed the tutorial at https://github.com/mysensors-kicad/part_management and all seems to work. The issue though happens when I run CvPcb to associate the footprints and get the following error:

    IO_ERROR: footprint library path 'C:\Users\Thomas\Git\MySensors\mysensors_symbols\mysensors_radios.pretty' does not exist from C:/Jenkins/workspace/windows-kicad-msys2-stable/src/kicad/pcbnew/kicad_plugin.cpp : FootprintEnumerate() : line 1786

    I see the same error for all the mysensor_xyz.pretty files. Now those files are not in that location because the guide (refernced above) that I followed didn't say anything about cloning those "mysensor_xyz.pretty" repos and I was under the assumption that KiCad would look for those files in their respective GitHub repos. I figured that was the whole purpose of defining a MYSGITHUB path.

    Am I supposed to clone those repos as well? If so, wouldn't I need to update my fp-lib-table AND what is the point of the MYSGITHUB path?

    This is what the pertenant part of my fp-lib-table file looks like:

    (lib (name mysensors_arduino)(type Github)(uri ${MYSGITHUB}/mysensors_arduino.pretty)(options "allow_pretty_writing_to_this_dir=${MYSLOCAL}\mysensors_symbols\mysensors_arduino.pretty")(descr ""))
      (lib (name mysensors_buttons)(type Github)(uri ${MYSGITHUB}/mysensors_buttons.pretty)(options "allow_pretty_writing_to_this_dir=${MYSLOCAL}\mysensors_symbols\mysensors_buttons.pretty")(descr ""))
      (lib (name mysensors_connectors)(type Github)(uri ${MYSGITHUB}/mysensors_connectors.pretty)(options "allow_pretty_writing_to_this_dir=${MYSLOCAL}\mysensors_symbols\mysensors_connectors.pretty")(descr ""))
      (lib (name mysensors_handsoldering)(type Github)(uri ${MYSGITHUB}/mysensors_handsoldering.pretty)(options "allow_pretty_writing_to_this_dir=${MYSLOCAL}\mysensors_symbols\mysensors_handsoldering.pretty")(descr ""))
      (lib (name mysensors_leds)(type Github)(uri ${MYSGITHUB}/mysensors_leds.pretty)(options "allow_pretty_writing_to_this_dir=${MYSLOCAL}\mysensors_symbols\mysensors_leds.pretty")(descr ""))
      (lib (name mysensors_network)(type Github)(uri ${MYSGITHUB}/mysensors_network.pretty)(options "allow_pretty_writing_to_this_dir=${MYSLOCAL}\mysensors_symbols\mysensors_network.pretty")(descr ""))
      (lib (name mysensors_obscurities)(type Github)(uri ${MYSGITHUB}/mysensors_obscurities.pretty)(options "allow_pretty_writing_to_this_dir=${MYSLOCAL}\mysensors_symbols\mysensors_obscurities.pretty")(descr ""))
      (lib (name mysensors_radios)(type Github)(uri ${MYSGITHUB}/mysensors_radios.pretty)(options "allow_pretty_writing_to_this_dir=${MYSLOCAL}\mysensors_symbols\mysensors_radios.pretty")(descr ""))```

  • One more thing. I thought maybe the "/" were messing up Windows so I switched a few of them to "" and then got this error on the ones I switched:

    IO_ERROR: http GET command failed Cannot get/download Zip archive: 'https://codeload.github.com/mysensors-kicad%5cmysensors_radios.pretty/zip/master' for library path: 'https://github.com/mysensors-kicad\mysensors_radios.pretty'. Reason: 'Bad request' from C:/Jenkins/workspace/windows-kicad-msys2-stable/src/kicad/pcbnew/github/github_plugin.cpp : remote_get_zip() : line 584```

  • Admin

    I haven't tried to use kicad on windows, but on Linux I have to create the *.pretty directories myself, if I create them, and leave them empty, kicad can figure the rest out by itself.

    And it shouldn't be necessary to change the forward slashes... If I remember right, @Anticimex verified the setup instructions on windows..

  • Contest Winner

    The guide emphasizes in bold that you have to create the local pretty paths you specify in your fp table. Have you done that?

  • Ok, so I must have misread or just had a "space-out" moment when reading that part, but after creating the *.pretty directories it worked. Thanks!

  • Contest Winner

    Spacing out is done by all, glad it was such a simple "fix" 🙂

Log in to reply

Suggested Topics