Ping Pong with ESP8266 results in !TSM:FPAR:NO REPLY [solved]



  • Hello,

    I have 2 identical ESP8266 Node MCU's. Each has the Ping Pong example sketch installed to it.

    Now I'm getting a lot of Find Parent errors:

    TSM:INIT
    TSM:INIT:TSP OK
    TSM:INIT:STATID=201
    TSF:SID:OK,ID=201
    TSM:FPAR
    TSF:MSG:SEND,201-201-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    !TSM:FPAR:NO REPLY
    TSM:FPAR
    TSF:MSG:SEND,201-201-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    !TSM:FPAR:NO REPLY
    TSM:FPAR
    TSF:MSG:SEND,201-201-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    !TSM:FPAR:NO REPLY
    TSM:FPAR
    TSF:MSG:SEND,201-201-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    !TSM:FPAR:FAIL
    TSM:FAIL:CNT=7
    

    Why does a ping pong sketch between 2 nodes ask for a parent?

    What is needed to find the parent?

    Thanks!

    edit: updating the controller to the latest version has fixed the issue.


  • Mod

    I think one needs to have ID 0 and the other ID 1 if I remember well... but I never used it. Did you check already https://www.mysensors.org/build/debug ?



  • Yes, I checked the debug page.

    I followed all the documented steps:

     *  To use this sketch, assemble MySensors nodes - they need nothing more than a radio
     *  1.  Flash each node with the same sketch, open the console and type either 0 or 1 to the respective nodes to set thei ID
     *  2.  You only need to set the node id once, and restart the nodes
     *  3.  To being a ping-pong test, simply type T in the console for one of the nodes.
    

    Some documentation is missing:

    • You need to set the MY_NODE_ID to 201 or 200 when using it with ESP8266
    • You also need a Gateway, even when testing Node to Node ping pong

    It's not clear what the expected result is, I'd expect something like Ping from node 200, then Pong! from node 201. But it would seem that it gives "Ying node", then "Yang node".


  • Mod

    Besides the ping pong sketch, did you have trouble running normal gateway sketch and adding the other esp8266 as node?



  • @gohan not sure if I understand your question since I don't know what can be expected from the Gateway?

    Here's the gateway log:

    0;255;3;0;9;MCO:BGN:INIT GW,CP=RRNGE--,VER=2.1.1
    0;255;3;0;9;TSF:LRT:OK
    0;255;3;0;9;TSM:INIT
    0;255;3;0;9;TSF:WUR:MS=0
    scandone
    state: 0 -> 2 (b0)
    0;255;3;0;9;TSM:INIT:TSP OK
    0;255;3;0;9;TSM:INIT:GW MODE
    0;255;3;0;9;TSM:READY:ID=0,PAR=0,DIS=0
    0;255;3;0;9;MCO:REG:NOT NEEDED
    state: 2 -> 3 (0)
    state: 3 -> 5 (10)
    add 0
    aid 6
    cnt 
    chg_B1:-40
    f r-40, 
    connected with Airport, channel 6
    dhcp client start...
    scandone
    .chg_B1:-80
    ............ip:192.168.0.164,mask:255.255.255.0,gw:192.168.0.1
    .IP: 192.168.0.164
    0;255;3;0;9;MCO:BGN:STP
    0;255;3;0;9;MCO:BGN:INIT OK,TSP=1
    IP: 192.168.0.164
    0;255;3;0;9;Attempting MQTT connection...
    0;255;3;0;9;MQTT connected
    0;255;3;0;9;Sending message on topic: mygateway1-out/0/255/0/0/18
    pm open,type:2 0
    

    I see the following in the mqtt log:

    mygateway1-out/0/255/0/0/18 2.1.1
    

  • Mod

    I forgot to ask: are you using any nrf24 or rfm69 radio or are you trying to make the esp8266 talk to each other over wifi?



  • @gohan i'm using rfm69. Somehow I got it to work with one ESP gateway and 2 ESP nodes. All three have an rfm69 chip. I don't understand why you need a gateway to do ping pong?


  • Mod

    The mysensors protocol relies on the gateway, you can't do without it unless you are using other ping pong code that are not relying on mysensors.



  • @gohan then shouldn't there be a note in the documentation of the ping pong sketch about this?


  • Mod

    I'll take a look



  • @gohan thanks!


  • Mod

    Actually it is explained in this page how the mysensors network works, but I'll see how to add a line in the example sketch



  • @gohan thanks for the feedback. According to that page it seems you not only need a gateway but also a controller. This explains why my nodes don't get a node id automatically.


  • Mod

    The controller is needed for auto ID, but it can also be used myscontroller. It is also written in different places that manual id should be set also in case of problems.



  • @gohan indeed you're right. What did you mean with "myscontroller"?

    Setting the node id manually for the ping pong sketch makes them communicate to the Gateway:

    #define MY_NODE_ID 201
    

    Would auto ID work with the ESP MQTT Gateway and OpenHab controller?

    I have an MQTT server up and running and OpenHab is installed with the following configuration in /etc/openhab2/services/mqtt.cfg:

    broker.url=tcp://127.0.0.1:1883
    broker.clientId=OpenHab
    broker.retain=true
    broker.async=false
    

    Yet I still get !TSM:FPAR:NO REPLY


  • Mod

    https://forum.mysensors.org/topic/838/windows-gui-controller-for-mysensors

    I'd start from the ethernet gateway and work it out from there, myscontroller works with ethernet gateway. In openhab I don't know how to enable auto id, but there must be something in documentation. To be honest assigning manually ID has to be done only once because it is saved in eeprom and read at every boot, so I don't see it so mandatory to have the controller handling it.



  • @gohan, do you mean http://www.mycontroller.org? I can't find any project page with downloads on the link you provided. There is a download link to a zip file somewhere in the comments but impossible to say if that is still up to date as it dates from 2015.


  • Mod

    yes, it's the zip file. It is a windows app. Mycontroller it is actually a controller like Domoticz or Openhab. I know it is a little old, but it works.



  • @gohan, I switched over to mycontroller (from OpenHab) and I'm using Arduino's nodes and I'm still getting errors not finding the parent.

    I'm using the Mock sketch and tested with setting the ID manually but no luck.

    0 MCO:BGN:INIT NODE,CP=RRNNA--,VER=2.1.1
    4 TSM:INIT
    4 TSF:WUR:MS=0
    108 TSM:INIT:TSP OK
    110 TSM:INIT:STATID=99
    112 TSF:SID:OK,ID=99
    114 TSM:FPAR
    3241 TSF:MSG:SEND,99-99-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    5249 !TSM:FPAR:NO REPLY
    5251 TSM:FPAR
    8378 TSF:MSG:SEND,99-99-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    10385 !TSM:FPAR:NO REPLY
    10387 TSM:FPAR
    13514 TSF:MSG:SEND,99-99-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    15521 !TSM:FPAR:NO REPLY
    15523 TSM:FPAR
    

    Edit: adding a 4.7 capacitor didn't change this. Neither did downgrading to 2.0.

    Starting sensor (RRNNA-, 2.0.0)
    TSM:INIT
    TSM:RADIO:OK
    TSP:ASSIGNID:OK (ID=254)
    TSM:FPAR
    TSP:MSG:SEND 254-254-255-255 s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=bc:
    TSM:FPAR
    TSP:MSG:SEND 254-254-255-255 s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=bc:
    TSM:FPAR
    TSP:MSG:SEND 254-254-255-255 s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=bc:
    TSM:FPAR
    TSP:MSG:SEND 254-254-255-255 s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=bc:
    !TSM:FPAR:FAIL
    !TSM:FAILURE
    TSM:PDT
    TSM:INIT
    TSM:RADIO:OK
    TSP:ASSIGNID:OK (ID=254)
    TSM:FPAR
    TSP:MSG:SEND 254-254-255-255 s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=bc:
    TSM:FPAR
    TSP:MSG:SEND 254-254-255-255 s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=bc:
    TSM:FPAR
    TSP:MSG:SEND 254-254-255-255 s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=bc:
    TSM:FPAR
    TSP:MSG:SEND 254-254-255-255 s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=bc:
    !TSM:FPAR:FAIL
    !TSM:FAILURE
    TSM:PDT
    TSM:INIT
    TSM:RADIO:OK
    TSP:ASSIGNID:OK (ID=254)
    TSM:FPAR
    TSP:MSG:SEND 254-254-255-255 s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=bc:
    TSM:FPAR
    TSP:MSG:SEND 254-254-255-255 s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=bc:
    TSM:FPAR
    TSP:MSG:SEND 254-254-255-255 s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=bc:
    

    Any idea?


  • Mod

    On the gateway do you see any message received? Can you post the gateway log when nodes are registering?


Log in to reply
 

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.