OpenHab don't want to reconnect after Gateway restart



  • Hi, I have OpenHabian installed on RPi3 and I have MySensors ethernet gateway configured on arduino uno and W5100 shield and Rs485 sensors network. (I have some problems with RS485 communication but I mentioned that in other thread.) The issue is that when I reset gateway or when I disconnect ethernet cable for a while I need to reboot my openhab or restart openhab service because openhab won't reconnect with gateway. All of configured things are marked as ONLINE but i can't switch any relays from OpenHab. Maybe you have some ideas what I'm doing wrong ?
    P.S. I'm configured my Things and Items with autodiscover, not by editing some config files.


  • Mod

    I don't know much Openhab, but if you leave it alone for several hours it would not reconnect anyway?



  • In PaperUI, goto Configuration/Things/MySensors Ethernet Gateway. Set Disable Network Sanity Check to On (the label is named backwards). This sends a status check at your defined interval. This will reconnect your gw if it fails x times. (See other config params on that page)


Log in to reply
 

533
Online

6.9k
Users

7.8k
Topics

82.9k
Posts

Suggested Topics

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.