req node id node not found



  • It all started when I was debugging reason for a Dallas sensor (in Nano node) not getting values (other attached sensors like DHT work ok). I checked the wires several times thoroughly and then I tried with another Dallas, but that did not help then I tried with another PIN and still no success. So I replaced the entire Nano and still the Dallas does not work and in addition now the serial monitor just keeps repeating:

      req node id
      send: 255-255-0-0 s=255,c=3,t=3,pt=0,l=0,st=ok:
    

    I removed the node ans sensors from Vera config but still the Vera plugin does not find the sensors presented during inclusion.

    The node has capacitor for RF, I also cleared the EEPROM, and finally I now upgraded ide to 1.6 (used to be 1.05)
    Lib version 1.4.1. No Luck.

    Please help..



  • Just to reply that I found the bug: ground wire broken, but not consistently so sometimes it got contact (when I measured it) and then not.

    This brings me to think is there any way on the Arduino to detect if something is not connected as it supposed to be? How could I make such extra self checking of the wires? Double wiring? ;-)


Log in to reply
 

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.