Actioning switch is far from instant



  • Hi all,

    I have a couple arduino relays which I am using for my lights in my home. They work really well, but if they haven't been used for a while, they won't respond until I try them a couple times. It is like they go to sleep and need a couple messages sent to them before they actually work.

    Is that possible? I am using the Relay with Button Actuator pretty much as it is set up in the example. To me it doesn't look like it sleeps, as they are also repeaters. Am I right?

    Some help as to what the problem might be would be great 🙂



  • OK, tried turning on my lights using Vera and one worked pretty quickly, as in the second try, but the other one took about 15 tries.

    None of my sensors or the Ethernet Gateway are using a capacitor across the power input so I might give that a go. It just seems weird because I haven't required these before.



  • I've noticed that almost all of my repeater nodes are falling asleep. Only one is staying awake all the time. I am almost certain that all of my sensors were programmed the same way ensuring that they all stayed awake, because they are all mains powered.

    Could this be the issue? The sketch that is staying awake has this : gw.begin(NULL, AUTO, true);

    The ones sleeping say this : gw.begin(incomingMessage, AUTO, true);

    If that isn't the issue, is there some way in Vera that I can change a configuration to stay awake, or do I have to change ands upload new sketches again?


  • Admin

    @Dean

    The repeater nodes won't sleep unless you explicitly call gw.sleep().

    It is important that you call gw.process() in your loop section all the time. This call will relay messages between the child nodes and parent.



  • @hek can you have a look at the RepeaterNode sketch just to make sure it's correct, because I have one of them running as it is in the example and it appears to be sleeping; according to the dashboard it hasn't updated for 8 hours...


  • Admin

    Does the repeater send any sensor data itself? The dashboard "last update" only reflect data coming from the repeater.



  • @hek said:

    Does the repeater send any sensor data itself? The dashboard "last update" only reflect data coming from the repeater.

    No, all it is is a repeater. The only node that could send its signal through it is my doorbell which won't send anything until the doorbell is pressed, so I guess that all makes sense.

    I only have one sensor that is communicating all the time, which is my garage door switch which also sends temp values. The funny thing is that it is this switch that is the most reliable and ALWAYS works the instant I ask it to. the relay switches that I have turning operating some lights, that is the only thing I have them doing and there are times that I am having to repeatedly press there button on the dashboard to finally get the relay to work.


 

248
Online

8.7k
Users

9.5k
Topics

99.5k
Posts