Serial Monitor: Reversed question marks when on battery



  • Hi,

    I am creating my first sensor using a easypcb. It has two reed switches, one on D3 and the other on D8 (via an IRS).

    When I power the sensor from an USB port the output in the serial monitor looks fine, but when I power it via battery (2 AA rechargables, 2.6v in total) the output contains reversed question marks:

    12:45:04.443 ->  __  __       ____
    12:45:04.443 -> |  \/  |_   _/ ___|  ___ _ __  ___  ___  _ __ ___
    12:45:04.443 -> | |\/| | | | \__⸮ \ / _ \ `_ \/ __|/ _ \| `__/ __|
    12:45:04.443 -> | |  | | |_| |___| |  __/ | | \__ \  _  | |  \__ \
    12:45:04.443 -> |_|  |_|\__, |____/ \___|_| |_|___/\___/|_|  |___/
    12:45:04.476 ->         |___/                      2.3.2
    12:45:04.476 -> 
    12:45:04.476 -> 16 MCO:BGN:INIT NODE,CP=RPNNA---,FQ=8,RE⸮=255,VER=2.3.2
    12:45:04.476 -> 28 T⸮M:INIT
    12:45:04.476 -> 28 TSF:WUR:MS=0
    12:45:04.476 -> 32 TSM:INIT:TSP OK
    12:45:04.476 -> 34 TS⸮:INI⸮:ST⸮TID=1
    12:45:04.476 -> 36 TSF:SID:OK,ID=1
    12:45:04.476 -> 38 TSM:FPAR
    12:45:04.476 -> 43 ?TSF:MSG:SEND,1-1-255-255,s=255,⸮=3,t=7,pt=0,l=0,⸮g=0,⸮t=0,st=OK:
    12:45:06.499 -> 2052 !TSM:FPAR:NO REPLY
    

    This has been soldered to the PCB:

    • Arduino Pro Mini 3v
      RFM69HW
      Antenna
      //Battery Measurement
      1M Ohm
      470k Ohm
      1uF Capacitor
      //Booster
      Step up Booster(to 3v)
      1uF Capacitor

    Does that mean the booster is broken? Or did I use the wrong capacitor size? The easypcb says 0.1uF but I only had 1uF capacitors and I hoped it would work.



  • Well, it seems the problem might have been that the booster capacitor was touching the booster.

    Only problem left is a lot of NACKs, but I will create a different topic for that.

    /edit: There are less reversed question marks now, but there are still some.


  • Mod

    @kiesel said in Serial Monitor: Reversed question marks when on battery:

    /edit: There are less reversed question marks now, but there are still some.

    There should be no illegal characters at all. Looks like there's still a comm issue.



  • @Yveaux thanks, what could be the reason for them? And by xomms you mean Serial, not the rfm69, right?


  • Mod

    @kiesel said in Serial Monitor: Reversed question marks when on battery:

    @Yveaux thanks, what could be the reason for them?

    Baud rate could be slightly off, or crappy connections,or ....

    And by xomms you mean Serial, not the rfm69, right?

    Correct


Log in to reply
 

Suggested Topics

  • 3
  • 13
  • 22
  • 5
  • 14
  • 6
  • 12
  • 3

89
Online

9.5k
Users

10.1k
Topics

105.2k
Posts