Sensors won't connect to Gateway after adding Controller

  • Hello,

    I've posted this in the HA Forums too but hoping someone here might be able to help too

    I am stuck setting up MySensors and if anyone could help me I would be very grateful. I am completely new to Arduino's and the syntax (and I'm not a programmer anyway!) so I am aware I'm on a steep learning curve here!

    I have followed the tutorials to set up an Ethernet Gateway and a basic motion sensor. I then assigned static ID's to these as at this point I wasn't using a controller and I could get the two to talk successfully. I used the serial monitor to check both devices and when I wave my hand in front of the sensor I get the following:


    42401 MCO:SLP:WUP=1
    42403 TSF:TRI:TSB
    42414 TSF:MSG:SEND,1-1-0-0,s=1,c=1,t=16,pt=0,l=1,sg=0,ft=0,st=OK:1
    42420 MCO:SLP:MS=120000,SMS=0,I1=1,M1=1,I2=255,M2=255
    42425 TSF:TDI:TSL
    42427 MCO:SLP:WUP=1
    42429 TSF:TRI:TSB
    42439 TSF:MSG:SEND,1-1-0-0,s=1,c=1,t=16,pt=0,l=1,sg=0,ft=0,st=OK:0
    42445 MCO:SLP:MS=120000,SMS=0,I1=1,M1=1,I2=255,M2=255
    42450 TSF:TDI:TSL


    18749588 TSF:MSG:READ,1-1-0,s=1,c=1,t=16,pt=0,l=1,sg=0:1
    18752809 TSF:MSG:READ,1-1-0,s=1,c=1,t=16,pt=0,l=1,sg=0:0

    If I've misinterpreted this then please let me know, but it appears to me that the 1 (motion) and 0 (reset) on both devices almost simultaneously would suggest that they are communicating.

    I also set up a repeater and had communication between these, and could even pass the sensor data through it (we have thick walls so I took the sensor out of range and put the repeater in the middle).

    At this point I was thinking, this is all pretty easy, just need to hook it up to HA and I'll be away! However, I cannot get it to work. My understanding is that the controller - HA in this case - hands out the ID's to the nodes and therefore I don't want to define these in the sketch. I believe I am also right in saying that the gateway always has an ID of 0.

    I added the following to my HA configuration.yaml

        - device: ''
      version: '2.3.2'

    I restarted HA, and it appeared to be communicating as I was getting the following in the serial monitor for the gateway:

    19548847 GWT:RFC:MSG=0;255;3;0;2;
    19548853 GWT:RFC:MSG=255;255;3;0;20;
    19548859 ?TSF:MSG:SEND,0-0-255-255,s=255,c=3,t=20,pt=1,l=1,sg=0,ft=0,st=OK:0
    19558932 GWT:RFC:MSG=0;255;3;0;2;
    19569021 GWT:RFC:MSG=0;255;3;0;2;
    19579111 GWT:RFC:MSG=0;255;3;0;2;
    19589199 GWT:RFC:MSG=0;255;3;0;2;
    19600464 GWT:RFC:MSG=0;255;3;0;2;
    19610560 GWT:RFC:MSG=0;255;3;0;2;
    19620649 GWT:RFC:MSG=0;255;3;0;2;
    19630739 GWT:RFC:MSG=0;255;3;0;2;
    19640828 GWT:RFC:MSG=0;255;3;0;2;
    19650917 GWT:RFC:MSG=0;255;3;0;2;
    19661007 GWT:RFC:MSG=0;255;3;0;2;
    19671098 GWT:RFC:MSG=0;255;3;0;2;
    19681187 GWT:RFC:MSG=0;255;3;0;2;
    19691277 GWT:RFC:MSG=0;255;3;0;2;
    19701367 GWT:RFC:MSG=0;255;3;0;2;
    19711457 GWT:RFC:MSG=0;255;3;0;2;
    19721546 GWT:RFC:MSG=0;255;3;0;2;
    19731637 GWT:RFC:MSG=0;255;3;0;2;
    19741726 GWT:RFC:MSG=0;255;3;0;2;

    Again, please correct me if I'm wrong but I believe this is telling me that the gateway and HA are communicating?

    The issue, and where I am currently stuck is that my sensor won't connect to the gateway. I have cleared the EEPROM from the board (using the MySensors clear eeprom sketch) and removed the ID from the sketch before uploading it again. I've done the same on the repeater and switched the boards for brand new ones but get the same issue each time.

     __  __       ____
    |  \/  |_   _/ ___|  ___ _ __  ___  ___  _ __ ___
    | |\/| | | | \___ \ / _ \ `_ \/ __|/ _ \| `__/ __|
    | |  | | |_| |___| |  __/ | | \__ \  _  | |  \__ \
    |_|  |_|\__, |____/ \___|_| |_|___/\___/|_|  |___/
            |___/                      2.3.2
    16 MCO:BGN:INIT NODE,CP=RNNNA---,FQ=16,REL=255,VER=2.3.2
    26 TSM:INIT
    28 TSF:WUR:MS=0
    36 TSM:FPAR
    38 ?TSF:MSG:SEND,255-255-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    2050 TSM:FPAR
    2052 ?TSF:MSG:SEND,255-255-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    4062 TSM:FPAR
    4064 ?TSF:MSG:SEND,255-255-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    6074 TSM:FPAR
    6076 ?TSF:MSG:SEND,255-255-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    8084 !TSM:FPAR:FAIL
    8085 TSM:FAIL:CNT=1
    8087 TSM:FAIL:DIS
    8089 TSF:TDI:TSL

    This just loops with the count incrementing by one each time. There is nothing on the gateway serial monitor beyond the messages in the log above. It doesn't even seem to be aware anything is trying to communicate with it.

    I have looked through the Debug info on the MySensors website and I think I have an understanding of what is happening based on the values for s,c,t. (I'm assuming s=255 is like a broadcast message rather than a defined value for the sensor). The line TSF:MSG:SEND,255-255-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK is the sensor looking for the gateway and the next line !TSM:FPAR:NO REPLY is saying there is no response.

    I'm sure I have missed something blindingly obvious but no amount of reading or research has helped me, so I'd be very grateful if someone could point a newbie in the right direction!

    The sketch for Gateway is:

    // Enable debug prints to serial monitor
    #define MY_DEBUG
    // Enable and select radio type attached
    #define MY_RADIO_RF24
    //#define MY_RADIO_NRF5_ESB
    //#define MY_RADIO_RFM69
    //#define MY_RADIO_RFM95
    // Enable gateway ethernet module type
    #define MY_GATEWAY_W5100
    // W5100 Ethernet module SPI enable (optional if using a shield/module that manages SPI_EN signal)
    //#define MY_W5100_SPI_EN 4
    // Enable Soft SPI for NRF radio (note different radio wiring is required)
    // The W5100 ethernet module seems to have a hard time co-operate with
    // radio on the same spi bus.
    #if !defined(MY_W5100_SPI_EN) && !defined(ARDUINO_ARCH_SAMD)
    #define MY_SOFTSPI
    #define MY_SOFT_SPI_SCK_PIN 14
    #define MY_SOFT_SPI_MISO_PIN 16
    #define MY_SOFT_SPI_MOSI_PIN 15
    // When W5100 is connected we have to move CE/CSN pins for NRF radio
    #ifndef MY_RF24_CE_PIN
    #define MY_RF24_CE_PIN 5
    #ifndef MY_RF24_CS_PIN
    #define MY_RF24_CS_PIN 6
    // Enable UDP communication
    //#define MY_USE_UDP  // If using UDP you need to set MY_CONTROLLER_IP_ADDRESS below
    // Enable MY_IP_ADDRESS here if you want a static ip address (no DHCP)
    #define MY_IP_ADDRESS 192,168,86,19
    // If using static ip you can define Gateway and Subnet address as well
    #define MY_IP_GATEWAY_ADDRESS 192,168,86,1
    #define MY_IP_SUBNET_ADDRESS 255,255,254,0
    // Renewal period if using DHCP
    //#define MY_IP_RENEWAL_INTERVAL 60000
    // The port to keep open on node server mode / or port to contact in client mode
    #define MY_PORT 5003
    // Controller ip address. Enables client mode (default is "server" mode).
    // Also enable this if MY_USE_UDP is used and you want sensor data sent somewhere.
    //#define MY_CONTROLLER_IP_ADDRESS 192, 168, 178, 254
    // The MAC address can be anything you want but should be unique on your network.
    // Newer boards have a MAC address printed on the underside of the PCB, which you can (optionally) use.
    // Note that most of the Arduino examples use  "DEAD BEEF FEED" for the MAC address.
    #define MY_MAC_ADDRESS 0xBE, 0x93, 0x51, 0x91, 0xF0, 0x22
    // Enable inclusion mode
    // Enable Inclusion mode button on gateway
    // Set inclusion mode duration (in seconds)
    // Digital pin used for inclusion mode button
    // Set blinking period
    // Flash leds on rx/tx/err
    // Uncomment to override default HW configurations
    //#define MY_DEFAULT_ERR_LED_PIN 7  // Error led pin
    //#define MY_DEFAULT_RX_LED_PIN  8  // Receive led pin
    //#define MY_DEFAULT_TX_LED_PIN  9  // Transmit led pin
    #if defined(MY_USE_UDP)
    #include <EthernetUdp.h>
    #include <Ethernet.h>
    #include <MySensors.h>
    void setup()
      // Setup locally attached sensors
    void presentation()
      // Present locally attached sensors here
    void loop()
      // Send locally attached sensors data here

    The sketch for the sensor is:

    // Enable debug prints
    #define MY_DEBUG
    // Enable and select radio type attached
    #define MY_RADIO_RF24
    //#define MY_RADIO_NRF5_ESB
    //#define MY_RADIO_RFM69
    //#define MY_RADIO_RFM95
    //define ID
    //#define MY_NODE_ID 1
    #include <MySensors.h>
    uint32_t SLEEP_TIME = 120000; // Sleep time between reports (in milliseconds)
    #define DIGITAL_INPUT_SENSOR 3   // The digital input you attached your motion sensor.  (Only 2 and 3 generates interrupt!)
    #define CHILD_ID 1   // Id of the sensor child
    // Initialize motion message
    MyMessage msg(CHILD_ID, V_TRIPPED);
    void setup()
        pinMode(DIGITAL_INPUT_SENSOR, INPUT);      // sets the motion sensor digital pin as input
    void presentation()
        // Send the sketch version information to the gateway and Controller
        sendSketchInfo("Motion Sensor", "1.0");
        // Register all sensors to gw (they will be created as child devices)
        present(CHILD_ID, S_MOTION);
    void loop()
        // Read digital motion value
        bool tripped = digitalRead(DIGITAL_INPUT_SENSOR) == HIGH;
        send(msg.set(tripped?"1":"0"));  // Send tripped value to gw
        // Sleep until interrupt comes in on motion sensor. Send update every two minute.
        sleep(digitalPinToInterrupt(DIGITAL_INPUT_SENSOR), CHANGE, SLEEP_TIME);

  • Hello
    If your using an nrf24 radio module try changing the nrf24l01 the FPAR is telling you it is not talking to the remotes I have had this issue with several nrf modules and changing them has corrected this issue

  • @mntlvr thank you for taking the time to read my post and to respond. I have tried swapping out the nrf24l01 board on both the gateway and the sensor with brand new ones and still have the same issue. What I can't understand is why it works with no controller and assigned static ID's, but then not when a controller is connected.

  • Hi @Steve-Parsons

    If your sensor node is unable to reach your gateway or any other parent node - which seems to be the case - your issue is unlikely to be related to the controller.

    My understanding is that the controller - HA in this case - hands out the ID's to the nodes and therefore I don't want to define these in the sketch. I believe I am also right in saying that the gateway always has an ID of 0.

    This is correct. Your nodes will request a unique ID from your controller if you don't assign them manually. If you prefer though, you can still statically assign node IDs. I prefer static IDs because it allows you to organize your network in a way that makes sense for you, like keeping all your repeater IDs single digit, or all temperature sensors in a range of 50 - 69, etc.

    What I can't understand is why it works with no controller and assigned static ID's, but then not when a controller is connected.

    Besides adding a controler to your setup, this seems to be one of the changes you made at the same time. What happens if you assign a static ID to your sensor node now (in your current setup with a controller)? As I said, your are not forced to use dynamically assigned IDs when using a controller.

    You could also try to define a static route from your sensor node to the gateway.
    #define MY_PARENT_NODE_ID 0 (0 should be your gateway)

    Besides that - which Arduinos do you use? How do you power the NRF24 modules (on both devices)? Are they provided with a stable 3.3V power supply? Did you try adding capacitors? Did you try moving your sensor node closer to the gateway? If your sensor is unable to reach any parent, this could very well be a general power / hardware or range issue.

    I added the following to my HA configuration.yaml

    	version: '2.3.2'

    This doesn't cause your current issue, but you should consider changing it to 2.3. The MySensors integration provided by pymysensors will otherwise fall back to the very old 1.4 serial protocol version, which might bite you in the future, if you are going to implement sensor types which are only supported with newer versions.

  • Thank you so much @BearWithBeard for this, it's really helpful.

    I decided to try using a serial gateway and have had more success. The sensor is connecting and getting an ID from the controller. Although the gateway drops out when i reboot my Pi and I have to unplug, reconnect and restart HA! Not the end of the world, and certainly better than no connection, but a bit annoying.

    I'd like to use an Ethernet gateway if I can so I'll try your suggestion of static ID's and see what happens. I like the idea of organising things as you suggest, so may well end up doing that anyway. I'll try the static route to the gateway too if still no luck - very useful info.

    I'm using Uno's at the minute while I test/set it up and am powering them via USB from a laptop (sensor) and an NUC (Gateway). Although my serial gateway is connected via USB to the Pi running HA. No capacitors at this point either. They are within a few metres of each other so don't think range is the problem.

    Will amend my HA Config as you suggest, again useful info.

    Only other thing I didn't mention is I'm using a 5100 shield breakout board on the gateway rather than the board in the tutorial, not sure if this affects power or is relevant!

    Again, thank you, really appreciate your advice! I was completely stuck so really nice to have options now.

Log in to reply

Suggested Topics