Node registration problem

  • I have a node that's sending a find parent request to the gw. The gw receives it and sends back a reply. The node never receives the reply and says parent not found. Any suggestions or help on how to fix/troubleshoot would be appreciated.

    Node log:

    18098 TSM:FAIL:RE-INIT
    18100 TSM:INIT
    18106 TSM:INIT:TSP OK
    18108 TSM:INIT:STATID=1
    18111 TSF:SID:OK,ID=1
    18113 TSM:FPAR
    18117 ?TSF:MSG:SEND,1-1-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    20124 !TSM:FPAR:NO REPLY
    20126 TSM:FPAR
    20130 ?TSF:MSG:SEND,1-1-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    22138 !TSM:FPAR:NO REPLY
    22140 TSM:FPAR
    22145 ?TSF:MSG:SEND,1-1-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    24153 !TSM:FPAR:NO REPLY
    24155 TSM:FPAR
    24159 ?TSF:MSG:SEND,1-1-255-255,s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=OK:
    26166 !TSM:FPAR:FAIL
    26167 TSM:FAIL:CNT=2

    gw log:

    8974 TSF:MSG:READ,1-1-255,s=255,c=3,t=7,pt=0,l=0,sg=0:
    8981 TSF:MSG:BC
    8984 TSF:MSG:FPAR REQ,ID=1
    8993 TSF:MSG:GWL OK
    12351 !TSF:MSG:SEND,0-0-1-1,s=255,c=3,t=8,pt=1,l=1,sg=0,ft=0,st=NACK:0
    13023 TSF:MSG:READ,1-1-255,s=255,c=3,t=7,pt=0,l=0,sg=0:

  • Mod

    @mhkid what radio are you using? How do the radios get their power?
    What capacitors?

    If you haven't seen it already, has a troubleshooting guide.

  • @mfalkvidd nrf24, 4.7uf, and it's powered at 3.3v, I put a meter on it. I'm using the MySensors board by sunberg.

    I'll take a look at the guide, thanks.

  • Mod

    @mhkid the sundberg board for the gateway as well?

  • @mfalkvidd no just the sensor

  • Mod

    @mhkid for the gateway:
    How does the radio get its power?
    What capacitors?
    Are you using a normal nrf24 or the variant with PA?

  • @mfalkvidd Radio is getting 3.3v volts powered from a usb plug in. The capacitor on the radio is a 4.7uf. Here is a picture if this helps.!IMG_20200608_111955.jpg

  • Mod

    @mhkid that looks like the easypcb by sundberg. Is it? I thought you said you used something else for the gateway?

  • @mfalkvidd It is. That's not a gw it's a sensor node. My problem isn't with the gw it's with the node. The gw receives the find parent message and responds. The node fails and says there is no response (see my original post)

  • Mod

    @mhkid the most likely reason that the node doesn't see the gateway's response is that the power supply to the radio on the gateway is insufficient.

  • @mhkid If the suggestion by @mfalkvidd doesn't resolve the problem you might look at moving both Gateway and Node marginally to see if it it is some effect.
    Clearly the Gateway can "hear" the Node but not the reverse, and as most transceivers are matched between power out and receive sensitivity, polarisation or influence from nearby objects may be in play. There can be some strange effects at 2.4 GHz, particularly where "shrunk" antennae are used.

  • @zboblamont Thank you. I will try and report back.

  • @mfalkvidd It's powered from an outlet and it reads 3.3v when I put my meter on it, I don't believe this is the problem.

  • @zboblamont Moved things around and that didn't work. I soldered up a new newbie pcb thinking maybe it was my solder job and tried that and I get the same result. I've swapped nrf24 radios out and still the same result.

  • I think I found the problem. I've been using an ESP32 for the gateway and hadn't had problems. For whatever reason I added this new node and I had the problems as described. I decided to try swapping the ESP32 out with an ESP8266 and things started working. I guess I'll stay with ESP8266 on the gateway.

  • That sounds more like lucky coincidence to me than actually pinpointing the problem.

    Glad it's back to working for you though.

  • @TRS-80 I have no idea what you're talking about. I changed out pieces one at a time until I found the problem. That's not called luck that's called troubleshooting. Please provide constructive comments not sarcastic non-sense.

  • I just had to read through the thread again to make sure I was not mixing you up with someone else. But no that's not it, and yes this is the right thread I am thinking of.

    It sounded like radio propagation issues to me. I think the gateway thing was a coincidence. I can be wrong of course, maybe it was the gateway after all (or something else).

    I wasn't being sarcastic, I really do hope it keeps working for you. I guess we will see...

  • @TRS-80 My point was you didn't add anything constructive to thread. You could have said hey you might have a radio propagation issue and here's how you could troubleshoot it. That's a helpful comment. What's not helpful is sitting on the sidelines until the problem was solved and then making a comment like: You didn't solve it you just got lucky. I did pinpoint the problem to be the gateway hardware. Could I have spent hours to figure out exactly what it was in the ESP32 that was failing? Possibly, but I have parts on hand, they are cheap, and I just swapped it out and it eliminated the issue. So my approach wasn't lucky it was measured and methodical. I tried the suggestions given in the thread then I replaced one radio and tested with a known working radio. I did the same with the other radio and so on. No coincidence there that I was able to isolate where the issue was. And your comment was not based on any evidence it was just a feeling you had and you offered no solutions.

    I'm not trying to cause an issue here and I'm trying to be as polite as possible to what I felt was a very 'troll like' comment. Be helpful and supportive in your replies. I came asking for help and everyone else on the thread gave some things to try and added value to the conversation. Be the same way as I'm sure you have value to add.

  • Well I'm sorry you took it that way. By the time I happened along into the thread, you had already pronounced your diagnosis. I offered my thoughts into the thread, this way if your first diagnosis turns out not to be correct, you have other ideas to try. These issues can be complicated, and (I know from experience) some times what we think at first ends up not actually being the problem.

    As I said, I could be wrong anyway.

    @mhkid said in Node registration problem:

    And your comment was not based on any evidence it was just a feeling you had

    Each of us are chock full of thoughts, memories, things we learned which we are no longer consciously aware of. The sum total of all this "sub-conscious" thoughts and memories can manifest itself as a "gut feeling" but perhaps you are unaware of this.

    At any rate, it is not as if you need to be a "radio whisperer" or that this is some obscure subset of problems. Rather I would submit to you that these are the most common type of problems.

    @mhkid said in Node registration problem:

    you offered no solutions

    In fact I said "It sounded like radio propagation issues to me."

    No need for me to go into any further detail, if exchanging the gateway has solved the problem. However if you continue to experience problems, please share new information and we can continue from there.

Log in to reply

Suggested Topics