Problems with powermeter pulse sensor



  • Hello
    I have installed a 3 phase meter for my waterheater.
    It is on 3 kw and is also equipped with a ledpulse.
    I have made a sensor and flashed it with the standard sketch. I have only changed the pulse/whr to 800 as that is what my meter says.

    But I get this very strange watt values. I get in the serial log printed watt: around 42000
    the meter says 2994 +- which is also correct because its a 3000 w heater.
    I did a manual test and clocked 20 pulses looking at the meter and divided by 20.

    then i got 1,465 ms which calculates to around 3090 watt so the optical out on the sensor is working good. I have also tried putting a 10k resistor between ground and D3 pin without success.

    The arduino is a arduino nano clone bought on ebay. I have also tried with another one but with same problem (arduino nano clone also). Could it be that the timing is corrupt on theese clones? Or do you have any other suggestions?



  • hmm think i solved the problem. I tried with an arduino uno instead and now the sketch works fine. Very strange 😞


Log in to reply
 

Suggested Topics

95
Online

10.6k
Users

10.8k
Topics

111.0k
Posts