Ethernet Shield 2

  • I'm running an Arduino UNO with Ethernet shield 2 using Wiznet W5500. I'm trying to setup a connection with my Vera Lite. It would suggest that the Vera plugin installed correctly with Plugin Version 1.4 but No indication of Lib version yet. I presume that this field will only be filled in once a successfull connection has been established with the ethernet gateway. The plugin currently shows: "Cannot send command-communication error"

    For the ethernet gateway, I used the mysensors example. In edit mode I changed the IP address and MAC leaving port 5003. (matched with Vera plugin Advanced tab). If I use "Run on Arduino", I get "There was an error compiling". If I cut and paste EthernetGateway.ino into the IDE (1.7.6), it compiles without any error. However, despite the "apparent" successfull compilation, the VERA plugin continues to display "Cannot send command-communication error". I have also tried to change #include <Ethernet.h> to #include <Ethernet2.h>, though still no connection.
    Is the sketch compatible with the Arduino shield 2 with just hardwired Dallas Temperature sensors? If so, any suggestions where to look for remedying the current lack of comm with VERA?
    Appreciate any feedback.

  • Have you tried restarting Vera once the gateway is up and running, and then doing an include?

  • @akboer Thanks for attending to my issue which is highly appreciated. Yes indeed, I compiled with ether.h, reboot vera. Likewise, I changed to ethernet2.h and reboot the Vera too. In both cases. the end result on the VERA lite Plugin is "Cannot send command-communication error".
    Am I correct in using this sketch in a ethernet shield 2 with hardwired dallas temp devices? I have no wireless ethernet links installed.
    Any further guidance would be appreciated.

  • I have a Uno and the same shield as you, although I connect to a Vera Edge. I'm using the V1.5 library on the Uno and a Nano for a sensor node.

    Aside from the changing parameter for soft SPI, I compiled for both gateway and node with no trouble. On Vera I used the plugin from the UI7 branch of GitHub (are you using UI7 ?)

    This is a very common setup, so should work OK... you HAVE configured your gateway IP address in the Vera plugin attributes?

  • @akbooer What refers to the V1.5 library? Do you mean the EthernetGateway library? I'm using the from GitHub. What should I do with soft SPI since I'm not using a radio. If this need to be changed, does this involve editing Myconfig.h? I'm still running UI5 on my Vera Lite. The VERA Lite Arduino Plugin indeed is holding the same IP address and port number as referred to in the EthernetGateway.ino.

  • Yes, the Ethernet gateway library.

    If you're not using a radio, how are you connecting to any sensor nodes?

  • I have only hardwired dallas temp devices connected to pin 2.

  • I didn't think the gateway node supported attached sensors?

  • I can't imagine I'm the only one trying to interface an Arduino UNO with Ethernet Shield 2 (Wiznet W5500) and hardwired sensors on pin 2 with Vera Lite UI5. I'm still lost with VERA lite Plugin reporting "Cannot send command-communication error". Any guidance please!

  • Does this thread shed any light on your issue?

  • @akbooer Thanks for yr quick support suggestion. However, none is applicable since the ethernet shield 2 is working fine. I even connect to the Vera using HTTP GET request to get data into the variable container plug in. The problem remains that I can't fine a proper sketch to interface the ethernet shield board with the Arduino VERA plug in. THis would have many advantages for me by virtue of having individual device nr's.

Log in to reply

Suggested Topics

  • 3
  • 477
  • 30
  • 3
  • 18
  • 47
  • 7
  • 6