Problem with adding new sensor



  • Hi Everyone,

    Can someone help explain why, when adding new sensors the following happens:

    1.gif

    In this example i just added a new relay sensor (Arduino light 1:3).

    If I then manually delete "Arduino Node 1" everything starts working:

    2.gif

    Thanks,

    Joseph


  • Hero Member

    Restarting Vera and refreshing your browser would probably give the same result as deleting the device..



  • I've tried restarting the vera, my USB gateway and the sensor without luck. In fact if i don't manually delete the "Node 1" sensor my other sensors stop working.

    Just curious why this is happening. Other than this bug i can't believe how easy everything was to setup !


  • Contest Winner

    @jribera

    try to flash the EEPROM

    sometimes you need to reset the radio ID, in my experience

    /*
    *
    * This sketch clears radioId, relayId and routing info in EEPROM 
    *
    */
    
    #include <SPI.h>
    #include <EEPROM.h>  
    
    void setup()  
    { 
      for (int i=0;i<512;i++) {
        EEPROM.write(i, 0xff);
      }
    }
    
    void loop()      
    { 
      // Nothing to do here...
    }


  • @BulldogLowell

    Thanks i will try this over the weekend.

    I actually found a post from Hek on http://forum.micasaverde.com/index.php/topic,16170.msg158102.html#msg158102

    Which says "The -node (or -relay) device is automatically created for every Arduino in your sensor network. "

    So its interesting that i'm deleting this yet everything is still working :)



  • Manged to fix this buy re-installing all the Vera Plugins. Thanks for everyone's suggestions.


Log in to reply
 

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.