Big Wish - a working system including up-to-date Reference

  • A real great project here, i follow since long, built many sensors, even ordered own PCBs.
    Some of them worked now for over a year...

    But now, as new projects came in mind, i needed more sensors, and more gateways, so i tried with the wifi gateway
    That´s where my problems started - see my other topics here

    I saw now, your work made a lot of progres, OTA-Update, message signing,....,

    But now old and new sketches are not compatible any more, many compile errors

    I have to confess, for a beginner, it´s really hard to follow, for most of the problems the experts here say "did you try the developer version? " - the developer version is, as the name says, developer level, no waranty it works...

    So please, could you update the build page ? Or maybe if you prefer take some things like the wifi gateway out till it´s really working ?
    Please understand that some people find this page and think, wow, that´s exactly what i need, i´ll order the parts and build it, they want to spend time in automate the house, not in debugging faults.

    Please don´t understand me wrong, i know all this is done privately just for fun, but imagine a beginner seeing the nice pages in the build-area, thinking, wow, really easy, but then it starts to get really time consuming

  • Admin

    Sorry to hear that you are experiencing problems.

    The core team is working on releasing 2.0.0 and we will update the main site (including the examples) when it's been released. It still needs testing though, that's why we urge people to run it.

    All the examples in 2.0 has been updated to work with the new sketch structure. So if you run it your local IDE it shouldn't be much troubles.

    The ESP8266 still suffers from stability problems, most seems to stem from powering issues and things out of our controls (like bugs in the ESP core). But the latter should get better with time as the the ESP-Arduino seems to get much attention by a great community and the tremendous work done by Igrr.

    As for documentation and updates of the main site, it suffers, as my time is limited and I've been prioritising other MySensors related things like getting the site up and building a sensor testing ground for the community [not released yet].
    But when 2.0 has been released, the main site surely needs some attention.

    And Yes, I've got a 8h full time work and a family like all the other core team members.

  • Hello Hek,

    thanks a lot for your answer, i hopefully wasn´t to harsh ?

    When do you expect 2.0.0 to come out ? Maybe it makes more sense for me to wait and put the project aside till then?

    I didn´t want to change to the developer version, no need for the extra features, all i wanted was one / some wifi gateways because i have some positions in the house i couldn´t cover with wired gateways - and especially for the wifi gateway many people here said go with the dev version, it solves a lot of problems.
    That´s where the problems started then, the mixture between old and new doesn´t work well in the arduino IDE.
    Also some older examples here in the forum, i can´t use because i get compiling errors with the new developer version

    I try to investigate further - so are the 1.5 version and the 2.0 dev compatible regarding already existing sensors ?
    ( I have to confess Arduino IDE makes it even worse, even when installing the portable version, it uses files from wherever...)

    As you are speaking about stabilty problems regarding the Wifi-Gateway - i was thinking i made some faults, tried almost everything, but as i have many of the ESP8266 running without any problems with ESP-Easy, i couldn´t make that much faults regarding power supply and such things
    (Easy thing to try , dev. Wifi Gateway, just connected to a putty sesion, dev relais sketch, as soon as powering the relais node on, it will crash)

    So would you or others here suggest to use the wifi client at the moment, or better wait ?

    At the moment, at germen FHEM Forum, some ordered about 100 PCBs to build Wifi Gateways, at the moment they are sending the first out, sounds stupid but i´d be lucky if they all work and i know a have to find the fault in my doing

  • Admin

    Mostly a structural thing left before the release of 2.0 (so the library can be downloaded directly from the Arduino Library Manager).
    So I suggest you try to use it.

    1.5 and 2.0 sensors should be compatible over the air.

    If the relays are connected directly to gateway it sounds like a powering issue. Do you have the same problem if you try removing the relay and run the same command?

    If the relay is attached to some other node and the gateway crash when you try to turn it on over the air, it sounds like a bug.

  • Not really something for feature request, more trouble shooting...

    But the relay sensor was just an example, not connected to the gateway, node by itself.
    I don´t even have to switch the relay - just the Wifi Gateway running, connected to putty
    As soon as a sensor sends his startup message, Wifi Gateway crashes, no longer reachable

    I´d be really happy if someone could try it, maybe it´s still my fault:
    Power Up Wifi Gateway, then power up relay node ( both dev version) , i think it has something to do because relay node is also a repeater ?

  • Admin

    Ok, I just verified your setup on the latest dev branch.

    • Uploaded the relay sketch on a node (unmodified).
    • Flashed an esp with attached NRF-radio (static ip).
    > telnet 5003
    Connected to
    Escape character is '^]'.
    0;255;3;0;14;Gateway startup complete.

    And the same time on the gateway while powering up the relay node.

    0;255;3;0;9;Init complete, id=0, parent=0, distance=0
    pm open,type:2 0
    0;255;3;0;9;Client 0 connected
    0;255;3;0;9;read: 2-2-0 s=255,c=3,t=15,pt=0,l=2,sg=0:
    0;255;3;0;9;send: 0-0-2-2 s=255,c=3,t=15,pt=0,l=2,sg=0,st=ok:
    0;255;3;0;9;read: 2-2-0 s=255,c=0,t=18,pt=0,l=10,sg=0:2.0.0-beta
    0;255;3;0;9;read: 2-2-0 s=255,c=3,t=6,pt=1,l=1,sg=0:0
    0;255;3;0;9;read: 2-2-0 s=255,c=3,t=11,pt=0,l=5,sg=0:Relay
    0;255;3;0;9;read: 2-2-0 s=255,c=3,t=12,pt=0,l=3,sg=0:1.0
    0;255;3;0;9;read: 2-2-0 s=1,c=0,t=3,pt=0,l=0,sg=0:
    0;255;3;0;9;read: 4-4-0 s=255,c=2,t=0,pt=1,l=1,sg=0:75
    0;255;3;0;9;read: 4-4-0 s=1,c=3,t=8,pt=7,l=5,sg=0:23.5
    0;255;3;0;9;read: 4-4-0 s=2,c=1,t=1,pt=2,l=2,sg=0:40

    No crashes or nothing. It even picked up another sensebender module reporting temperature.

    The only difference I can see is that you use putty to connect.

  • Plugin Developer


    The second and third lines from the end of the last log don't make sense to me. Sensor 255 requests temperature, payload 75? Sensor 1 internal message parent response 23.5?

  • Admin

    @martinhjelmare said:

    The second and third lines from the end of the last log don't make sense to me. Sensor 255 requests temperature, payload 75? Sensor 1 internal message parent response 23.5?

    Yes, strange. I suspect it is some trace of my "production" serial gateway (on the same freq) that is doing hardware acks while the esp node is listening to all of this (and also acks the same message). Hmm.. I should probably have turned the serial gw off before the test to get a cleaner log.

  • Hello Hek,

    thanks a lot for all the effort trying to help me

    Thats what the relay node gives me when plugging in power:

    Starting sensor (RNNNA-, 2.0.0-beta)
    Radio init successful.
    send: 100-100-0-0 s=255,c=3,t=15,pt=0,l=2,sg=0,st=ok:
    send: 100-100-0-0 s=255,c=0,t=17,pt=0,l=10,sg=0,st=ok:2.0.0-beta
    send: 100-100-0-0 s=255,c=3,t=6,pt=1,l=1,sg=0,st=ok:0
    read: 0-0-100 s=255,c=3,t=6,pt=0,l=1,sg=0:M
    send: 100-100-0-0 s=255,c=3,t=11,pt=0,l=5,sg=0,st=ok:Relay
    send: 100-100-0-0 s=255,c=3,t=12,pt=0,l=3,sg=0,st=ok:1.0
    send: 100-100-0-0 s=1,c=0,t=3,pt=0,l=0,sg=0,st=ok:
    Init complete, id=100, parent=0, distance=1

    Thats what the Gateway logs, after that it´s unreachable

    0;255;3;0;14;Gateway startup complete.

    That´s the serial output of the gateway, 111 is another node:

    0;255;3;0;9;Radio init successful.
    state: 0 -> 2 (b0)
    .state: 2 -> 3 (0)
    state: 3 -> 5 (10)
    add 0
    aid 7
    pm open phy_2,type:2 0 0
    connected with Power-LAN, channel 6
    dhcp client start...
    0;255;3;0;9;Init complete, id=0, parent=0, distance=0
    0;255;3;0;9;read: 111-111-0 s=1,c=1,t=16,pt=0,l=1,sg=0:0
    0;255;3;0;9;read: 111-111-0 s=1,c=1,t=16,pt=0,l=1,sg=0:1
    0;255;3;0;9;read: 111-111-0 s=1,c=1,t=16,pt=0,l=1,sg=0:0
    0;255;3;0;9;read: 100-100-0 s=255,c=3,t=15,pt=0,l=2,sg=0:
    0;255;3;0;9;send: 0-0-100-100 s=255,c=3,t=15,pt=0,l=2,sg=0,st=fail:
    0;255;3;0;9;read: 100-100-0 s=255,c=0,t=17,pt=0,l=10,sg=0:2.0.0-beta
    0;255;3;0;9;read: 100-100-0 s=255,c=3,t=6,pt=1,l=1,sg=0:0
    0;255;3;0;9;read and forward: 0-0-100 s=255,c=3,t=6,pt=0,l=1,sg=0

    strange you don´t have this "read and forward" message ?

  • Admin

    Looks like the second fast consecutive send kills the gateway. What measures have you taken to ensure ESP/radio powering?

    What type of NRF radio are you using?

  • I tried many things regarding power supply, 47uF and 100nF both on the ESP and NRF, even feeded it with a good laboratory power supply (max 3A).
    I can´t imagine it´s a power problem, but could try tonight to even feed them with different power sources ?

    But i found a similar thread / same problem:

    But i don´t use any bootloader

  • So just to be totally sure and to help me and hopefully others, i did the following:

    I feeded ESP and NRF from different power supplys-result is still the same, ESP hangs, no response

    The Power supply of the ESP is the same as i use for many ESP-Easy-Projects, i even flashed ESP-Easy on these 2 boards i try to get the MySensors-Gateway running, no problems

    You asked which nRF i use - they are from china 🙂 different sellers, different looking, some with external antenna, all the same results

  • Admin

    I've tried to stress test again here but I still cannot reproduce the hangs.

    Are you using this gateway sketch:

    And this Relay sketch:

    Unmodified (except for WLAN SSID)?

  • The second one yes, but the first one, i´m not using a Ethernet Gateway, but a Wifi Gateway with the ESP8266

    that´s the one i use:
    nothing modified, even still with DHCP

    I also have a Ethernet Gateway, which is running since months, the problems started with the Wifi / ESP Gateway

    Could you maybe have a look at the link above ? In this thread, Yveaux asked you for some help, maybe tha´t the point the problem comes from ?

  • Admin

    Yes, I meant GatewayESP8266 😉

    I don't get the "read and forward" print at all. Even when sending out a command to the node (from telnet/nc).

    I guess you've updated library to the latest and ESP as well in Board Manager?

  • Yes, i erased and downloaded everything new 2 days ago

    Did you see the other forum post ?

    Really strange problem, i´d say i have a fake chip or something, but as it´s working with ESPEasy, i can´t imagine...

    In Board manager, i´m using 2.0, should i also go to the developer version ?

  • Admin

    Yes, really strange. Just wish I could reproduce. Make things much easier to debug!

    I'm using 2.1.0-rc2 of the esp.

  • Could maybe someone upload the compiled binary ? Just to check all possible faults ?
    The needed settings are:

    • With DHCP
    • SSID Power-LAN
    • key kr08151020

  • Hi @hek

    Thank you again for all the work you and the team do for the MySensors community - maybe we can help back? I read your post, and understand the family and full time job - it's two careers. Maybe if there was a community Wiki that we all could help maintain - this way when things change they are instantly updated?

    Just throwing it out there.

  • Hello Hek,

    i just saw in the german FHEM Forum, somebody has exactly the same Problems as me - but when switching back to the old / regular version, it works as expected, except the other problem with the long values.
    SO it musst be a software thing, nothing hardware related

    But as it is really strange you don´t get this problen, did any body else see it ?

  • Admin

    If you can reproduce this, It would be helpful if you could start adding debug prints in the library code to locate where it hangs to narrow down things.

  • Hello Hek,

    thank you so much to try to help me - i found the problem now and i guess it´s the same problem many others have here:
    On almost all ESP12 GPIO 4 and 5 are labeled wrong
    I didn´t use a NodeMCU, but one of the other available boards

    As the CE pin is then connected to the wrong GPIO, it seems to work, Radio init ok, but as soon as the gateway sends something, it crashes

    Here are some interesting posts about that:

    Maybe you should ad this notice to the build-section for the wifi gateway ?

    Best regards


    anhhuy0501 created this issue in esp8266/Arduino

    closed Wrong GPIO number on ESP8266-12 #437

Log in to reply

Suggested Topics