Makefile arduino-mk



  • Hello I've been using the arduino-mk Makefile for my project instead of using the IDE as I generally program using vim anyhow, why fire up the IDE when you can just 'make' and
    'make upload'?

    Anyhow, I'm also interested in this project. But when I combine the two I get errors like:

    fatal error: MySensor.h: No such file or directory
    

    my Makefile is pretty simplistic:

    include /home/george/git/Arduino-Makefile/Arduino.mk
    ARDUINO_LIBS     = SPI MySensors DHT
    

    USER_LIB_PATH is computed to be:

    - [DEFAULT]            USER_LIB_PATH = /home/thoth/sketchbook/libraries
    

    and the MySensors folder is in there:

    ls ~/sketchbook/libraries/MySensors 
    core  drivers  examples  keywords.txt  library.json  library.properties  MyConfig.h  MySensor.h  tests
    

    Is anyone else using the arduino-mk Makefile? And if so any hints as to what might be wrong here?

    note I've tried with latest everything on Archlinux, and using a docker container with debian jessie here:
    https://github.com/joshuacox/mkarduino

    same result in both environments

    *Note in debian I use this include line:

    include /usr/share/arduino/Arduino.mk
    


  • I don't seem to be getting any replies here, so I'm moving to github here:
    https://github.com/mysensors/Arduino/issues/480

    joshuacox created this issue in mysensors/Arduino

    closed Naming conventions #480


 

429
Online

7.9k
Users

8.8k
Topics

93.8k
Posts